Not enough electricity power provided with AP warning ?

  • 2
  • Question
  • Updated 3 months ago
  • Answered
After upgrading to Unleashed 200.8, my PoE switch powered R610 showing "Not enough electricity power" warning ? I am sure my PoE switch can provide both 802.3af and 802.3at power output and my R610 works well with both 2.4Ghz and 5Ghz SSID running. any idea ? 
Photo of George Wang

George Wang

  • 6 Posts
  • 1 Reply Like

Posted 8 months ago

  • 2
Photo of Vesalius


  • 8 Posts
  • 4 Reply Likes
The ethernet cable may be the culprit. If it has Copper Clad aluminum conductors or just smaller gauge copper conductors the ethernet cable may lose a lot of the output power from your switch before it makes its way to the AP, especially if it is a long cable run. Great video below from Lawrence Systems with an engineer that works on the Cat5e,cat6 and Cat8 standards as well as POE. Cat7 is not recognized in the US and that is part of why so many Amazons sellers advertise cheap Cat 7 cables and they often underperform.

Go to the 17:30 minute mark for the POE discussion.
Photo of George Wang

George Wang

  • 6 Posts
  • 0 Reply Likes
Thanks, Vesalius.

The cable is like new and just 10 meters long (AMP Cat. 6 cable). The solution I found is to force the AP running PoE mode from "Auto" to "802.3at PoE" under Unleashed setting. I still don't know why the AP can't detect the best PoE mode itself.
Photo of George Wang

George Wang

  • 6 Posts
  • 1 Reply Like
I just found out the solution that is to force AP PoE operation mode from "Auto" to "802.3at PoE" and reboot AP. I still don't know why the AP can't detect itself. bug? PoE switch compatibility ? Hmm... 
Photo of Karthik

Karthik, Employee

  • 42 Posts
  • 24 Reply Likes
Hi George,

PoE Switches negotiate PoE power after identifying other end devices such as AP, Cameras using LLDP-MED.

if you are using ICX Switches:
By default, LLDP is disabled in ICX 7450 switch. To enable it, the following global command has to be issued:
ICX7450-48P Router(config)#lldp run 

The switch will have to advertise power via LLDP and the following commands have to be issued either for the specific port e.g. port 1/1/5,
ICX7450-48P Router(config-if-e1000-1/1/5)#lldp advertise power-via-mdi ports ethernet 1/1/5

or if all ports have to be configured identically
ICX7450-48P Router(config-if-e1000-1/1/5)#lldp advertise power-via-mdi ports all

Also verify on Ruckus Unleashed AP if LLDP enabled
ruckus# show ap mac

If not enabled
ruckus(config-ap)# lldp enable

Photo of Anton Kuzmin

Anton Kuzmin

  • 20 Posts
  • 1 Reply Like
Same story.
I have several R710 and R610 in my house
My POE+ 802.11at switches are Netgear gs108epp and Zyxel GS1200-8pV2.
Both supports 802.11at, but my ruckus AP connects only at 802.11af with limited perfomance
Q: Is it possible to managed my switch/ruckus to work correctly?
If not -what is the best price recommended switch with 8 ethernet + minimum 2 POE out to work with ruckus?
Photo of Anton Kuzmin

Anton Kuzmin

  • 20 Posts
  • 1 Reply Like
o! I found a solution - just manually set to every AP mode to 802.11at.
The only issue that group policy not working in this case - only one by one...
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 475 Posts
  • 155 Reply Likes
Hi Anton,

You can use the master AP's remote AP CLI feature which will run the same command for all the connected APs (only to the APs which are already connected and online in Unleashed) in once.

ruckus(debug)#remote_ap_cli -A "set power-mode at"

or if you want to run it on specific APs, then use below command

ruckus(debug)#remote_ap_cli -a aa:bb:cc:dd:ee:ff "set power-mode at"

In above command, aa:bb:cc:dd:ee:ff is MAC address of the desired AP where you want to run the command.

Syamantak Omer
Photo of Alfred Barnat

Alfred Barnat

  • 8 Posts
  • 1 Reply Like
Was there ever any additional follow-up to this?

I've had exactly the same problem as well since upgrading to 200.8. I only have a single R720 to test with (along with several H510s, which don't require 802.11at), but I have tested with multiple ports, multiple cables, and two separate Netgear MS510TXPP switches, all with the same result.

The switches autodetect class 4 (802.3at) PoE for all my Ruckus APs, so I can't find anything wrong on that end.

I'll also note that I doubt the workaround provided above is actually doing anything. Yes, if I manually override the PoE setting on the R720 to 802.3at, it will show "802.3at" on the status page, but I also still get the warning about power. I really can't imagine this option allows the AP to draw more power than it believes the switch can provide (which sounds like a great way to damage some hardware) vs. operating in a lower power mode than the current PoE source can support.
Photo of John D

John D, AlphaDog

  • 579 Posts
  • 179 Reply Likes
This seems to be the intended design. Ruckus APs do not respect the static POE class based support for 802.3at. Instead, they expect to be able to negotiate over LLDP with the switch and unless they succeed at that, they assume that the switch is 802.3af. You can force override them to 802.3at or 802.3at+ if you know what you're doing and have a switch that doesn't support this kind of negotiation.
Photo of Michael Brado

Michael Brado, Official Rep

  • 3298 Posts
  • 523 Reply Likes
And spread the APs across your switch ports...
Photo of Philip March

Philip March

  • 11 Posts
  • 5 Reply Likes
I am seeing the same issue on my R710 running off a Cisco RV350p which is PoE+.  Never had this issue until I noticed it this week... shortly after upgrading firmware to  Tried to force 802.3at through ssh commands to R710 but still showing power is at af level.  This is not the only firmware issue I'm seeing with Ruckus products.  Has been my go to for network installs, but I cannot move forward with them until I see more consistent firmware upgrades that don't cause problems.
Photo of Daniel M

Daniel M

  • 64 Posts
  • 13 Reply Likes

Seeing the same issue—port 2 being an R710 and port 3 an R610.  The R710 doesn’t appear to be doing LLDP by default.  What my switch sees is below and this remains unchanged even after enabling lldp on the R710 as noted in another post here.  The switch settings are the same for both ports.

switch(config)# sh lldp info remote-device 2

 LLDP Remote Device Information Detail
switch(config)# sh lldp info remote-device 3
 LLDP Remote Device Information Detail
  Local Port   : 3
  ChassisType  : mac-address
  ChassisId    : ...
  PortType     : mac-address
  PortId       : ...
  SysName      : R610
  System Descr : Ruckus R610 Multimedia Hotzone Wireless AP/SW Version: 20...
  PortDescr    : eth0
  Pvid         :
  System Capabilities Supported  : bridge, wlan-access-point, router
  System Capabilities Enabled    : bridge, wlan-access-point
  Remote Management Address
     Type    : ipv4
     Address : ...
  Poe Plus Information Detail
    Poe Device Type         : Type2 PD
    Power Source            : Only PSE
    Power Priority          : Unknown
    Requested Power Value   : 25.0 Watts
    Actual Power Value      : 25.0 Watts
Photo of Alfred Barnat

Alfred Barnat

  • 8 Posts
  • 1 Reply Like
I've since been able to confirm that this is definitely not tied to the one R720 (which is not surprising, since others are seeing the same issue). This also, unfortunately, does affect an R750 I was able to test with.

As far as I can tell, LLDP (and LLDP-MED) are fully enabled on both the AP and switch. "get lldp" on the AP does indicate everything is enabled there. "get lldp neighbors" does also display the correct information for my switch, though the only entry I see related to PoE is "UPOE: 0". Hopefully the AP is checking for more than just UPoE.

On the switch, LLDP is enabled globally and in "Tx & Rx" mode for all ports (which is the default, and fully enabled). LLDP-MED is also enabled for all ports. Pulling up the information for the port the AP is connected to, though, it doesn't look like the AP is transmitting any MED properties. All MED details are blank ("N/A"), though standard LLDP details are all there and correct.

I'll reiterate that I did try to force the AP to 802.11at, and this appeared to have no effect. Do I need to do something other than changing the setting in the UI? (The CLI setting just seems to follow the UI.)

Considering that this seemed to be working prior to an AP firmware update, this certainly sounds like an issue with the Ruckus firmware. I am currently running the latest firmware from 6/10 (, so no fixes so far on that end.

Photo of Alfred Barnat

Alfred Barnat

  • 8 Posts
  • 1 Reply Like
Also upgraded the firmware on all my Netgear switches just for kicks. No changes there either. LLDP is still definitely working, since I see all the basic details about the APs on the switches, and the PoE switches do classify all my Ruckus devices as class 4 (which means 30W of power should be available), but I still see nothing under the LLDP-MED details for any Ruckus devices. Same as before the update on the APs as well.

It would be really nice to get this resolved.
Photo of Alfred Barnat

Alfred Barnat

  • 8 Posts
  • 1 Reply Like
In the logs I downloaded from the R750 I'm testing, I'm seeing this:
### LLDP Info ###
LLDP state: Enabled
LLDP interval: 30
LLDP holdtime: 120
LLDP mgmt: Enabled
LLDP bond type: Source MAC for LLDP frames on bond slaves: fixed
LLDP poe: Enabled
LLDP power: 25000
LLDP interface:
LLDP on eth0 : Enabled
LLDP on eth1 : Enabled
The switch also says, under LLDP-MED details for the port the AP is on
Capabilities Supported: Capabilities, Network Policy, Location, Extended PSE, Inventory
That same port doesn't show anything under the "MED Details" for the neighbor (i.e. the R750) on that port, though, again, all basic information is there and correct.
Photo of Alfred Barnat

Alfred Barnat

  • 8 Posts
  • 1 Reply Like
I realized I made a slight mistake in the original post. The "get lldp", etc. commands were actually run on an H510. The R750, strangely, has a completely different CLI, and I'm not sure how to retrieve LLDP status, though the information above pulled from the logs does come from the R750.
Photo of Aristotelis Casternopoulos

Aristotelis Casternopoulos

  • 3 Posts
  • 0 Reply Likes
New owner of a couple r610 (flashed to unleashed in gateway mode). Had the same issue with injector. The 1Gbps ruckus one. No issues with the old r500.

Interestingly after a couple minutes the alert went away after i had logged out of the web interface and logged back in.
Can confirm the second wired ethernet jack is working as well. I assume the error will come if I power cycle AP as it came back repeatedly.

Seems to me the handshake is taking a long time