No option to add uplink on dual ports on ICX 7250

  • 1
  • Question
  • Updated 7 months ago
First post. I'm setting up a VLAN. I have 2 ICX-6450-48P switches and an ICX-7250-48P switch. I configured them from the web interface. Please don't flame cuz I don't use the CLI for everything. thanks. On the 6450s on ports 1/2/3 and 1/2/4 I have them configured as dual mode on VLAN 1 and uplink on VLAN 5. Works great. passes both tagged and untagged traffic. Acts like a "trunk" port which is what I want. But on the 7250, I have added those ports as dual  mode on VLAN 1, and tagged the traffic for VLAN 5, but then I don't have the option to add the ports as "uplink ports" for vlan 5. Nothing else seems to be different. Am I missing something super obvious? Ports 1/2/7 and 1/2/8 on the 7250 don't forward the tagged vlan 5 packets it seems. 
Photo of David Moseley

David Moseley

  • 5 Posts
  • 0 Reply Likes
  • like I'm sooooo close...

Posted 7 months ago

  • 1
Photo of Ben

Ben, Employee

  • 52 Posts
  • 9 Reply Likes
I believe that uplink port option is a bit misleading. I think that adds a command that limits mulicast/broadcast on the client side ports and forces everything in that vlan to the uplink port. It can cause issues and isn't needed. The web gui really hasn't been worked on at all since the 7xxx series was released. I wouldn't recommend using it at all. As for what you are doing, you just need the ports to be tagged in the appropriate vlans. If you want to also send untagged at the same time, you need dual mode as well like had mentioned. 
Photo of David Moseley

David Moseley

  • 5 Posts
  • 0 Reply Likes
Thanks for the info, Ben. That's the thing though. You're right. It should work as is with vlan1 set to dual and vlan5 set to tagged. On the 6450s that's how I configured those initially too, but they wouldn't pass the vlan 5 traffic until I set them as uplink. Even my ISP's tech person can't figure it out and he used the CLI and has brocade switches in his data center. Like I said I'm missing something. I'll keep hammering away at it. Thank you. 
Photo of Ben

Ben, Employee

  • 52 Posts
  • 9 Reply Likes
If you could provide 'show run' from the units and the ports being used I would be able to help quite a bit more. It's pretty tough to figure out what is happening from the GUI. 
Photo of David Moseley

David Moseley

  • 5 Posts
  • 0 Reply Likes
7250 Show run
Current configuration:
!
ver 08.0.30hT211
!
stack unit 1
  module 1 icx7250-48p-poe-port-management-module
  module 2 icx7250-sfp-plus-8port-80g-module
!
!
!
!
vlan 1 name DEFAULT-VLAN by port
 spanning-tree rstp
!
vlan 5 name HVAC by port
 tagged ethe 1/2/7 to 1/2/8




6450 Show run
Current configuration:
!
ver 07.4.00bT311
!
stack unit 1
  module 1 icx6450-48p-poe-port-management-module
  module 2 icx6450-sfp-plus-4port-40g-module
!
!
!
!
vlan 1 name DEFAULT-VLAN by port
 other-proto
!
vlan 2 name test by port
!
vlan 5 name HVAC by port
 tagged ethe 1/2/1 to 1/2/4
 uplink-switch ethe 1/2/1 to 1/2/4
Photo of David Moseley

David Moseley

  • 5 Posts
  • 0 Reply Likes
Thanks, Ben. And both 6450s are configured the same way and they pass all traffic between them. Disregard that vlan 2. I was testing on it. 
Photo of Ben

Ben, Employee

  • 52 Posts
  • 9 Reply Likes
I would get rid of the uplink switch command. It will cause you problems:

enable
conf t
vlan 5
no uplink-switch eth 1/2/1 to 1/2/4

It looks like you have vlan 5 tagged between the two switches. So that should work. The clients in those vlans should likely be untagged vlan 5 though. So lets say you have a vlan 5 client on 1/1/1 of the 6450. You would do this:

enable
conf t
vlan 5
untagged eth 1/1/1

That untagged vlan 5 traffic would land on 1/1/1 and then could traverse the link to the 7250 as tagged (converted in switch)
Photo of David Moseley

David Moseley

  • 5 Posts
  • 0 Reply Likes
True, except the only clients I'm configuring are wireless access points which will have SSIDs on vlan 1 and vlan 5, so I have to treat the ports the APs are plugged into as "trunk ports" as well. I'll try removing uplink from the ports and see if that helps. Thank you. 
Photo of Ben

Ben, Employee

  • 52 Posts
  • 9 Reply Likes
Got it. So "trunk" in Cisco terms is 'tagged' in ICX. In Cisco, a trunk port allows tagged traffic from all vlans by default. For ICXs, we tag ports to vlans. It's a little more granular on the ICX side. I believe your config should look like this then:

conf t
vlan 5
tagged eth <port to AP>

interface ethernet <port to AP>
dual-mode (vlan 1 is assumed since it is the default vlan)

In addition, if you are running the default vlan across the switches, you will need to dual mode the appropriate ports between the switches:

conf t
interface ethernet <ports-between-switches>
dual-mode

Hope that helps!