No link activity using SFP modules.

  • 1
  • Question
  • Updated 10 months ago
We are running a new deployed network consisting of ICX-7150-48 and using fiber uplinks.  Currently the modules we have purchased appear to be compatible with the 7150s based on the product support for 1 GB Fiber. 

Fiber Module Model - E1MG-SX-A

Fiber Cable - Multimode LC/LC Duplex Fiber Optic cable 62.5/125

The logs show that the modules were accepted when they were inserted locally in the office, however fiber cables weren't connected from what has been relayed. 

I won't have access to the switches until the technician wakes up in several hours. 

Brocades are somewhat new to our department, is there anything I need to look for configuration wise that would prevent the uplinks from functioning?

Any direction would greatly be appreciated. 

Thank you, 
Corey


Photo of Corey St.John

Corey St.John

  • 3 Posts
  • 1 Reply Like

Posted 10 months ago

  • 1
Photo of Scott Farrand

Scott Farrand

  • 15 Posts
  • 4 Reply Likes
These don't seem to auto-detect that there's a 1GB gbic installed.

If you're running 7150's on both ends of your link, set the port speed/duplex configuration.

e.g.
Interface Ethernet 1/3/1
 speed-duplex 1000-full-master


Photo of Corey St.John

Corey St.John

  • 3 Posts
  • 1 Reply Like
Hello Scott, 

Thank you for the prompt response. 

I'll provide an update once I am able to get remote access to these switches and override auto-detect. 

Photo of NETWizz

NETWizz

  • 213 Posts
  • 67 Reply Likes
No, that should be fine for 62.5/125 fiber as far as I can recall.  I cannot particularly remember there being an "A", but the part number EM1G-SX is very familiar.

If it doesn't link, you may want to flip the fiber around on the LIU/FIU which is often ST or SC.  Sometimes folks get receive to receive and transmit to transmit instead of transmit to receive and receive to transmit.

Other than that, you can do a "show media" or "show media e 1/3/1" or whatever the port number is the device is using.

Another great couple commands are "show run int e 1/3/1"

and

"show int e 1/3/1"


Hope that helps, but it should be fairly straight-forward, which surely means it will take all day, where when you have something complicated to resolve it will end up just working.
(Edited)
Photo of Corey St.John

Corey St.John

  • 3 Posts
  • 1 Reply Like
Hello Scott and NETWizz,

Thank you for the responses and troubleshooting tips.  

Sure enough the solution was to override the auto-negotiation settings. 

Once we hard coded 1000 full on our core switch we had connectivity. 

Appreciate the community!