MS Surface with Windows RT cannot reach the captive portal page.

  • 3
  • Question
  • Updated 4 years ago
I have a lot of people connecting with a MS Surface with Windows RT. Internet Explorer is unable to redirect to the captive portal. I tried to add the url to the trusted websites, but that didn't work. Any suggestions?
Photo of Karel Decloedt

Karel Decloedt

  • 4 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 3
Photo of Rob Coote

Rob Coote

  • 37 Posts
  • 7 Reply Likes
We've had similar issues. Two things to try:

1) Do not use the "app" version of IE, launch IE from the desktop
2) Enable Compatibility Mode

The good news is this is a workaround for Windows 8/RT. The bad news is it's completely broken in Windows 8.1 and IE 11.
Photo of Karel Decloedt

Karel Decloedt

  • 4 Posts
  • 0 Reply Likes
thanks for the reply.
i didn't use the app.
i will try compatibility mode

should i try another browser: firefox, chrome?
Photo of Rob Coote

Rob Coote

  • 37 Posts
  • 7 Reply Likes
Firefox and Chrome should both work.
Photo of Karel Decloedt

Karel Decloedt

  • 4 Posts
  • 0 Reply Likes
doesnt work for IE11 and windows RT 8.1
There is no chrome app available...
Photo of Rob Coote

Rob Coote

  • 37 Posts
  • 7 Reply Likes
That's correct, 8.1 RT has no workaround. You can't get any other browser on RT.
Photo of Andrew Barker

Andrew Barker

  • 7 Posts
  • 0 Reply Likes
Anyone from Ruckus got an answer for this as we have over 90 RT devices that dont work because of this??
Photo of Karel Decloedt

Karel Decloedt

  • 4 Posts
  • 0 Reply Likes
Official Reply over here: https://forums.ruckuswireless.com/ruc...

quote: "... Win 8.1 RT - Nothing to report yet. The workaround is using a separate WLAN with classic PSK. "
Photo of Colin Sevier

Colin Sevier

  • 4 Posts
  • 0 Reply Likes
When is the update coming out.. I seen "in December". This needs to get fixed.. captive portal not working at all..
Also having a problem with users losing authentication after going to sleep on Ipads. Now IOS 7 having issues with ZeroIT.. I'm losing faith in Ruckus FAST. Fix this already.. had to update to the newest firmware to even get IOS devices to be able to hit accept on the guest page. What is going on with the captive portal and authentication methods?I Why is it taking so long to get an update for this?? I know windows 8.1 and IE11 suck, but this is no excuse. What's the hold up??

ZoneDirector 3025 with 22 7372's
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 51 Reply Likes
@Colin, I certainly understand your frustration and I'm sorry for the obvious pressure you are feeling. Some of what you're describing is a result of changes the client vendors have made that we then have to react to as we made design decisions based on the vendors then-current behavior. Our reaction to those changes takes time unfortunately and you're somewhat caught in the middle. There may be a workaround on the IOS issues, so please open a support case.

9.7 is still on track for mid-December, that's the best I can offer (without risking a contract hit on me)
Photo of Andrew Barker

Andrew Barker

  • 7 Posts
  • 0 Reply Likes
Keith is there any date for the release of 9.7?
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 51 Reply Likes
@Andrew, 9.7 was just posted, but I am afraid that Windows RT 8/8.1 is not supported for Zero-IT.
Photo of Colin Sevier

Colin Sevier

  • 4 Posts
  • 0 Reply Likes
I think Microsoft should have stopped at windows 7 and Apple stop at IOS 6.1.4.
Newer is not always better.
Photo of Andrew Barker

Andrew Barker

  • 7 Posts
  • 0 Reply Likes
Keith,

Just tried the 9.7 firmware and had to downgrade, I will explain below.

We have staff wifi and use the hotspot services so they can login.

In our hotspot service page we have the login page which points to a local site with policies and other info which is http://policy/wifi/index.html

And in the walled garden section we have http://policy.wifi/index.html and the ruckus login page https://ruckus.ourdomain.com/user/use...

On 9.6 this all used to work brilliantly now on 9.7 it no longer works, are we doing something really stupid here or has functionality changed?
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 51 Reply Likes
This is a great conversation that's separate from the main topic, so I created a new topic to continue the discussion. Please reference the new topic here: Hotspot problems after 9.7 upgrade
Photo of Gordon Taylor

Gordon Taylor

  • 5 Posts
  • 0 Reply Likes
Has the captive portal with Windows 8.1 RT been fixed in this realse i couldn't see a specific mention to it in the 9.7 Docs?
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 51 Reply Likes
We did correct a bug where the Register Device option caused a re-direct loop for Windows RT 8.1. If that's what people were seeing, then yes 9.7.0 has that fix.
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 51 Reply Likes
As does 9.6.2 which was just released.