MACBook Pro on 10.10.3 disconnects from Wireless and cannot reconnect

  • 2
  • Question
  • Updated 2 years ago
We have a ZD1106 running on 9.8.1.0 build 101. and all the MacBooks in the office running 10.10.3 are having the same problem where they get dropped from Wifi and cannot reconnect.

We are running 802.1X EAP and I am not sure if it is an authentication issue or not, because the wifi icon on the top shows connected, but apps like Skype and Dropbox show no connectivity.

I am not sure if we need to upgrade to a latest version of firmware, and I also do not know how to do this. We have a support in place
Photo of Neill Swart

Neill Swart

  • 3 Posts
  • 0 Reply Likes
  • Frustrated

Posted 2 years ago

  • 2
Photo of Deven Patel

Deven Patel

  • 3 Posts
  • 0 Reply Likes
Hey! 

We have a similar issue with ours as well ZD1106 on 9.6.2.0 build 13. Was looking at upgrading to the latest firmware but seeing as you have the same issue theres no point. 

Let me know how you get on if you have any success with anything. 
Photo of Neill Swart

Neill Swart

  • 3 Posts
  • 0 Reply Likes
We have upgraded to 9.9.1.0 build 31, and a few parameter changes so I am not sure what fixed the issue, but seems resolved. Parameter changes were:
- Setting fixed channel for 2.4 and 5GHz instead of Auto (Under Access Point Config)
- 802.11d Enabled (under WLAN Config for each SSID)
- Radio Resource Management Enable 802.11k Neighbor-list Report (under WLAN Config for each SSID)
Photo of Neill Swart

Neill Swart

  • 3 Posts
  • 0 Reply Likes
Since this change though Apple devices using iOS (Not OSX, like Macbooks) cannot authenticate on the 802.1x EAP, we have had to create a separate WPA2 Authentication for these devices to work around the issue.
Photo of Deven Patel

Deven Patel

  • 3 Posts
  • 0 Reply Likes
Hey Neil!

Thanks for the reply Friday here today won't look at doing any changes today, next week will try out your solution and hopefully it works for us as well :)

Cheers

Deven
Photo of Bill Burns

Bill Burns, AlphaDog

  • 203 Posts
  • 38 Reply Likes
Apple has acknowledged a wifi issue w/ 10.10.3 that matches your problem description.When you can: update your OSX machines to 10.10.4.

I'm not sure this will help but:
I had a similar issue w/ OSX 10.7.5.
The workaround was to force a pre-"N" wifi connection.
The method I used was to put a wep password on a hidden SSID. (not supported by 802.11n and greater)
OSX 10.7.5 machines connecting to that hidden SSID no longer lose their connectivity.
(and because it's hidden, other users are not tempted/distracted by the extra SSID)

I'm told there'a a better way to achieve that pre-"N" effect but I forget what it is.
Photo of Sid Sok

Sid Sok, Official Rep

  • 102 Posts
  • 48 Reply Likes
You can search our knowledge base and look for "How to enable TKIP" for the full article, but you can enable TKIP or as Bill's pointed out use WEP instead, WAP-TKIP is just a bit more secure but either one will disable 11n functionality such as channel bonding or Block-Ack.


********
If legacy clients are unable to connect to WLAN with WebUI encryption WPA-Mixed/Auto, a ZD CLI WLAN configuration command can be used to set WPA/TKIP.

SSH login to the ZoneDirector using a tool such as "Putty" and execute the following set of commands across the ZoneDirector to configure the TKIP based algorithm for the wlan.

ruckus>enable
ruckus#config
ruckus(config)#wlan <Name of the configured wlan/ssid>


Eg:- ruckus(config)#wlan "BG-TKIP"

ruckus(config-wlan)#open wpa passphrase <give your passphrase here> algorithm TKIP

Eg:- ruckus(config-wlan)#open wpa passphrase test1234 algorithm TKIP

ruckus(config-wlan)# exit
ruckus(config)#exit


Once after executing the above command, the WebUI interface will prevent configuring the wlan encryption options. However, still further changes can be made from the command line interface.
********


Sid
Photo of Deven Patel

Deven Patel

  • 3 Posts
  • 0 Reply Likes
Hey!

Sorry for the delay on this we managed to fix our problem here. The issue was we had Channel Fly Enabled it was working great until now I guess environmental factors have changed causing the AP's to switch channels all the time, which caused the laptops to lose their connection to the AP.

So we turned off Channel Fly and enabled Background Scanning. We also rolled out new Ruckus R600 AP's

10.10.4 has helped as well we did the above changes pre 10.10.4 :)