LACP on R710?

  • 1
  • Question
  • Updated 5 months ago
  • Answered
I know the R700 sadly didn't support LACP, but I thought the R710 did?

I followed the instructions that I've seen online:

ruckus(ap-mode)# get power-mode
PoE Configured Mode      : AT
Power Consumption Status : 802.3at Switch/Injector
OK
ruckus(ap-mode)# set bond bond0 add eth0
OK
ruckus(ap-mode)# set bond bond0 add eth1
OK
ruckus(ap-mode)# set bond bond0 xmit-hash 1
OK
ruckus(ap-mode)# set bond bond0 lacp-rate 1
OK

However:

ruckus(ap-mode)# get bond
LACP/Bonding is DISABLED.
OK
ruckus(ap-mode)# get bond bond0
LACP/Bonding is DISABLED.
OK

ruckus(ap-mode)# set bond bond0 enable
Error: parameter error
Usage:
set bond <profile> {options}
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
** <profile>: bond0, ...
** options:
    - enable  : R720 Only to enable LACP Mode
    - disable : R720 Only to disable LACP Mode

So does the R710 not support LACP and ONLY the R720? https://www.ruckuswireless.com/products/access-points/ruckus-indoor/ruckus-r710  seems to imply that it's supported.

My HPe switch says that both ports are in the Trunk, so I'm assuming LACP is working, but it's disturbing that the AP says disabled?

According to https://www.juniper.net/documentation/en_US/release-independent/nce/topics/example/nce152-example-LA... I should be able to "get bond" on the AP, eg, they have:

rkscli: get bond
<bond0>
        Mode:           8023AD
        LACP-rate:      fast
        MII-Mon:        100 (ms)
        Xmit-Hash:      layer3+4
        Slaves:         2
        Slave-0:        eth0, ACTIVE, UP, link-fail-count: 0
        Slave-1:        eth1, ACTIVE, UP, link-fail-count: 0
OK

Both ports are up:

ruckus(ap-mode)# get eth

Port  Interface  802.1X  Logical Link  Physical Link      Label
-----------------------------------------------------------------
0     eth0       None    Up            Up 1000Mbps full   10/100/1000 PoE
1     eth1       None    Up            Up 1000Mbps full   10/100/1000

Note: Read Port#N as N+1, if you are referring this CLI output with AP's "Configure :: Ethernet Ports" UI Page.

Is this a bug or is LACP really not working?

Thanks!
Photo of Dustin Marquess

Dustin Marquess

  • 3 Posts
  • 0 Reply Likes

Posted 6 months ago

  • 1
Photo of Victor Cenac

Victor Cenac

  • 48 Posts
  • 15 Reply Likes
I'm curious about this myself. However, it sounds like you are configuring the ports in a LAG (Link Agregation Group). That works without LACP just fine. LACP is there to prevent a device being connected to two switches by mistake, for example.... and other things like that. So depending on the switch settings, the LAG may work fine, even in the absence of LACP on the device side.
Photo of Dustin Marquess

Dustin Marquess

  • 3 Posts
  • 0 Reply Likes
Actually, no, I really do want LACP...

The HPe switch on the other end is configured for "Dynamic" (LACP) mode.. and it says that both ports are activate in the group, so it sounds like the R710 really is doing LACP.. but it seems strange that the CLI won't even show it...
Photo of Michael Brado

Michael Brado, Official Rep

  • 3004 Posts
  • 424 Reply Likes
We have a knowledge base article 3118 regarding LACP for link aggregation of two Eth ports on 802.11ac APs (ie R710).

https://support.ruckuswireless.com/articles/000003118
You need at least 802.3at PoE+ or a passive PoE injector capable of 20W.
Photo of Dustin Marquess

Dustin Marquess

  • 3 Posts
  • 0 Reply Likes
The unit says that it's getting 802.3at:

Power Consumption Status : 802.3at Switch/Injector

The switch is a HP PoE+ switch...

Tried even forcing:

rkscli: set power-mode atOK
rkscli: get power-mode
PoE Configured Mode      : AT
Power Consumption Status : 802.3at Switch/Injector
OK
rkscli: get bond
LACP/Bonding is DISABLED.
OK

Photo of Israr Ahmed

Israr Ahmed

  • 24 Posts
  • 1 Reply Like
hi , 
Please WhatsApp me on +919985563228
thank you
Photo of Michael Brado

Michael Brado, Official Rep

  • 2955 Posts
  • 414 Reply Likes
Please open a case. It is not appropriate and Ruckus does not endorse for members to "WeChat" or "WhatsApp" or other PC-control type program interaction between unverified persons.  Please open a ticket with our Tech Support, and share your information above, so we can assist you properly.  Thanks!