ip multicast

  • 1
  • Question
  • Updated 7 months ago
  • Acknowledged
  • (Edited)
Hi , 
I'm configuring the multicast on Rukcus Switch for the first time, I used to do that in HP switches.
I used to activate fastleave on Access Switches on HP as bellow :
vlan 8
   no ip igmp fastleave 26,28
   ip igmp forcedfastleave 1-25
   exit
- How can I do that on Ruckus Switches ?
- Also any idea how to configure ports for not seeing each other like I do in HP (filter source-port ... ) ?
- What is the different between "multicast active " and "multicast passive"?
 
Regards


Photo of Mohamed EL HARRAK

Mohamed EL HARRAK

  • 11 Posts
  • 0 Reply Likes

Posted 7 months ago

  • 1
Photo of Jijo Panangat

Jijo Panangat, Employee

  • 113 Posts
  • 39 Reply Likes
Hi Mohamed,

Please refer the multicast guide for config help.

https://support.ruckuswireless.com/documents/2662-fastiron-08-0-90-ga-ip-multicast-configuration-guide

Page no: 40 explains the difference between multicast active and passive modes.



Thanks
Jijo
Photo of Mohamed EL HARRAK

Mohamed EL HARRAK

  • 11 Posts
  • 0 Reply Likes
Thanks for you reply , I have already read that but still not clear for me.
I do have configured pim on core-Switch as multicast active and Access Switches as Muticast active too , is that correct or do I need to configure access swiches as passive ?
- what about fastleave how can I activate it on Ruckus switches ?
Photo of Jijo Panangat

Jijo Panangat, Employee

  • 113 Posts
  • 39 Reply Likes
Hi Mohamed,


Config suggestion cannot be made without proper understanding of your setup. The following explanation should help you to decide where it fits better.

In active mode, a Ruckus device actively sends out IGMP queries to identify multicast groups on the network, and makes entries in the IGMP table based on the group membership reports it receives. Routers in the network generally handle this operation. Use the active IGMP mode only when the device is in a stand-alone Layer 2 Switched network with no external IP multicast router attachments. In this case, enable the active IGMP mode on only one of the devices and leave the other devices configured for passive IGMP mode.

Similarly passive mode is used to forwards reports to the router ports which receive queries.

When a device receives an IGMP V2 leave message, it sends out multiple group-specific queries. If no other client replies within the waiting period, the device stops forwarding traffic. When fast-leave-v2 is configured, and when the device receives a leave message, it immediately stops forwarding to that port. The device does not send group specific-queries. You can config this under the vlan.

If you still need assistance, we would request to open a tac case for reviewing the topology and devices involved before suggesting any changes. 




Thanks




(Edited)
Photo of Israr Ahmed

Israr Ahmed

  • 26 Posts
  • 2 Reply Likes
hi , 
can you say me the model number of the switch to that i can share you the commands to activate the multicasting on the ruckus switches.
Photo of Mohamed EL HARRAK

Mohamed EL HARRAK

  • 11 Posts
  • 0 Reply Likes
hi,
switch model is icx7150-24f-port-management-module --> Layer 3 CS with PIM enabled 
----- CS Configuration -----------
vlan 8 name TVs
 router-interface ve 8

vlan 120 name DTV
 router-interface ve 120
ip multicast-routing
!
router pim
 rp-address 172.16.X.1 Multicast-Range
!
ip access-list standard Multicast-Range
 sequence 10 permit 239.0.0.0 0.255.255.255

 interface ve 8
 ip address 172.16.X.1 255.255.255.0
 ip pim-sparse
!
interface ve 120
 ip address 172.16.XX.254 255.255.255.0
 ip pim-sparse
!
!

----------- ALL Access Switches Configuration ---------------
vlan 8 name TV by port
 tagged ethe 1/2/1 to 1/2/2 ethe 1/3/1 to 1/3/4 
 untagged ethe 1/1/13 to 1/1/24 
 multicast passive

- The configuration is working I've just need to be sure that it's 100% correct and clean , ALSO I need to know in this case how to enable fastleave on ports connected to TVs and disable it on Uplink port like I do in HP switches ?