Incorrect NTP date/time

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I have Ruckus 7372 and it is showing a wrong date / time. I am trying to change the time using ssh and set ntp command however it is not working.


rkscli: get ntp
Device GMT time   : Fri Jun  6 17:18:21 2014
NTP Server        : ntp.ruckuswireless.com
rkscli: set ntp 0.pool.europe.ntp.org 
Usage: set ntp {options}
-> server <name/IP>
-> update, synchronize time now
Photo of Nem Nesic

Nem Nesic

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 2183 Posts
  • 300 Reply Likes
I find a couple Knowledge Base Articles that might apply.  Can you confirm your DNS domain name IP address?

KBA-1967: Not able to configure NTP server thru CLI on the standalone AP using domain name
https://support.ruckuswireless.com/answers/000001967
KBA-3042: Can we change time settings on a standalone AP managed AP to the local time
https://support.ruckuswireless.com/answers/000003042
Photo of Nem Nesic

Nem Nesic

  • 2 Posts
  • 0 Reply Likes
Thanks however, the links take me to purchase a premium support. Does this mean that you cannot help me unless I purchase the support plan?
Photo of Michael Brado

Michael Brado, Official Rep

  • 2183 Posts
  • 300 Reply Likes
Access to Forums, Knowledge Base, Documentation, should not require one, only firmware downloads, but it's recommended for 24x7 tech support/RMA preference/firmware upgrades.  Here is the content of both articles that I hope will be helpful.

Issue:

Not
able to configure NTP server on the stand alone AP while using the
domain name. Works fine when using the IP address of the same NTP
server. Following is the error message which the AP throws.

rkscli: set ntp server ntp1.jst.mfeed.ad.jp 
Bad IP or unable to resolve server name 
Usage: set ntp {options} 
-> server <name/IP> 
-> update, synchronize time now


Solution:

Above
mentioned problem is due to the wrong  DNS IP address configured on the
AP. As the AP is not able to resolve the  DNS name properly, It throws
the following error.

 Bad IP or unable to resolve server name 


Configuring proper DNS IP address on the AP will fix the issue. Find the below example for more details.

rkscli: set ntp server ntp.nict.jp
OK
rkscli:

---

Q:  Can we change time settings on a Standalone AP/ZD managed AP to the local time?

A:  No,
it is not possible to change the time settings on the AP. The time
settings on the AP will always show GMT/UTC time and not the local time.
There is no option to change the time zone. Although if we change the
NTP server, it will still show GMT/UTC time. 

 
If APs are showing proper GMT/UTC time then they are getting proper updates from NTP server.