Include ap Device Name in syslog messages (remote syslog messages) (ap name or ZD name)

  • 1
  • Idea
  • Updated 1 month ago
  • (Edited)
In setting up our many ZDs and APs to log messages to our Syslog server,  i was supprised to find that neither include the "device name" in the syslog messages device sends out.  Thus on the receiving syslog server, its impossible/difficult to figure out which device is sending which messages.

additionally, when you look at the device local syslog messages (via on device support info), it *does* include the device namem under "System Log" (which is at the very bottom).

Please correct me if im wrong or missing somewhere where i can enable this (or modify the Ruckus devices' /etc/syslogd.conf).  I even ran a pkt capture to verify that the raw syslog messages being sent out didnt include device name, and they dont.

Otherwise this is a feature/option ruckus should strongly consider adding asap.
thanks

example (from support info / debug logs):
(the AP device name = r710-UPstairs-RuckusAP

Jul 14 19:36:23 r710-UPstairs-RuckusAP authpriv.notice dropbear[3769]: Deferring to RKS shell to authenticate password.

VS below is what the AP sends out to a syslog server:

Jul 14 19:36:23 dropbear[2440]: Deferring to RKS shell to authenticate password..



btw,
for anyone looking to change the remote syslog level (on an AP from CLi/SSH)

set syslog network 7 

(or run set syslog <press enter> to see different level options)
Photo of Stephen Hall

Stephen Hall

  • 12 Posts
  • 0 Reply Likes

Posted 1 month ago

  • 1

Be the first to post a reply!