ICX7250 Stack Lag group to a 7750 MCT LAG

  • 1
  • Question
  • Updated 2 months ago
We have 2 ICX7250 units stacked and we have 2 7750's in a multi-chassis trunk.  We are trying to connect 2 10GB ports from each 7250 to a 7750 so that we have a full ring.  Currently I can only get a lag group on the 7250's to come up if they are set to static, even then I'm only able to enable the lag from one of the 7250's, if I do enable the ports on both then it appears as if a loop occurs.  If I change the lag to dynamic then it looks like it's up on the 7750 side but it is blocking on the 7250 side.  Below I have posted the 7250 config and one of the 7750 configs (they are identical) to see if anyone has some suggestions.
7250:

ver 08.0.61aT213
!
stack unit 3
  module 1 icx7250-48p-poe-port-management-module
  module 2 icx7250-sfp-plus-8port-80g-module
  default-ports 3/2/5 3/2/7
  stack-trunk 3/2/7 to 3/2/8
  stack-port 3/2/7
stack unit 4
  module 1 icx7250-48p-poe-port-management-module
  module 2 icx7250-sfp-plus-8port-80g-module
  default-ports 4/2/5 4/2/7
  stack-trunk 4/2/5 to 4/2/6
  stack-port 4/2/5
stack enable
stack mac 609c.9f0a.76c8
stack suggested-id 1
!
!
global-stp
!
lag h1 static id 255
 ports ethe 3/2/5 to 3/2/6 ethe 4/2/7 to 4/2/8
!
!
!
vlan 1 name DEFAULT-VLAN by port
!
vlan 5 by port
 tagged lag 255
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
!
vlan 10 name LAN by port
 tagged ethe 3/1/2 to 3/1/7 ethe 3/1/9 to 3/1/48 ethe 3/2/2 ethe 3/2/4 ethe 4/1/1 to 4/1/48 ethe 4/2/1 to 4/2/4 lag 255
 untagged ethe 3/1/8
 router-interface ve 1
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
!
vlan 12 name Cosmo by port
 tagged lag 255
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
!
vlan 13 name DMZ by port
 tagged lag 255
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
!
vlan 14 name Royal by port
 tagged ethe 3/1/25 ethe 3/2/2 ethe 4/2/1 to 4/2/4 lag 255
 untagged ethe 3/1/1
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
!
vlan 15 name West by port
 tagged lag 255
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
!
vlan 16 name Cubana by port
 tagged lag 255
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
!
vlan 17 name Storage by port
 tagged ethe 3/2/4 lag 255
 untagged ethe 3/2/3
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
!
vlan 18 name Ron by port
 tagged lag 255
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
!
vlan 20 name Phone by port
 tagged ethe 3/1/13 ethe 3/1/25 ethe 3/2/2 lag 255
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
!
vlan 30 name brooks by port
 tagged ethe 3/1/13 ethe 3/1/25 ethe 3/2/2 ethe 3/2/4 ethe 4/1/35 lag 255
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
!
vlan 31 name brookst by port
 tagged ethe 3/1/13 ethe 3/1/25 ethe 3/2/2 ethe 3/2/4 ethe 4/1/35 lag 255
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
!
vlan 32 by port
 tagged ethe 3/1/13 ethe 3/1/25 ethe 3/2/2 ethe 3/2/4 ethe 4/1/35 lag 255
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
!
vlan 33 name testinet by port
 tagged ethe 3/1/13 ethe 3/1/25 ethe 3/2/2 ethe 3/2/4 ethe 4/1/35 lag 255
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
!
vlan 50 name Internet by port
 tagged ethe 3/2/1
!
vlan 51 name Comcast1120 by port
 tagged ethe 3/2/1
!
vlan 52 name ComcastAG by port
 tagged ethe 3/2/1
!
vlan 53 name ATTUverse by port
 tagged ethe 3/2/1
!
vlan 54 name "UVerse ATT" by port
 tagged ethe 3/1/25 to 3/1/26 ethe 3/2/1 ethe 4/1/1 to 4/1/2 ethe 4/1/41
 spanning-tree
!
vlan 55 name "Comcast 1120 250" by port
 tagged ethe 3/1/25 to 3/1/26 ethe 3/2/1 ethe 4/1/1 to 4/1/2
!
vlan 69 name mgmt by port
 tagged ethe 3/1/2 to 3/1/7 ethe 3/1/9 to 3/1/48 ethe 3/2/2 ethe 3/2/4 ethe 4/1/1 to 4/1/48 ethe 4/2/1 to 4/2/4 lag 255
!
!
!
!
!
!
!
!
!
!
!
!
!
aaa authentication snmp-server default none
aaa authentication web-server default local
aaa authentication login default local
aaa authentication login privilege-mode
jumbo
ip route 0.0.0.0/0 10.69.1.1
!
no telnet server
!
!
web access-group 1
ssh access-group 1
hitless-failover enable
!
!
!
!
!
!
!
interface ethernet 3/1/1
 port-name Roy
 inline power
 stp-bpdu-guard
!
interface ethernet 3/1/2
 port-name "PTZ"
 dual-mode  10
 inline power
!
!
interface ethernet 3/2/1
 speed-duplex 1000-full
!
interface ethernet 3/2/2
 dual-mode  10
 speed-duplex 1000-full
!
interface ethernet 3/2/4
 dual-mode  10
 speed-duplex 1000-full
!
interface ethernet 4/1/1
 dual-mode  54
!
interface ethernet 4/1/2
 dual-mode  54
!
interface ethernet 4/1/3
 dual-mode  10
 inline power
!
interface ethernet 4/2/1
 dual-mode  10
 speed-duplex 1000-full
!
interface ve 1
 ip address 10.69.1.35 255.255.255.0
!
!
!
ip access-list standard 1
 sequence 10 permit 10.69.1.0 0.0.0.255
 sequence 20 permit 192.168.4.0 0.0.0.255
!
ip access-list standard 2
 sequence 10 permit 10.69.1.0 0.0.0.255
!
!
!
lldp run
!
!
!
!
end


7750:

ver 08.0.70bT203
!
stack unit 1
  module 1 icx7750-48-xgf-port-management-module
  module 2 icx7750-qsfp-6port-qsfp-240g-module
  module 3 icx7750-6q-6port-qsfp-240g-module
!
!
!
!
global-stp
!
store-and-forward
!
lag PfSense1_ALL static id 45
 ports ethe 1/1/45
!
lag PfSense2_ALL static id 46
 ports ethe 1/1/46
!
lag h1 static id 255
 ports ethe 1/1/39 to 1/1/40
!
lag mct static id 256
 ports ethe 1/2/5 ethe 1/2/6
!
!
default-vlan-id 4095
!
vlan 5 by port
 tagged ethe 1/1/13 to 1/1/14 ethe 1/1/19 to 1/1/26 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 10 by port
 tagged ethe 1/1/6 ethe 1/1/13 to 1/1/14 ethe 1/1/19 to 1/1/26 ethe 1/1/33 ethe 1/1/41 to 1/1/42 lag 45 to 46 lag 255 to 256
 router-interface ve 10
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 12 name Cosmo by port
 tagged ethe 1/1/13 to 1/1/14 ethe 1/1/19 to 1/1/26 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 13 name DMZ by port
 tagged ethe 1/1/19 to 1/1/26 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 14 name Royal by port
 tagged ethe 1/1/13 to 1/1/14 ethe 1/1/19 to 1/1/26 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 15 name West by port
 tagged ethe 1/1/13 to 1/1/14 ethe 1/1/19 to 1/1/26 lag 255 to 256
!
vlan 16 name Cubana by port
 tagged ethe 1/1/13 to 1/1/14 ethe 1/1/19 to 1/1/26 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 17 name Storage by port
 tagged ethe 1/1/6 ethe 1/1/13 to 1/1/14 ethe 1/1/19 to 1/1/26 ethe 1/1/42 lag 255 to 256
 untagged ethe 1/1/1 to 1/1/5 ethe 1/1/7 to 1/1/8 ethe 1/1/43 to 1/1/44
 spanning-tree 802-1w
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 18 name Ron by port
 tagged ethe 1/1/13 to 1/1/14 ethe 1/1/19 to 1/1/26 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 20 name Phone by port
 tagged ethe 1/1/13 to 1/1/14 ethe 1/1/19 to 1/1/26 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 30 name brooks by port
 tagged ethe 1/1/13 to 1/1/14 ethe 1/1/19 to 1/1/26 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 31 name brookst by port
 tagged ethe 1/1/13 to 1/1/14 ethe 1/1/19 to 1/1/26 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 32 name steelnet by port
 tagged ethe 1/1/13 to 1/1/14 ethe 1/1/19 to 1/1/26 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 33 name testinet by port
 tagged ethe 1/1/13 to 1/1/14 ethe 1/1/19 to 1/1/26 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 50 name Internet by port
 tagged ethe 1/1/11 to 1/1/12 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 51 name Comcast1120 by port
 tagged ethe 1/1/11 to 1/1/12 lag 45 to 46 lag 255 to 256
 untagged ethe 1/1/47
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 52 name Comcast by port
 tagged ethe 1/1/11 to 1/1/12 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 53 name ATTUverse by port
 tagged ethe 1/1/11 to 1/1/12 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 54 name "UVerse ATT" by port
 tagged ethe 1/1/11 to 1/1/12 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 55 name "Comcast 1120 250" by port
 tagged ethe 1/1/11 to 1/1/12 lag 45 to 46 lag 255 to 256
 spanning-tree 802-1w
 spanning-tree 802-1w lag 45 disable
 spanning-tree 802-1w lag 46 disable
 spanning-tree 802-1w lag 255 disable
 spanning-tree 802-1w lag 256 disable
!
vlan 69 name MGMT by port
 tagged ethe 1/1/6 ethe 1/1/13 to 1/1/14 ethe 1/1/19 to 1/1/26 ethe 1/1/30 ethe 1/1/33 ethe 1/1/41 to 1/1/42 lag 45 to 46 lag 255 to 256
 untagged ethe 1/1/10
!
!
!
!
!
!
vlan 3000 name MCTsession-vlan by port
 tagged lag 256
 router-interface ve 3000
!
vlan 3001 name mct-keep-alive by port
 untagged ethe 1/1/48
!
!
!
vlan 4095 name DEFAULT-VLAN by port
!
!
!
!
!
aaa authentication web-server default local
aaa authentication login default local
aaa authentication login privilege-mode
jumbo
enable user password-masking
hostname Core2_ICX7750-48F
ip route 0.0.0.0/0 10.69.1.254
!
no telnet server
username admin password .....
!
!
!
router vrrp-extended
!
!
!
!
interface ethernet 1/1/10
 speed-duplex 1000-full
!
interface ethernet 1/1/11
 dual-mode  50
 speed-duplex 1000-full
!
interface ethernet 1/1/12
 dual-mode  50
 speed-duplex 1000-full
!
interface ve 10
 port-name "VLAN 10 L3 Interface (LAN)"
 ip address 10.69.1.34 255.255.255.0
 ip vrrp-extended vrid 1
  backup
  advertise backup
  ip-address 10.69.1.253
  short-path-forwarding
  enable
!
interface ve 3000
 ip address 192.168.254.2 255.255.255.252
!
!
!
!
cluster BusStop 1
 rbridge-id 2
 session-vlan 3000
 keep-alive-vlan 3001
 icl BusStop lag 256
 peer 192.168.254.1 rbridge-id 1 icl BusStop
 deploy
 client PfSense1_ALL
  rbridge-id 45
  client-interface lag 45
  deploy
 client PfSense2_ALL
  rbridge-id 46
  client-interface lag 46
  deploy
 client h1
  rbridge-id 255
  client-interface lag 255
  deploy
!
!
lldp tagged-packets process
lldp run
!
!
!
!
!
end

Any ideas would be appreciated!
Thanks.
Photo of Andy Gee

Andy Gee

  • 2 Posts
  • 1 Reply Like

Posted 2 months ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 2430 Posts
  • 335 Reply Likes
Your post got flagged as possible SPAM Andy, maybe you can share only the interfaces/config pertinent to your question (next time pls)?
Photo of Andy Gee

Andy Gee

  • 2 Posts
  • 1 Reply Like
Yes sorry about that.  I got it working though, I had to change the lags on both sides to dynamic instead of static.  We are good to go now.