ICX 7250 Collaboration issue with Lumina SDN controller

  • 1
  • Question
  • Updated 4 months ago
  • Answered

Hello dear Community,
I'd be very thanksful if you could assist me with an issue.​
I would like to connect my Brocade ICX 7250-48 (SW-version: 08.0.80cT213​) to the Lumina Flow Manager (version 7.3.0). 
The SDN controller is already installed and the connection between my laptop and the controller is established too. You can see the output of the Brocade CLI command "show openflow" below:

Openflow is enabled on ports 1/1/1 to 1/1/12 in normal mode (with the CLI command: openflow enable layer23).
They are also untagged in vlan 156.
So here is my senario: i have two hosts (pc1 with the ip address 192.168.1.1/24 and pc2 with the ip address 192.168.1.2/24).
I've created two flows in Lumina Flow Manager, one flow from pc1 to pc2 with the match "input port of pc1" and as action "output port of pc2"
and the second flow i have configured from pc2 to pc1 with the match "input port of pc 2" and as action "output port of pc 1".
In my opinion they could be able to ping each other. but they can't!

So i have two questions:
1) After creating the flows, when i check the configuration of flows on flow manager, their output port was automatically set to "SDN controller", but why? (because of this they are not able to ping each other)
2) Why hosts are not detected automatically by the SDN controller? (I mean i can not see pc1 and pc2 on the topology view of the SDN controller, but i can see the Brocade switch)

You can see also the output of Brocade CLI command "show openflow flow" below.





I would be very greateful , if you could help me with this.

Best regards,

Mohammad


Photo of Mohammad Babaee

Mohammad Babaee

  • 1 Post
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Nadir Shah

Nadir Shah

  • 9 Posts
  • 0 Reply Likes
Hello Mohammad,
I have ICX 7250-24 switch and ODL oxygen version. I have connected the ethernet interface 1/1/1 to the  ODL controller. the controlling is running. I have enabled the openflow ofv130 and have connected with controller using no ssl in Config mod. Then I enabled openflow layer23 on ethernet interface 1/1/1.  However, the switch is not getting connected with the controller. When I disabled openflow and assigned ip address to 1/1/1 ethernet interface, then the controller is pinged. However, it is necessary that the ip address should not be assigned to ethernet interface 1/1/1 if we want to enable the openflow. When the ip address is not assigned to the ethernet interface 1/1/1, then the switch cannot ping the controller. Can you help me in this regard?
thanks!
Nadir

Photo of Vu Pham

Vu Pham, Employee

  • 14 Posts
  • 12 Reply Likes
Hi Mohammad - I believe we'll need bidirectional flows from port 1/1/1 to 1/1/2, then from 1/1/2 to 1/1/1 for each type of traffic. Additionally, we'll also need to allow ARP traffic to pass both way as well. With out ARP getting resolved, IP host to host traffic won't work. ARP is ethertype=0x0806, while regular IPv4 traffic (ethertype=0x800), so permit IP any any will not allow ARP.

Thanks,

Vu