ICX 7150: Not letting me create a Router-Interface

  • 1
  • Question
  • Updated 5 months ago
  • Answered
HELP!!!

I've been trying to create a vlan with its own dhcp server, however for some reason my switch is not letting me create a router-interface. I do have the dhcp pool ready for it, though.

below is code:
ICX7150-C12 Switch(config)#vlan 30

ICX7150-C12 Switch(config-vlan-30)#tagged e 1/1/3
Added tagged port(s) ethe 1/1/3 to port-vlan 30.

ICX7150-C12 Switch(config-vlan-30)#tagged e 1/1/4
Added tagged port(s) ethe 1/1/4 to port-vlan 30.

ICX7150-C12 Switch(config-vlan-30)#untagged e 1/1/5
Added untagged port(s) ethe 1/1/5 to port-vlan 30.

ICX7150-C12 Switch(config-vlan-30)#router-interface ve 30
Invalid input -> router-interface ve 30
Type ? for a list

ICX7150-C12 Switch(config-vlan-30)#exit

ICX7150-C12 Switch(config)#show run
Current configuration:
!
ver 08.0.70cT211
!
stack unit 1
  module 1 icx7150-c12-poe-port-management-module
  module 2 icx7150-2-copper-port-2g-module
  module 3 icx7150-2-sfp-plus-port-20g-module
!
!
!
!
vlan 1 name DEFAULT-VLAN by port
!
vlan 30 by port
 tagged ethe 1/1/3 to 1/1/4
 untagged ethe 1/1/5
!
!
!
!
!
!
!
!
!
!
!
!
!
aaa authentication web-server default local
aaa authentication login default local
dhcp-gateway-list 10 192.168.30.1
ip address 192.168.1.90 255.255.255.0
no ip dhcp-client enable
ip dhcp-server enable
!
ip dhcp-server pool testvlan30
 excluded-address 192.168.30.1
 lease 1 0 0
 network 192.168.30.0 255.255.255.0
 option  3 ip 192.168.30.1
 deploy
!
!
username telepro password .....
username user password .....
username ruckus password .....
username admin password .....
!
!
interface ethernet 1/3/1
 speed-duplex 1000-full
!
interface ethernet 1/3/2
 speed-duplex 1000-full
!
!
!
!
!
!
!
!
!
end

Photo of Jose Quiroz

Jose Quiroz

  • 8 Posts
  • 1 Reply Like

Posted 10 months ago

  • 1
Photo of Alex Shalima

Alex Shalima

  • 60 Posts
  • 33 Reply Likes
Hi Jose,

1. Is your switch in Layer 3 mode? (using router image, instead of switch)

Do this:

show flash
show boot

Make sure that the image it is booting to has a letter R in it.


2. If not, do the below:

Usually, the secondary image on switches is the Router image. To make it boot to secondary permanently do this:

conf t
boot system flash secondary
write memory
reload
y


Happy routing :)

Cheers,
Alex



Photo of Jose Quiroz

Jose Quiroz

  • 8 Posts
  • 1 Reply Like
It worked but now i dont have any internet in that vlan :/
I set vlan 30 with ports 6-12.
but i have my internet connected to port 1, the default vlan.

how can i send internet to vlan 30 while still handing out IP's in the 30 subnet?
(Edited)
Photo of Josue Jimenez (C)

Josue Jimenez (C), Employee

  • 5 Posts
  • 5 Reply Likes
I would try a ip route to the default gateway, 
device(config)# ip route 0.0.0.0/0 x.x.x.x

This link can help you out: http://docs.ruckuswireless.com/fastiron/08.0.70/fastiron-08070-commandref/GUID-2E5545F8-42DD-476B-A0...
Photo of Jijo Panangat

Jijo Panangat, Employee

  • 137 Posts
  • 42 Reply Likes
Try adding a route for vlan 30 subnet to reach the gateway.

 ip route 192.168.30.0 255.255.255.0 <default gw ip>
Photo of Jose Quiroz

Jose Quiroz

  • 8 Posts
  • 1 Reply Like
still no internet. when i connect my laptop straight to the internet source i get:

IP: 192.168.1.25
Sub: 255.255.255.0
GW: 192.168.1.254
DHCP Server: 192.168.1.249

so i tried:
ip route 192.168.30.0 255.255.255.0 192.168.1.254

but still no internet for some reason...

note: i also tried: ip route 0.0.0.0/0 192.168.1.254
Photo of Rajiv Widyaratne

Rajiv Widyaratne

  • 1 Post
  • 0 Reply Likes
Just what I was looking for. Thank you!