ICX 7150: Not letting me create a Router-Interface

  • 1
  • Question
  • Updated 4 weeks ago
  • Answered
HELP!!!

I've been trying to create a vlan with its own dhcp server, however for some reason my switch is not letting me create a router-interface. I do have the dhcp pool ready for it, though.

below is code:
ICX7150-C12 Switch(config)#vlan 30

ICX7150-C12 Switch(config-vlan-30)#tagged e 1/1/3
Added tagged port(s) ethe 1/1/3 to port-vlan 30.

ICX7150-C12 Switch(config-vlan-30)#tagged e 1/1/4
Added tagged port(s) ethe 1/1/4 to port-vlan 30.

ICX7150-C12 Switch(config-vlan-30)#untagged e 1/1/5
Added untagged port(s) ethe 1/1/5 to port-vlan 30.

ICX7150-C12 Switch(config-vlan-30)#router-interface ve 30
Invalid input -> router-interface ve 30
Type ? for a list

ICX7150-C12 Switch(config-vlan-30)#exit

ICX7150-C12 Switch(config)#show run
Current configuration:
!
ver 08.0.70cT211
!
stack unit 1
  module 1 icx7150-c12-poe-port-management-module
  module 2 icx7150-2-copper-port-2g-module
  module 3 icx7150-2-sfp-plus-port-20g-module
!
!
!
!
vlan 1 name DEFAULT-VLAN by port
!
vlan 30 by port
 tagged ethe 1/1/3 to 1/1/4
 untagged ethe 1/1/5
!
!
!
!
!
!
!
!
!
!
!
!
!
aaa authentication web-server default local
aaa authentication login default local
dhcp-gateway-list 10 192.168.30.1
ip address 192.168.1.90 255.255.255.0
no ip dhcp-client enable
ip dhcp-server enable
!
ip dhcp-server pool testvlan30
 excluded-address 192.168.30.1
 lease 1 0 0
 network 192.168.30.0 255.255.255.0
 option  3 ip 192.168.30.1
 deploy
!
!
username telepro password .....
username user password .....
username ruckus password .....
username admin password .....
!
!
interface ethernet 1/3/1
 speed-duplex 1000-full
!
interface ethernet 1/3/2
 speed-duplex 1000-full
!
!
!
!
!
!
!
!
!
end

Photo of Jose Quiroz

Jose Quiroz

  • 8 Posts
  • 1 Reply Like

Posted 6 months ago

  • 1
Photo of Josue Jimenez (C)

Josue Jimenez (C), Employee

  • 4 Posts
  • 4 Reply Likes
Hi, you may be probably running switching code, you need to run routing code, the routing code may look like this: SPR08061c, "R" for routing.
Photo of Alex Shalima

Alex Shalima

  • 59 Posts
  • 30 Reply Likes
Hi Jose,

1. Is your switch in Layer 3 mode? (using router image, instead of switch)

Do this:

show flash
show boot

Make sure that the image it is booting to has a letter R in it.


2. If not, do the below:

Usually, the secondary image on switches is the Router image. To make it boot to secondary permanently do this:

conf t
boot system flash secondary
write memory
reload
y


Happy routing :)

Cheers,
Alex



Photo of Jose Quiroz

Jose Quiroz

  • 8 Posts
  • 1 Reply Like
It worked but now i dont have any internet in that vlan :/
I set vlan 30 with ports 6-12.
but i have my internet connected to port 1, the default vlan.

how can i send internet to vlan 30 while still handing out IP's in the 30 subnet?
(Edited)
Photo of Josue Jimenez (C)

Josue Jimenez (C), Employee

  • 4 Posts
  • 4 Reply Likes
I would try a ip route to the default gateway, 
device(config)# ip route 0.0.0.0/0 x.x.x.x

This link can help you out: http://docs.ruckuswireless.com/fastiron/08.0.70/fastiron-08070-commandref/GUID-2E5545F8-42DD-476B-A0...
Photo of Jijo Panangat

Jijo Panangat, Employee

  • 98 Posts
  • 35 Reply Likes
Try adding a route for vlan 30 subnet to reach the gateway.

 ip route 192.168.30.0 255.255.255.0 <default gw ip>
Photo of Jose Quiroz

Jose Quiroz

  • 8 Posts
  • 1 Reply Like
still no internet. when i connect my laptop straight to the internet source i get:

IP: 192.168.1.25
Sub: 255.255.255.0
GW: 192.168.1.254
DHCP Server: 192.168.1.249

so i tried:
ip route 192.168.30.0 255.255.255.0 192.168.1.254

but still no internet for some reason...

note: i also tried: ip route 0.0.0.0/0 192.168.1.254
Photo of Rajiv Widyaratne

Rajiv Widyaratne

  • 1 Post
  • 0 Reply Likes
Just what I was looking for. Thank you!


Photo of Jon Maiman

Jon Maiman, Employee

  • 14 Posts
  • 5 Reply Likes
Please capture the output from the following commands and post it to the thread:

Skip
Show run
Show Version
Show Ip Int
Show Ip Route
page

Best guess without more information is you don't have a "WAN" IP address for the port connected to the Internet.   Since the ICX7150 is running router code, you need to be able to route up to the Internet.   Second guess is your Upstream Internet Router doesn't have routes back to your ICX7150 for the locally hosted subnets you created.   The output from the above commands should help isolate the problem.

--Jon

Photo of Jose Quiroz

Jose Quiroz

  • 8 Posts
  • 1 Reply Like
please see below:

ICX7150-C12 Router(config)#skip
Invalid input -> skip
Type ? for a list



ICX7150-C12 Router(config)#show run
Current configuration:
!
ver 08.0.70cT213
!
stack unit 1
  module 1 icx7150-c12-poe-port-management-module
  module 2 icx7150-2-copper-port-2g-module
  module 3 icx7150-2-sfp-plus-port-20g-module
!
!
global-stp
!
!
!
vlan 1 name DEFAULT-VLAN by port
!
vlan 2 name IP-Subnet_10.1.2.0/24 by port
!
vlan 30 by port
 untagged ethe 1/1/6 to 1/1/12
 router-interface ve 30
!
!
!
!
!
!
!
!
!
!
!
!
!
aaa authentication web-server default local
aaa authentication login default local
boot sys fl sec
ip dhcp-server enable
!
ip dhcp-server pool testvlan30
 excluded-address 192.168.30.1
 lease 1 0 0
 network 192.168.30.0 255.255.255.0
 option  3 ip 192.168.30.1
 deploy
!
ip route 192.168.30.0/24 192.168.1.254
!
username telepro password .....
username user password .....
username ruckus password .....
username admin password .....
!
!
!
!
!
!
!
!
!
interface ethernet 1/3/1
 speed-duplex 1000-full
!
interface ethernet 1/3/2
 speed-duplex 1000-full
!
interface ve 30
 ip address 192.168.30.1 255.255.255.0
!
!
!
!
!
!
!
!
!
!
end



ICX7150-C12 Router(config)#Show Version
  Copyright (c) 2017 Ruckus Wireless, Inc. All rights reserved.
    UNIT 1: compiled on Aug 30 2018 at 04:48:29 labeled as SPR08070c
      (29437672 bytes) from Secondary SPR08070c.bin
        SW: Version 08.0.70cT213
      Compressed Boot-Monitor Image size = 786944, Version:10.1.13T225 (mnz10113)
       Compiled on Tue Jul 24 10:23:08 2018

  HW: Stackable ICX7150-C12-POE
==========================================================================
UNIT 1: SL 1: ICX7150-C12-2X1G POE 12-port Management Module
      Serial  #:FEK3811Q1WN
      Current License: 2X1G
      P-ASIC  0: type B160, rev 11  Chip BCM56160_B0
==========================================================================
UNIT 1: SL 2: ICX7150-2X1GC 2-port 2G Module
==========================================================================
UNIT 1: SL 3: ICX7150-2X10GF 2-port 20G Module
==========================================================================
 1000 MHz ARM processor ARMv7 88 MHz bus
 8192 KB boot flash memory
 2048 MB code flash memory
 1024 MB DRAM
STACKID 1  system uptime is 38 minute(s) 25 second(s)
The system started at 00:01:54 GMT+00 Sat Jan 01 2000

The system : started=cold start



ICX7150-C12 Router(config)#Show Ip Int
Interface           IP-Address      OK?  Method    Status             Protocol   VRF
Ve 30               192.168.30.1    YES  NVRAM     up                 up         default-vrf



ICX7150-C12 Router(config)#Show Ip Route
Total number of IP routes: 1
Type Codes - B:BGP D:Connected O:OSPF R:RIP S:Static; Cost - Dist/Metric
BGP  Codes - i:iBGP e:eBGP
OSPF Codes - i:Inter Area 1:External Type 1 2:External Type 2
        Destination        Gateway         Port          Cost          Type Uptime
1       192.168.30.0/24    DIRECT          ve 30         0/0           D    39m7s



ICX7150-C12 Router(config)#page
Invalid input -> page
Type ? for a list
Photo of Jon Maiman

Jon Maiman, Employee

  • 14 Posts
  • 5 Reply Likes
As I suspected, you don't have a "WAN" IP Address to your upstream Internet Router.    From when you connected your laptop to the Internet directly, your IP Subnet for the Internet is 192.168.1.0/24 and your gateway (next hop) is 192.168.1.254.    You can create a VE in VLAN 1 (the default VLAN) and have it get an address via DHCP.   The config. would be approx.:

vlan 1
router-interface ve 1

interface ve 1
ip dhcp-client

You will still need the default route to the internet:

ip route 0.0.0.0/0 192.168.1.254

However, this only fixes the problem in one direction (sending traffic upstream to the Internet).   You will need a route on your Internet Gateway pointing to your ICX switch for the 192.168.30.0/24 network for downstream traffic.

This begs the question, if you only plan on having one IP Subnet 192.168.30.0 on your ICX Switch, why are you running router code?   Wouldn't it be simpler to just use your switch as layer 2 only and configure your Internet Gateway to handout addresses in the 192.168.30.0 subnet for clients?   Since the Internet Traffic will be NAT'ed anyway, you really could just leave the DHCP clients be assigned in the 192.168.1.0 subnet your Internet Gateway is already configured for.

--Jon
(Edited)
Photo of Jose Quiroz

Jose Quiroz

  • 8 Posts
  • 1 Reply Like
Need to get myself more familiar with these ICX products.

We will be installing a new ICX 48 port in an office that will require several vlans where only some are allowed internet access. And we wanted everything to be driven by the ICX switches.

Either case, I still haven't gotten vlan 30 to work correctly.

Does ruckus offer some sort of remote support or training?
Photo of Jon Maiman

Jon Maiman, Employee

  • 14 Posts
  • 5 Reply Likes
Jose,

   Where are you located?   Your best bet is probably to engage a Ruckus Channel Partner in your area for assistance (at least with your initial configuration and testing).

--Jon

Photo of Jose Quiroz

Jose Quiroz

  • 8 Posts
  • 1 Reply Like
We are located in South Texas.
Photo of Chase Holland

Chase Holland, Employee

  • 2 Posts
  • 0 Reply Likes
Jose,

Where in South TX are you located?  Want to see if we can have an SE give you a call and talk through your questions.

Thank you,

Chase
Photo of Jose Quiroz

Jose Quiroz

  • 8 Posts
  • 1 Reply Like
Mission, Texas. Sure! That would help a lot.
Photo of Chase Holland

Chase Holland, Employee

  • 2 Posts
  • 0 Reply Likes
Jose,  Your fastest ability for support with an ICX expert would be to open a quick TAC case and ask for a 15 minute screen share webinar with a support engineer to walk through the setup of that routed interface (and maybe upgrade the code to L3 code if needed).  If that doesn't work, I can get one of our sales engineers to give you a call, but it might be a couple of days.  Just let me know!
Photo of Jijo Panangat

Jijo Panangat, Employee

  • 102 Posts
  • 35 Reply Likes
Hi Jose,

You can also open a TAC case with us for remote assistance, If you think that should solve the problem.


Thanks
Jijo