How do I prevent a computer for changing associated AP

  • 1
  • Question
  • Updated 4 years ago
I have 7 Lenovo AIO computers running Windows 8.1 with Intel Centrino 2230 wireless adapters. These units are public facing running a program that connects to a SQL database. If the connection to the database is interrupted, the program crashes. The units are within range of 2 different AP and every time they switch AP, the connection is interrupted. I set the WLAN to tunnel but this didn't help. I tried to use the Intel ProSet software to use a mandatory AP by MAC address but when I enter the MAC address of the AP, it can no longer connect to that AP. I have ZF7363 with a ZD1100 running 9.6.0.0.267. Any thoughts about settings to prevent the loss of connection to the DB?
Photo of Chris Wanner

Chris Wanner

  • 3 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 51 Reply Likes
Can you give them their own dedicated (maybe hidden) SSID on that AP?

--
-create a WLAN Group with all the WLAN's checked that need to be broadcast.

-under the configure >> access points > select the AP and click on edit and select WLAN Group -- override system default and select the Wlan group created earlier under Radio b/g/n and for a/n
--
[from a soon to be posted KB article)
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 51 Reply Likes
BTW - each WLAN has it's own derived MAC address so the system MAC (which I think you used) would have looked like an invalid match to your Intel card. This will help you poke at what it actually is (from ZD CLI):

ruckus(config-wlan)# called-station-id-type [wlan-bssid | ap-mac]
wlan-bssid Set the called station ID type to ‘BSSID:SSID’
ap-mac Set the called station ID type to ‘APMAC:SSID’
Photo of Chris Wanner

Chris Wanner

  • 3 Posts
  • 0 Reply Likes
Keith,

Thanks for the help. I have a separate WLAN for them but it doesn't prevent it from changing AP. As far as I know, I can't create a WLAN that picks and chooses with AP is part of that group. If I can, then that makes life much easier.

For the MAC address of the AP, I did see that each WLAN gets a separate MAC so I did use the MAC for that specific AP. What I am trying to make work is for the computer to associate only with 1 AP specifically and not any of the 3 that it sees.

Since I am using the web interface for the ZD, let me know if this is right.
Under Monitor/Currently Managed APs, the AP I want is this.

c4:01:7c:0e:f3:30 RuckusKidsDesk2 Above Kids Desk 2 outside main office zf7363 Connected (Root AP)

For the WLAN
BSSID Check-in/CBCKids c4:01:7c:4e:f3:39 802.11g/n Up

If I use the BSSID as the mandatory AP, won't that still allow the computer to switch AP?
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 51 Reply Likes
What I'm suggesting is you create an SSID and apply it specifically to the AP you want those clients to connect to. Here's an older thread describing the technique: https://support.ruckuswireless.com/answers/forums/8/topics/930 
Photo of Chris Wanner

Chris Wanner

  • 3 Posts
  • 0 Reply Likes
Thanks. That is what I have been working on. I was waiting until my test was done today to see if I got the settings right and so far, it is working very well.