How to put ZF R710 in 802.3at PoE+ Mode?

  • 2
  • Question
  • Updated 3 years ago
  • Answered
Hi, I have an issue where I am unable to put my new ZF R710 into 802.3at PoE+ Mode.  Currently, I have a new POE+ switch that I'm using which is the Linksys LGS308P. It has LLDP enabled on the switch end. Note, my ZF R710 is in standalone mode.  Is there any other configuration that I need to do either on the Linksys LGS308P or ZF R710 so I can out it into   802.3at PoE+ Mode?
Photo of hayk

hayk

  • 20 Posts
  • 3 Reply Likes

Posted 4 years ago

  • 2
Photo of Michael Brado

Michael Brado, Official Rep

  • 2921 Posts
  • 406 Reply Likes
KBA-5005 has the following information, including two CLI commands for the AP, if your switches have LACP/LLDP enabled.



Root Cause

LLDP
and LLDP power over MDI should be enabled on the POE+ switch in order
for 802.3at power to be negotiated between the R710 and POE+ switch.

Troubleshooting Steps

Use rkscli command "get power-mode" to check input power consumption status.
rkscli: get power-mode
PoE Configured Mode      : Auto
Power Consumption Status : 802.3at PoE+
OK
 
"PoE Configured Mode" should be "Auto" not "AF".
When PoE+ switch with LLDP power via MDI support is connected, the " Power Consumption Status" will be "802.3at PoE+".
 
Here are options for " Power Consumption Status".
    { "Unknown"      },
    { "DC"           },
    { "802.3at PoE+" },
    { "PoE Injector" },
    { "802.3af PoE"  },


Workaround


Resolution

There are 3 requirements for the R710s to negotiate 802.3at power between itself and the POE+ switch,
two of them are on the POE+ switches and one on the Ruckus R710-:

1. LLDP must be enabled on the POE+ switches.

2. LLDP Power via MDI must be enabled on the POE+ switches.
The command to enable LLDP and LLDP power via MDI will vary depending on the make of the switch.

3.
LLDP and LLDP POE setting must be enabled on the R710s. R710s received
with 100.2.0.0.336 have both LLDP and LLDP POE setting ENABLED by
default.

However, R710s received with firmware prior to 100.2.0.0.336 DON'T have LLDP and LLDP POE setting enabled by default.
These settings WON'T be enabled even after upgrading to 100.2.0.0.336 or RuckOS 3.1.1.x.x or later.

So
if R710s received with firmware prior to 100.2.0.0.336, then later
upgraded to 100.2.0.0.336 or 3.1.1.x.x, still need to have LLDP and LLDP
POE enabled.
This can be done via CLI on the R710.

rkscli: set lldp enable
rkscli: set lldp poe enable

You can do a get lldp to make sure the ap took the two config changes.

rkscli: get lldp
LLDP state: Enabled
LLDP interval: 30
LLDP holdtime: 120
LLDP mgmt: Enabled
LLDP poe: Enabled
LLDP power: 25000
LLDP interface:
LLDP on eth0 : Enabled
LLDP on eth1 : Enabled
OK

PS: Negotiation may take up to 2 minutes after system is up.
---

Customers report success after following this example on Juniper switches:
https://www.juniper.net/techpubs/en_US/release-independent/nce/information-products/pathway-pages/nce/nce-152-LAG-Ruckus-configuring.pdf
Photo of hayk

hayk

  • 20 Posts
  • 3 Reply Likes
Hey Michael, with all the trouble that's been reported with getting the R710 into AT power mode, do you think Ruckus Marketing can change the Datasheet of the R710  stating that to put it into AT Mode requires LLDP via MDI Support on the switch.  The Datasheet is very miss leading thinking if you have a POE+ switch that it would work in AT Mode, This is my biggest complaint.  This would prevent people from getting the wrong hardware in the first place. 
Photo of Austin Wahl

Austin Wahl

  • 6 Posts
  • 0 Reply Likes
oddly enough I cannot get this AP to negotiate in poe+ after rebooting the ap the lldp settings go back to disabled and need to be re-enabled.

they are on v 9.12 controlled by a zd 1200 switch is a sg300-28pp, all settings look good for lldp and they are Lagged on the switch.
(Edited)
Photo of Mike Loiterman

Mike Loiterman

  • 4 Posts
  • 9 Reply Likes
I have the same issue.  Settings do not survive a reboot.
Photo of Austin Wahl

Austin Wahl

  • 6 Posts
  • 0 Reply Likes
Have to do it via cli on your zone director. Config into the default group and enable lldp and then you are good. Besides that still cannot get it to use poe+ from my switch. Settings all look good though. Had ruckus look yesterday
Photo of Michael Harris

Michael Harris

  • 2 Posts
  • 0 Reply Likes
I have heard today that there is a Command for the R710 that will FORCE 802.3at negotiation with the switch.  I'm using SG300's also
Photo of Austin Wahl

Austin Wahl

  • 6 Posts
  • 0 Reply Likes
Any info on this, i went back and forth between ruckus and cisco, switch sees it as class 4 but will not go into at mode. Finally gave up on it, the only commands i saw were auto or af.
(Edited)
Photo of Itech Las Vegas

Itech Las Vegas

  • 14 Posts
  • 0 Reply Likes

rkscli: set power-mode at

is what my SE told me was the command

support said the feature wasn't available

does it work for you

I haven't tested yet

Photo of Lukas

Lukas

  • 24 Posts
  • 4 Reply Likes
Command works (with a warning), but AP is still stuck with af-mode. Also using a Cisco SG-300. It seems that there is some incompatibility.

Update: now it says: injector mode. Does this mean, that the AP switched to AT-mode?
(Edited)
Photo of Itech Las Vegas

Itech Las Vegas

  • 14 Posts
  • 0 Reply Likes
lukas is your switch a pp switch meaning Poe-Plus version?
(Edited)
Photo of Itech Las Vegas

Itech Las Vegas

  • 14 Posts
  • 0 Reply Likes
lukas how much poe wattage is being consumed on the port in your switch?
(Edited)
Photo of John D

John D, AlphaDog

  • 513 Posts
  • 144 Reply Likes
I had the same results with the command (a few minutes later it went into Injector mode). My POE+ switch claims that the AP is consuming 4-5W when the R600 consumes about 3W, which would suggest that it's working.
Photo of Lukas

Lukas

  • 24 Posts
  • 4 Reply Likes
Yes, same for me, BUT I have another R710 without this command connected and this AP is also consuming 4-5W. For both APs the switch reports an AT-compatible POE device so there is no difference. Any other idea? I have different switch models, which all don't work: SG300-28PP, SG-300-10PP, SG300-10MPP
(Edited)
Photo of Itech Las Vegas

Itech Las Vegas

  • 14 Posts
  • 0 Reply Likes

i would think it would consume a lot more than 4-5watts when in AT mode

does anyone have it working in AT mode?

when we tried on ours  the parameter wasn't available

we are running build 9.12.2.0 build 101

This is the output of the command:

rkscli: set power-mode at

Error: parameter error

Usage: set power-mode {auto|af}

what firmware are you running?

 

Photo of Michael Brado

Michael Brado, Official Rep

  • 2864 Posts
  • 399 Reply Likes
Considering that SCG-300 is Cisco's lowest end consumer switch, does it even support LLDP...?  (Requirement #1 from KBA-5005)
Photo of Itech Las Vegas

Itech Las Vegas

  • 14 Posts
  • 0 Reply Likes

it does but apparently they forgot to add the TLV power via mdi parameter to it

Photo of Itech Las Vegas

Itech Las Vegas

  • 14 Posts
  • 0 Reply Likes

does Injector Mode cause the limitations of  only 2 streams in 5ghz?


Photo of Itech Las Vegas

Itech Las Vegas

  • 14 Posts
  • 0 Reply Likes

does Injector Mode cause the limitations of  only 2 streams in 5ghz?


Photo of John D

John D, AlphaDog

  • 513 Posts
  • 144 Reply Likes
I wasn't aware that the R710 ever decreased 5GHz capability. It seems like in AF mode, the 4th SS on 2.4GHz is disabled and 2.4GHz transmit power is lowered by 4dBm.
Photo of Itech Las Vegas

Itech Las Vegas

  • 14 Posts
  • 0 Reply Likes

you are correct I was misinformed

does injector mode work with these limitations as well?

(Edited)
Photo of Lukas

Lukas

  • 24 Posts
  • 4 Reply Likes
For me it seems, that those Cisco SG Switches basicially support LLDP with those TVL settings, but something goes wrong during the transmission. If you navigate at the switch's webinterface to Administration -> Discovery -> LLDP Port Status you can find the POE values, which the switch sends and recieves from the specific port. For some reason the remote values are not available. 
If you naviate to LLDP Med Port Setting, select a port and click "Edit..." you can specifiy the TLVs available for each port. There is a "POE-PSE" TVL which indicates to me that the swich should be able to announce his at-capability to the AP.
(Edited)
Photo of Lukas

Lukas

  • 24 Posts
  • 4 Reply Likes
Additional question: why are some posts missing? Especially about the "set power-mode at" command?
(Edited)
Photo of Itech Las Vegas

Itech Las Vegas

  • 14 Posts
  • 0 Reply Likes
Yes i ensbled those lldp settings as well however from everything ive read thru the lldp-med POE-PSE is used for 802.3af finer control of power usage and power via mdi tlv is used 802.3at for negotiation into the the standard. This is exactly where you should find the power via mdi tlv however its missing
(Edited)
Photo of Lukas

Lukas

  • 24 Posts
  • 4 Reply Likes
Ah, I thought those two tlvs were the same. So the switch is not fully POE+ capable (maybe someone should ask cisco, if they could add this tlv)? Is it possible to automaticially run a script, which executes the "set power-mode at" command on all R710/make this option available in the webIF?
Photo of Itech Las Vegas

Itech Las Vegas

  • 14 Posts
  • 0 Reply Likes
ive already had my ticket escalated with cisco and they are looking at filing a bug report and getting a firmware fix

they said don't expect anything soon though

Maybe if others report the same bug it will gain more traction and we will get a fix sooner though
(Edited)
Photo of Itech Las Vegas

Itech Las Vegas

  • 14 Posts
  • 0 Reply Likes
did you figure out when you set power-mode at and the ap goes to injector mode are the limitations removed from usb and 2.4ghz radios?
also can you tell me what firmware your on as that setting doesn't work on my r710's
Photo of Lukas

Lukas

  • 24 Posts
  • 4 Reply Likes
I'm running on vSZ 3.2.1 MR1. Maybe that's why the command does not work for you. If I output the help for the command this option is not documented so it's maybe a new option which is not implemented in your branch yet.
However I was not able to verify that the restrictions were removed, because POE injector powered could still mean that the AP is in af mode. I may be able to check in a few week, if the mode has changeds, because the second ethernet port also gets disabled and when I have physical access to the AP I can check that.
I'll also open a ticket, however it would be very nice, if you could report back if you get any updates on this.
Photo of Itech Las Vegas

Itech Las Vegas

  • 14 Posts
  • 0 Reply Likes

per my SE injector mode should remove the limitations of AT mode

It might be that your AP isn't using more wattage currently as it isn't under the load to require it.

Photo of Austin Wahl

Austin Wahl

  • 6 Posts
  • 0 Reply Likes
I remember reading something about the newer sg300 firmware about POE+ are you guys running the 1.4.2.04 firmware?
Photo of Lukas

Lukas

  • 24 Posts
  • 4 Reply Likes
Yes, the problem exists also with version 1.4.2.04. There was an internal POE-FW update mentioned in the release notes, but only for the large switches (48+ Ports) which I don't own.
Photo of Itech Las Vegas

Itech Las Vegas

  • 14 Posts
  • 0 Reply Likes
yes we are on SG500X 48port switch with 1.4.2.04

I upgraded to that berfore I even opened a ticket with cisco or ruckus and posting on here

I just reread the release notes for it and I don't see anything about POE+ in it.
do you have a link to the internal FW download?
(Edited)
Photo of Lukas

Lukas

  • 24 Posts
  • 4 Reply Likes
http://www.cisco.com/c/dam/en/us/td/docs/switches/lan/csbms/Sx500/release_notes/R_1_4_2_RN.pdf
See page 8: "Software version 1.4.2.04 includes upgraded firmware to the PoE controller". Only the large switches are affected.
Photo of Itech Las Vegas

Itech Las Vegas

  • 14 Posts
  • 0 Reply Likes
ok but it didn't fix this issue

as I believe this issue is with LLDP not POE as the poe classification is working correctly
Photo of Jeronimo

Jeronimo

  • 321 Posts
  • 37 Reply Likes
On switch side, Must enable LLDP power over MDI.

If not supported "LLDP power over MDI", R710 cannot operate with POE+.
Photo of Lukas

Lukas

  • 24 Posts
  • 4 Reply Likes
I have a little update on the problem: today I was able to test, if the command set power-mode AT (via CLI on each AP) changes the AP behaviour to AT-Mode. And IT WORKS! I tried connecting a laptop to the second LAN-Port (which should be only enabled, when in AT-mode) and there was a connection.
I'm running on a vSCG Version 3.2.1 MR3
Photo of Lukas

Lukas

  • 24 Posts
  • 4 Reply Likes
I have a little update on the problem: today I was able to test, if the command set power-mode AT (via CLI on each AP) changes the AP behaviour to AT-Mode. And IT WORKS! I tried connecting a laptop to the second LAN-Port (which should be only enabled, when in AT-mode) and there was a connection.
I'm running on a vSCG Version 3.2.1 MR3