How to make nearby devices “stick” to specific AP?

  • 1
  • Question
  • Updated 4 months ago
We have iPads that are situated right next to an Ruckus Wireless ZoneFlex H510 yet the iPads keep roaming away to other R500s from time to time. All APs are controlled by ZD1200.. Is there a way to tag devices to only stay at their particular AP and not roam?
Photo of AO

AO

  • 7 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of Max O'Driscoll

Max O'Driscoll, AlphaDog

  • 348 Posts
  • 90 Reply Likes
They have an inbuilt tag called a MAC - you could use that.
Bit of work involved in this solution.
Use the MAC addresses to allow/deny to WLANs. You could:

Create a unique SSID and add the AP to it.
Assign an ACL (acccess control list) to that  SSID with "allow" rule.
Assign the MAC addresses of allowed ipads to that ACL.
Create a second ACL with a "deny" rule
add the same MAC addresses to it and apply to all your other broadcast SSID.

Your specified ipads can now only connect to one specific AP.

Clunky but it will work.
Someone else might have simpler way.

Perhaps force ipads to use 5GHz and turn that off on all other APs for instance.
(Edited)
Photo of Karl Lavender

Karl Lavender

  • 12 Posts
  • 1 Reply Like
Without much context, I assume that you have H500 solution running on ZD because this is a medium / large space like a campus area, dormitory or smaller hotel.  The issue you're having is 'mostly' driven by the selection the client device makes.  I don't think iPads have a built-in roaming aggressiveness feature you can adjust like the NIC in most PC's, which can certainly help from the client side.

1) ideally you want to find out why they are roaming - there is going to be some kind of interference behind the choices, or the APs are installed with a far too strong -dB overlap and it may just find the other loud AP to have a clearer channel at the time.

2) dial down your 2.4 so that its usable range is about the same as the 5GHz, drop it by ~3dB and then check again for dead zones you probably created.  Then see what you might need to do re: moving some AP or adding some antennae that would give both your 2.4 and 5 ranges additional range, dialing back the 2.4 as needed.

Lastly, if you are using the H500 range because this is meant to be an AP-per-room type situation, then you may just need to dial down the signal altogether so that it becomes solely usable within that room, or parts of that room.
Photo of AndiT

AndiT

  • 24 Posts
  • 3 Reply Likes
Generally this happen because the other signals are too strong. I don't know if you have done this, but after the deployment the next thing to do is to set the right TX Power on each AP or you can have this type of issues. Maybe the other APs are too close too.

Other thing that you can do is to enable the band balancing, with this you can do that the iPads work in the 5GHz band, just noticed that this configuration affects to all the end users connected to the APs, so be careful with the percentage used.

Hope this could help you.