How to auto-provision Brocade switches by DHCP

  • 1
  • Question
  • Updated 4 weeks ago
Going through the documentation (which is pretty shoddy) I can't seem to figure this out. My best guess, from what I've read, is:
  • Unzip firmware distribution into TFTP server root
  • Add option 66 pointing to DHCP server (e.g. 192.168.0.1)
  • Add option 67 pointing to manifest file (e.g. FI08070a_Manifest.txt)
  • Reboot switch

However, after getting a DHCP address there are no attempts by the switch to download the manifest file (but it does try to download a config file.) How does this work?
Photo of PofP

PofP

  • 8 Posts
  • 0 Reply Likes

Posted 4 weeks ago

  • 1
Photo of David Ellis

David Ellis

  • 20 Posts
  • 2 Reply Likes
Depending on the Switch model and the code version, the manifest.txt file may not work. You have to be on a 7000 series switch and at least 8.0.40 code to recognize the manifest. I created this document that may be helpful as well.

http://www.netadmin.us/docs/DHCP-Auto-Provision.pdf
Photo of PofP

PofP

  • 8 Posts
  • 0 Reply Likes
ICX7150 8.0.61a. Just completely ignores whatever I put in option 67 (which I assume is what your config is calling a "bootfile".) No download attempts at all.
Photo of David Ellis

David Ellis

  • 20 Posts
  • 2 Reply Likes
Can you post your DHCP Pool configuration and what version of Manifest file you are using?
Photo of PofP

PofP

  • 8 Posts
  • 0 Reply Likes
Also worth noting that the documentation is wrong regarding configuration downloads as well. It does request multiple configuration files:
* hostnameMAC-config.cfg
* hostnameMAC.cfg
* hostname.cfg
* brocade.cfg
But it stops after the first one. Claims that subsequent files are appended to the configuration are not true.
Photo of David Ellis

David Ellis

  • 20 Posts
  • 2 Reply Likes
I just configured this in my lab and it worked like a champ. I have an ICX-7150 running 8.0.61a and the following configuration on an ICX 7150-C12 as the DHCP server. I am using TFTPd on my laptop as the TFTP server.

vlan 420 by port                                                  
 untagged ethe 1/1/8 
 router-interface ve 420
!
ip dhcp-server enable
!
ip dhcp-server pool autoprovision
 bootfile FI08070a_Manifest.txt
 dhcp-default-router 192.168.42.1 
 excluded-address 192.168.42.1 192.168.42.99
 lease 0 0 15
 network 192.168.42.0 255.255.255.0
 tftp-server 10.10.10.100
 deploy
!
interface ve 420                                                  
 ip address 192.168.42.1 255.255.255.0
Photo of PofP

PofP

  • 8 Posts
  • 0 Reply Likes
Hmm, very frustrating, that's exactly the setup I'm using (although not on a Brocade DHCP server.) My TFTP server is the same machine as the default gateway. I've tried a few variations such as option 150 instead of 66, and still no luck. Thanks for going through the trouble though!

As for why the config gets downloaded, I know the switch defaults to pulling a config from its gateway, so my hunch is that the TFTP server address included in the DHCP reply is being ignored completely by the switch. This would possibly explain why it doesn't even try to download the manifest file.

It's a shame you aren't able to pull a packet trace since it's just a switch-to-switch communication. There must be something different getting sent by the Brocade DHCP server.

Just noticed you were asking about DHCP server config, but as I said I do not use switches for DHCP serving. Here's what a reply looks like:

	  Your-IP 172.16.0.5
Client-Ethernet-Address 78:a6:e1:2d:d8:c6
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: Offer
Server-ID Option 54, length 4: 172.16.0.1
Lease-Time Option 51, length 4: 6721
Subnet-Mask Option 1, length 4: 255.255.255.248
Default-Gateway Option 3, length 4: 172.16.0.1
Domain-Name-Server Option 6, length 4: 192.168.242.200
TFTP Option 66, length 10: "172.16.0.1"
TFTP-Server-Address Option 150, length 4: 172.16.0.1
BF Option 67, length 21: "FI08070a_Manifest.txt"

(Edited)
Photo of David Ellis

David Ellis

  • 20 Posts
  • 2 Reply Likes
Try changing the default gateway to something else since you are on the same switch and it is not needed. Set option 66 to your PC since it is the tftp server. What are you using for your DHCP server?
Photo of PofP

PofP

  • 8 Posts
  • 0 Reply Likes
My PC is not my TFTP server, my router is (and is also my DHCP server.) I tried setting up TFTP on my laptop in case the Brocade didn't like them being the same address, but no change.
I think the only thing left to try is setting up one Brocade as a DHCP server like you've done, and grabbing a packet trace via port mirroring to see why it works! Very frustrating that all the documentation is so vague or factually incorrect.
Thanks for your assistance though!