Hotspot problems after 9.7 upgrade

  • 1
  • Question
  • Updated 4 years ago
  • Doesn't Need an Answer
Keith,

Just tried the 9.7 firmware and had to downgrade, I will explain below.

We have staff wifi and use the hotspot services so they can login.

In our hotspot service page we have the login page which points to a local site with policies and other info which is http://policy/wifi/index.html

And in the walled garden section we have http://policy.wifi/index.html and the ruckus login page https://ruckus.ourdomain.com/user/use...

On 9.6 this all used to work brilliantly now on 9.7 it no longer works, are we doing something really stupid here or has functionality changed?

Note: This topic was created from a reply on the MS Surface with Windows RT cannot reach the captive portal page. topic.
Photo of Andrew Barker

Andrew Barker

  • 7 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 51 Reply Likes
Not offhand I can't think of anything that would cause this to fail.

Is this just Surface RT tablets or all clients? Can you provide more detail about how/where it fails? I'm using this new thread to open a case for you.
Photo of Andrew Barker

Andrew Barker

  • 7 Posts
  • 0 Reply Likes
It happens with all clients and operating systems.

The only thing we changed is the firmware from 9.6 to 9.7

It happens right after connecting to the wlan and opens the browser, this is the point where it fails.

I can provide a copy of the config if that helps?
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 51 Reply Likes
We are working with Andrew on this issue and will report back when we have root cause.
Photo of Yew Wei Chow

Yew Wei Chow

  • 3 Posts
  • 0 Reply Likes
Hi Keith,

My end-user also having the same problem on the hotspot after upgrading the firmware from ver 9.6 to 9.7. All the while, they using ver. 9.6.0.0.267 without any issue. The hotspot are set redirection to https://10.24.129.76 for authentication and after user is valid it will redirect back to https://10.24.129.76/my.policy. Inside the walled garden we set the unauthenticated users to the IP address of login page. When user get connected to WLAN and open the browser the login page will prompt automatically.

For ver. 9.7 it doesn't happen.