Hi, do you have any idea about this error "bad firmware header magic" ? upgrading R510

  • 1
  • Question
  • Updated 1 week ago
  • Answered
Photo of Bruce Tablada

Bruce Tablada

  • 4 Posts
  • 2 Reply Likes

Posted 2 weeks ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 2471 Posts
  • 344 Reply Likes
Not enough info...  ZD or SZ managed, or standalone code?  What version to what version?  Does it work, or not?  Only one R510, or more than one?  Just R510 models?  Did it work before?
Photo of Bruce Tablada

Bruce Tablada

  • 4 Posts
  • 2 Reply Likes
R510 has fw 106 and ZD1200 has fw 9.9. i tried to convert the fw of R510 to 9.9 so it can be managed by ZD but during the upgrade error occurred "Bad firmware header magic". and AP can't be access thru CLI. I tried hard reset and download the fw again
Photo of Bruce Tablada

Bruce Tablada

  • 4 Posts
  • 2 Reply Likes
Hi, 
As per reading on the release notes of 9.9.0.0.216 ZD1200 I discovered that R510 is not supported on the firmware version of Zonedirector 1200. That's why error occurred "Bad firmware header magic". Am I correct?.
Thanks
Photo of David Shader

David Shader

  • 2 Posts
  • 0 Reply Likes
I had a similar issue with some R500's:

See below, I sent the issue in with my ticket 00825708, the agent is RMA'ing both AP's:

 

-  Shipped AP on 104 firmware to property, AP gets "Failed to upgrade from 104 to 9.8.3"

- Ruckus support was contacted and made a decision that the AP had failed

-  Shipped a second AP that exhibits the same symptoms as the original AP.  I downgraded the firmware from 104 to 100, then attempted to upload the 9.8.3 firmware.

- AP is now giving a new error (bad firmware magic) and not connecting to the ZD.

- We had a T300 shipped as well with no issue.

- I also tried a local upgrade, the AP would take the firmware and do the whole reboot process, but when it came back online, it remained on standalone.








Photo of Bruce Tablada

Bruce Tablada

  • 4 Posts
  • 2 Reply Likes
Hi,

I just enable the internal dhcp of ZD1200 and the AP's were automatically upgraded by ZD. I think some sort of three way handshake session. and it resolved the issue.
Photo of Michael Brado

Michael Brado, Official Rep

  • 2467 Posts
  • 343 Reply Likes
Thanks for the positive update.  It may be that other DHCP server would need an option 43 or a DNS translation for the APs to learn your ZD IP (if they weren't on the same local LAN).
Photo of David Shader

David Shader

  • 2 Posts
  • 0 Reply Likes
My issue must be different from this one then. Our AP's connect to the ZD, but fail to upgrade firmware. We'll see after they get replaced.