Guest Access Broken with Recent Update

  • 1
  • Question
  • Updated 8 months ago

I believe it might be 200.5.10.0.283 that broke this, but it might have also been a prior release.  When connecting to the guest network, client connectivity would be intercepted and clients would be shown the Welcome Message, Terms and Conditions and whatnot.  With the latest updates, clients are being redirected to the “management” IP address of Unleashed and, since guests do not have access to this IP, Guest Access and the display of the Welcome Message and related is now broken (the captive portal never loads).

What am I missing here?  I believe this might have been an issue a while back, but there appears to be a regression in the latest update or two.

Photo of Daniel M

Daniel M

  • 51 Posts
  • 12 Reply Likes

Posted 9 months ago

  • 1
Photo of Jim Balla

Jim Balla

  • 6 Posts
  • 5 Reply Likes
There are several issues with this latest release. I have an open case with tech support. I was at 200.4 and everything worked fine. The issue started with 200.5. 

Here is what I have been told by tech support:

We checked simultaneously with our engineering team regarding the current issue and found this to be a bug happening with Master AP. 

Our engineering team was able to replicate the issue over master AP and I am in verge of opening a case with engineering for the same. 

What they say is, prior to 200.5, we do not use tunnel between the client and the master but post 200.5, we use tunnel between client and the master and because of this ACL framework change, the AP cannot detect the arp requests. 

We also found that ipv6 overrides the ipv4 address while reporting to master AP. Now when this override happens, it becomes difficult for the AP to trace the ipv4 address. 

The workaround found currently is to disable the ipv6 on the client. Could you please try this as test on one of your client and confirm if that works?

This work around did not work in my situation, but it maybe something you would like to try in your case. 

Good luck
Photo of Daniel M

Daniel M

  • 51 Posts
  • 12 Reply Likes

Thanks for chiming in Jim—I’d appreciate it if you would update the thread as to the results of your case and how long it took Ruckus to resolve.  As for the possible workaround, this is a non-starter and unrealistic—I can’t have all guests disable IPv6, assuming they even knew how—so I see no reason to even try it.

(Edited)
Photo of Jim Balla

Jim Balla

  • 6 Posts
  • 5 Reply Likes
I was just notified by the tech that it is a true bug in the release and that they passed it onto the engineering team (what ever that means). I reported this on Nov 1st and they are still working on it.
Photo of Jim Balla

Jim Balla

  • 6 Posts
  • 5 Reply Likes
I received a new build version yesterday to try (200.5.10.0.291). It has been running for over 24 hrs and everything is back to the way it is supposed to be.