Getting R710s to use POE+ (802.3at) mode on Netgear GS752TP switch

  • 1
  • Question
  • Updated 1 year ago
Hi.
I have 4 R710s connected to a Netgear GS752TP PoE switch which I cannot get to use PoE+ (802.3at) mode.

Looking at some of the previous posts and information, I SSHed into each R710 and found LLDP initially disabled, so I enabled via CLI. Now get lldp for all APs reads:

LLDP state: Enabled
LLDP interval: 30
LLDP holdtime: 120
LLDP mgmt: Enabled
LLDP bond type: Source MAC for LLDP frames on bond slaves: fixed
LLDP poe: Enabled
LLDP power: 25000
LLDP interface:
LLDP on eth0 : Enabled
LLDP on eth1 : Enabled
OK

On the GS752TP switch, all access points are connected to the first 8 ports (which are POE+ 802.3at capable). 

On the LLDP settings for the switch, I've enabled transmit optional TLVs for ports 1-8, which should include Power via MDI.

Unfortunately all APs still remain in 802.3af PoE Power Consumption Mode.

Any ideas on how to fix this ?

Thanks.
Photo of Rohan

Rohan

  • 5 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Robert Lowe

Robert Lowe

  • 143 Posts
  • 22 Reply Likes
What controller and FW version? I seem to remember seeing a bug fix for this in one of the latest releases
Photo of Dave Watkins

Dave Watkins

  • 59 Posts
  • 11 Reply Likes
Assuming these are connected to a ZoneDirector, you also needed to SSH into the ZD and enable the various LLDP options on Default AP Group. I typically do it on the AP Group the AP's are actually in too
Photo of Rohan

Rohan

  • 5 Posts
  • 0 Reply Likes
Hi. Thanks for the replies.

I'm using a ZoneDirector 1200 with latest (9.12.2.0 build 204) firmware.

I have actually already tried Dave Watkins' suggestion too (and I only use the System Default AP group) as per posting here - http://www.mirazon.com/enabling-lldp-in-ruckus-wireless/

Is there a way to monitor/log the negotiation that occurs between the PoE switch and the APs ?  Or are there any other suggestions ?

Thanks.
Photo of Max O'Driscoll

Max O'Driscoll, AlphaDog

  • 309 Posts
  • 72 Reply Likes
Just in case it's of any interest...or even use!

specs for R710 say...
  • PoE: 802.3af/at
Power Consumption
  • 8W (minimum)
  • 11W (typical)
  • 25W (peak, includes full USB load)​​
  • 12.95W (peak in 802.3af mode)
I have a Netgear GS752TP running R500s (max power 10.5W so don't need "at") using both "at" and "af" POE ports.

Notes:
I didn't require anything beyond default settings.
Running latest firmware for switch  (6.0.1.16).

(Edited)
Photo of Max O'Driscoll

Max O'Driscoll, AlphaDog

  • 309 Posts
  • 72 Reply Likes
screenshot of LLDP


Photo of Max O'Driscoll

Max O'Driscoll, AlphaDog

  • 309 Posts
  • 72 Reply Likes
also LLDP port settings

Photo of Robert Lowe

Robert Lowe

  • 143 Posts
  • 22 Reply Likes
ok, and which ports on the screenshot do you have R710 connected to? 
Photo of Max O'Driscoll

Max O'Driscoll, AlphaDog

  • 309 Posts
  • 72 Reply Likes
Sorry. To be clear I have R500s attached to 3, 7, 10 - which covers both power options on the switch.

The R500 is a lower power device than R710 so only needs "af". 

This was to give you a view of what is available on switch and to that R500 works off off boths kinds of POE port on default settings. If I had an R710 I'd put it on and see what happened!
Photo of Max O'Driscoll

Max O'Driscoll, AlphaDog

  • 309 Posts
  • 72 Reply Likes
Release notes for firmware 9.1.2.0.204
include...

Resolved Issues 1. Resolved an R710 PoE issue that occurred when the AP was connected to a switch that only supported 802.3af PoE mode. [ER-3225, SCG-47346]

This might be fixed but you are seeing other POE issues that are lurking in background.

======
for instance: from firmware release 9.12.1 December 2015

R710 Known Issues • No Syslog message is sent for 802.3af PoE mode change. [ZF-13160]

R710 AP continues to request 25W power from the PoE switch even when the AP is configured to 802.3af mode. [ZF-14489] R710 Features Not Supported in This Release ZoneDirector Version 9.12.1 Release Notes, 800-71040-001 Rev E 17

Workaround: Disable LLDP Power-Via-MDI TLV on the PoE switch (this is only necessary if you wish to force the AP into 802.3af PoE mode on an 802.3at PoE+ switch for power budgeting reasons). On some switches, you may need to reset the AP connected Ethernet port/s to force the switch to renegotiate the new power level. 
======
(Edited)
Photo of Robert Lowe

Robert Lowe

  • 143 Posts
  • 22 Reply Likes
That was the bug I was referring to earlier but that is actually the reverse of what the OP describes as his switch supports 802.3at & af.
Photo of Rohan

Rohan

  • 5 Posts
  • 0 Reply Likes
Hi again.

For what it's worth, this is the switch PoE status page (at the time I took this, 3 of the R710's were connected to ports g2 - g4), with port g1 - g8 all theoretically able to deliver full PoE+ 802.3at power, and all connected APs are correctly identified as Class 4.



And here is an example LLDP port config for g2, showing optional TLVs transmission, which includes Extended Power via MDI.



Yet the R710s still stubbornly stay in 802.3af PoE Power Consumption Mode.
(Edited)
Photo of Robert Lowe

Robert Lowe

  • 143 Posts
  • 22 Reply Likes
how many other ports do you have connected with PoE devices on this switch? Have you tried changing the priority to high on one of the R710 ports and rebooting the switch? It is applying class 4 so it looks like the switch is recognising that it is a PoE+ device. 
Photo of Rohan

Rohan

  • 5 Posts
  • 0 Reply Likes
There's only about 10 other PoE devices connected at the moment - mostly low power. The switch has a nominal power budget of 384W, but is currently only showing 60W consumption, so I assume nothing is getting throttled by the switch itself. I previously put them all up to high priority and rebooted everything, but it unfortunately made no difference.
Photo of Robert Lowe

Robert Lowe

  • 143 Posts
  • 22 Reply Likes
Ok, as the switch seems to be detecting class 4 via LLDP i am leaning towards the AP choosing to go into af mode for some reason but still requesting .at power (based on lldp power from OP and bug ZF-14489 from Max's post). Do you have any other 802.3at complaint switches you could test with? Will do some more digging on R710 & PoE+
Photo of Robert Lowe

Robert Lowe

  • 143 Posts
  • 22 Reply Likes
Photo of Rohan

Rohan

  • 5 Posts
  • 0 Reply Likes
I actually have a Linksys LGS116P unmanaged switch which is PoE+ 802.3at capable. I've tried one of the R710s on that and it behaves the same. But as an unmanaged switch, I don't think it has LLDP support anyway, so that probably doesn't really help.
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 136 Reply Likes
I've had the same experience with the Cisco Meraki MX65 switch that has 2 802.3at POE+ ports. I can get a Meraki AP to negotiate PoE+ with it, and it's clearly using LLDP to do so, but I can't get my R710 to negotiate PoE+....

I've double checked the same LLDP settings via both the AP and ZD CLIs.
Photo of Max O'Driscoll

Max O'Driscoll, AlphaDog

  • 309 Posts
  • 72 Reply Likes
Update re netgear switch end of things:
new firmware 6.0.1.18, 18 May2016,  for netgear GS7 series POE switches which references 2 POE fixes (which might or might not be relevant).

http://kb.netgear.com/app/answers/detail/a_id/30664

Directly previous firmware in March (6.0.1.16) included POE debug enhancements so I'm thinking netgear recognises there are issues with their POE.

this kb article:
http://kb.netgear.com/app/answers/detail/a_id/29801/related/1

has some hands on suggestions for disabling POE on ports not using it! Especially if switch to switch connection. I have a few of those!
(Edited)