For the R610, turn on secondary port at 802.3af?

  • 1
  • Question
  • Updated 4 weeks ago
  • Acknowledged
We have 100+ R610s that replaced R500s and R600s.  The R610s require 802.3at for full funcationality.  I have POE+ switches that have been powering all the Ruckus APs for a few years, and the APs have always worked at full functionality.  

With the reduced functionality, the secondary ethernet port is disabled.  Why?  I'm not sure, as it really doesn't require much/any power, and the APs on 802.3at actually use the same amount of power, once they are running.  But replacing all of my switches with ones that can provide 1500 watts of power seems very difficult/expensive.  A 48 port HP/Arruba POE+ switch only provide 382 Watts.

So, I'm wondering if anyone has found a way to turn on the secondary port while still getting 802.3af power.  I've looked without luck.

Thanks
Photo of David Buhl

David Buhl

  • 17 Posts
  • 11 Reply Likes

Posted 1 month ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 2957 Posts
  • 414 Reply Likes
Hi David,
I remember in the past, if you aren't fully loading your switch with just APs, we'd recommend to try spacing them out across the 4-port blocks, which are typically powered by the same internals. The advice was alternating top/bottom ports, so kitty-corner two APs in the 4 port sections.

If you used half the PoE+ ports on APs, and all lower class PoE phones/other devices, I think your power budget should still suffice. I hope this helps.
Photo of David Buhl

David Buhl

  • 17 Posts
  • 11 Reply Likes
Thanks for the reply.  I tried that and also spoke with HP/Aruba support.  They said splitting power among different blocks shouldn't make a difference, it's total wattage required.  Like I said, the total wattage on these 48 port POE+ switches is 382 Watts.  At the 30 watts required for 802.3at, thats a max of 12 ports, with basically no power output on any of the other ports.  

So I'm hoping there is a way to tell the AP that just turn on the secondary port after startup.  Again, no additional power is required.  And by the time startup is done, the AP's are usually pulling 5.8 watts. 
Photo of Diego Garcia del Rio

Diego Garcia del Rio

  • 80 Posts
  • 31 Reply Likes
Hi David,

you can force the power mode on the AP (either on the CLI of the ap with "set power-mode at"  or on SmartZone (at least on 3.6.2), if you go to the AP-specific settings you can set the power mode.

See below for the example config. I agree that in most cases an R610 will not exceed even 15 watts... especially if you're not loading it with 300 clients or doing 500 mbps with DPI and other features..


 

Cheers,
Diego

Photo of Diego Garcia del Rio

Diego Garcia del Rio

  • 80 Posts
  • 31 Reply Likes
Additional note.. if using Smart-Zone, only do it through the GUI... as the CLI setting will get overwritten each time SZ updates / syncs the config.

Cheers

Photo of David Buhl

David Buhl

  • 17 Posts
  • 11 Reply Likes
Sorry, thought I replied earlier.

I've used that toggle and tried forcing an AP to 802.3at while only getting 802.3af on the switch.  That didn't help.

If the switches actually get 802.3at, it'll overload the switch and ports will get shut down.

So what I'm looking for is some way to activate the secondary ethernet port while the AP is in 802.3af mode.
Photo of John D

John D, AlphaDog

  • 525 Posts
  • 149 Reply Likes
This doesn't seem to be possible in 802.3af mode. Plain old gigabit ethernet ports do take about a few watts to operate, which can easily be a problem for fitting within the 802.3af budget. Ruckus probably made the assumption that more 802.3af users care about wifi radios operating in a less crippled mode vs the ability to establish bridged wired connections using the second port.

The R610's specs for power consumption shows that it's just barely over the 802.3at threshold, so you probably don't need to budget for too beefy of a PoE+ switch.

Idle: 5.7W Typical: 10.4W Peak: 18.8W



Photo of David Buhl

David Buhl

  • 17 Posts
  • 11 Reply Likes
Thanks.  Unfortunately, the way the vendors handle POE works against me.  According to HP/Aruba, the POE standards require that 25W is allocated to each port with 802.3at turned on.  If the AP draws more during startup, it will allocate more to the Mac load for that port.  I see most of the APs get up to about 28.8W during initial startup.

The APs that are 802.3at, and the APs that are 802.3af both draw about 5.8W once they are running.  So that port and the extra 2.4 chain doesn't really matter.  The only real problem is the startup.  If the AP isn't getting 802.3at, it shuts those things down.

All Ruckus would need to do is activate the port after startup is complete.
Photo of Diego Garcia del Rio

Diego Garcia del Rio

  • 78 Posts
  • 30 Reply Likes
Hi David,

At least on Ruckus switches you can manually configure the PoE power budget to 18W for example (or 20W) so that you don't burn the 25W allocated and have the ability to use more ports. Not sure if Aruba has the same option or not.

To be honest, I've been using R610 APs on .af switches while the AP was set to power-mode "at" and they worked fine. Im surprised to see 28.8W during startup as its way more than what the Ruckus Datasheets state (and even those tend to be agressive in specifying peak power consumption). 

Did the switch ports shut down when setting the power-mode to .at? or is just theory?
Photo of David Buhl

David Buhl

  • 17 Posts
  • 11 Reply Likes
Yes, I tried setting the wattage by value on the HP/Aruba switches.  But any manually set budget under 30W leaves secondary disabled.  There is no other functionality that is removed that you would notice really.  

Have you been able to use the secondary port when you manually set the poe budget to 18?
Photo of Diego Garcia del Rio

Diego Garcia del Rio

  • 78 Posts
  • 30 Reply Likes
yes, got the secondary port working fine and the radios at full power.  I would force the AP to  AT power mode and limit the budget on the switch to 18W and it was working fine. If the AP is forced to AT mode then all functionality will work regardless of what the switch is thinking...  The switch-side limit is to better share the POE budget among all ports. In fact, I even got the AP working in AT mode when connected to a legacy AF-only switch.
Photo of John D

John D, AlphaDog

  • 525 Posts
  • 149 Reply Likes
My experience is like Diego’s. For devices where they are right on the border between af/at or at/at+ you generally can force them into the higher power mode without much ill effect. I have done this with forcing R720 and R730 into “at+” on at switches where the max per port power is 33W (vs the max 35W spec from ruckus) and never seen an overcurrent cutoff even under heavy load.

The R610 is barely outside the .af power envelope and I expect most of the time it is sitting closer to the idle numbers.
Photo of David Buhl

David Buhl

  • 17 Posts
  • 11 Reply Likes
Thanks Diego, that seems to be working.  I updated all of the APs to be 802.3at and rebooted a couple of them, while leaving the switch settings at about 17W.  The two I rebooted did activate the secondary port and don't seem to be marked as using extra power on the switch.

After hours I'll power-cycle my most loaded switch.  It's has 24 POE+ ports, and has 20 R610s attached.  If that one comes up normally, then that's definitely the solution.

I guess when I changed the APs to 802.3at previously, I had already messed with the POE settings on those ports that caused them not to be properly powered, or over-powered, depending on the test I was running.

Do you have LLDP turned on on those switch ports?

Thanks!

Dave
Photo of John D

John D, AlphaDog

  • 525 Posts
  • 149 Reply Likes
I kept LLDP on but saw that when POE mode is forced to a mode, I didn’t see any Ruckus products trying to do lldp power negotiations.
Photo of Diego Garcia del Rio

Diego Garcia del Rio

  • 78 Posts
  • 30 Reply Likes
I had LLDP on and saw ruckus advertising its consumption in some cases, but in this case where my switch was not negotiating poe over LLDP I don't recall if the LLDP POE PDUs are sent when forcing the mode.

Hope this solves the issue for you. Personally, I don't like switches reserving the full capacity... I prefer them cutting power on demand (most of them will allow you to configure priorities for POE) but maybe that's just me.

In my case, the peak of power consumption I've seen was not during power up but under very heavy ussage (hundreds of clients on an AP passing maybe 150-200 mbps and having application visibility on).

Other than that, I've never seen the devices come close to the max power budget.

Hope your test works out fine!

(and maybe take a look at the power priorities in your switch so that you either stagger the bringup of the ports over time or if the switch decides its overpowered then it shuts down your least important APs)

Cheers!