Even after manually entering a director IP in the CLI of the ruckus AP, it still does not connect to the zone director.

  • 2
  • Question
  • Updated 2 years ago
I have a ZD3000 model zone director running with an active dhcp server for discovery on the device. However, even when I manually set the proper zone director IP address in the AP's CLI it does not sync up. Running the command: "get director" always returns that the AP is in standalone mode even though it states the primary controller IP correctly. Both the AP and controller are on the same and the AP is getting a DHCP address on the proper vlan as well. How can I force the AP out of standalone mode and connect to the ZoneDirector?
Photo of Matthew Palmer

Matthew Palmer

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of Michael Brado

Michael Brado, Official Rep

  • 2109 Posts
  • 297 Reply Likes
Need more info.  What kind of DHCP server?  Is there a router acting as the Default gateway for DHCP and the ZD's Configure/System?

All on one flat subnet, same VLAN?

Can you ping the AP from the ZD's Toolbox/Network Connectivity at the top of the WebGUI, and the ZD from the AP's CLI?

After configuring the AP with 'set director ip a.b.c.d', you need to reboot.

If you setup your ZD's Administer/Diagnostics debug logs for Access Points, it will show if you are even seeing the LWAPP discoveries

when the AP reboots.

Do you see any activity logged on the Monitor/Access Points page, Events/Activities from this AP trying to connect?
(Edited)
Photo of Matthew Palmer

Matthew Palmer

  • 2 Posts
  • 0 Reply Likes
Yes everything on the hardware standpoint is on the same vlan, 100. The main dhcp server is 10.0.100.1 the Zd is 10.0.100.60 and the zone director has a dhcp server 10.0.100.200-210 and on the main server for the 100 vlan it only has 10.0.100.253-254 available for dhcp. After configuring the AP with the director IP, it was rebooted. The AP does ping in the ZD diagnostics and pulls a dhcp of 10.0.100.253. My first thought was to disable the dhcp from the main server as it keeps reaching to this server. However when I do so the AP never requests a dhcp from the ZD. No activity reported from this AP on the Zonedirector at all.

Also as a note, this exact same configuration worked when configuring a brand new R500, but when trying with the T301S it does not. That is why I thought it had something to do with the Ap not switching out of stand-alone mode.
Photo of Michael Brado

Michael Brado, Official Rep

  • 2074 Posts
  • 289 Reply Likes
By default the ZD assumes it's on an untagged VLAN 1. 
If your VLAN 100 is tagged, you would need to update the ZD Configure/System, and Configure/Access Points, Access Point Policies, management VLAN.
If so, we have a KBA article that might help with that:
https://support.ruckuswireless.com/answers/000002357
or
https://support.ruckuswireless.com/answers/000002513
(Edited)