Error on ZD 1200 and r500 aps not joining.

  • 1
  • Question
  • Updated 8 months ago
  • Answered
I have a property I just had to reset the ZD 1200 on. 24 of the APS came in and worked fine. 24 others had the cloud based firmware on them and wont talk to the ZD. I upgraded the FW to the Correct 104 version. That got me 10 more aps into the ZD. I still have 10 more that give me this error and will not finish the provisioning step. I have tried change mtus made sure ftp was open but still nothing. The IP 252.1 that is referenced is the ZD IP so Im not sure if maybe the ZD config got corrupted and needs a reset?

Dec 13 17:25:09 RuckusAP local2.err syslog: (ap state) AP begin to join ac.  
Dec 13 17:25:09 RuckusAP local2.err syslog: Cannot notify kernel for Upd AP Param 172.17.252.1(0) event, 
-- No such file or directory(2) 
Dec 13 17:25:09 RuckusAP local2.err syslog: WTP join cfm response, lwapp_notify_kernel_ip_addr [nat  ipv4
].   nat_ipv4_addr: 172.17.252.1    port: 0    family: 2   
Dec 13 17:25:09 RuckusAP local2.err syslog: WTP join cfm response, lwapp_notify_kernel_ip_addr [ipv6].   
ipv6_addr: ::    port: 0    
Dec 13 17:25:09 RuckusAP daemon.notice rsmd[33]: wsgclient ....... [stopped] (0.191)
Dec 13 17:25:09 RuckusAP daemon.notice rsmd[33]: wsgclient ....... [stopped] (0.074)
Dec 13 17:26:13 RuckusAP local2.err syslog: Proceed to IDLE state from CONFIGURAION state, no resp after 
15 re-transmits 
Dec 13 17:26:13 RuckusAP local2.err syslog: Cannot notify kernel for Delete AP 172.17.252.1(0) event, -- 
No such file or directory(2) 
Dec 13 17:26:45 RuckusAP local2.err syslog: (ap state) AP begin to join ac.  
Dec 13 17:26:45 RuckusAP local2.err syslog: Cannot notify kernel for Upd AP Param 172.17.252.1(0) event, 
-- No such file or directory(2) 
Dec 13 17:26:45 RuckusAP local2.err syslog: WTP join cfm response, lwapp_notify_kernel_ip_addr [nat  ipv4
].   nat_ipv4_addr: 172.17.252.1    port: 0    family: 2   
Dec 13 17:26:45 RuckusAP local2.err syslog: WTP join cfm response, lwapp_notify_kernel_ip_addr [ipv6].   
ipv6_addr: ::    port: 0    
Dec 13 17:26:45 RuckusAP daemon.notice rsmd[33]: wsgclient ....... [stopped] (0.189)
Dec 13 17:26:45 RuckusAP daemon.notice rsmd[33]: wsgclient ....... [stopped] (0.073)
Dec 13 17:27:49 RuckusAP local2.err syslog: Proceed to IDLE state from CONFIGURAION state, no resp after 
15 re-transmits 
Dec 13 17:27:49 RuckusAP local2.err syslog: Cannot notify kernel for Delete AP 172.17.252.1(0) event, -- 
No such file or directory(2) 
Dec 13 17:27:58 RuckusAP user.warn kernel: rks_ioctl_NODEDATA:4909 Node not found:00:01:ff:ff:ff:ff
Dec 13 17:27:58 RuckusAP user.warn kernel: rks_ioctl_NODEDATA: buffer error
OK

Photo of Elec Travis

Elec Travis

  • 5 Posts
  • 0 Reply Likes

Posted 8 months ago

  • 1
Photo of Darrel Rhodes

Darrel Rhodes, Employee

  • 125 Posts
  • 66 Reply Likes
Hi Elec, 

This could be related to the firmware you're running on your ZD1200, rather than the AP.

Please can you advise what version your ZD is on?

Thanks,
Darrel.
Photo of Elec Travis

Elec Travis

  • 5 Posts
  • 0 Reply Likes
Hello Darrel,
The FW on the ZD is 10.1.1.0 build 42. I started the APS off on Zoneflex 104.0.0.1347 software. After they connect to the ZD they download the 10.1.1.0 software and installs correctly. This process worked correctly for 10 out of 20 of the aps so not sure if i was just lucky? Or if something in the ZD cfg corrupted along the way?
Thanks again.
Photo of Darrel Rhodes

Darrel Rhodes, Employee

  • 125 Posts
  • 66 Reply Likes
Hi Elec,

Many thanks for confirming the ZD firmware version.  I asked as there is a very small chance of connection issues on firmware prior to 9.10 with some revisions of the R500 hardware but it sounds like this isn't the case here.

Have you tried perorming a 'hard' factory-default (hold down the Reset button for 20+ seconds) on one of the APs that's failing to join and trying again?

Many thanks,
Darrel.
Photo of Elec Travis

Elec Travis

  • 5 Posts
  • 0 Reply Likes
Thanks again.
I wont be back onsite to try a full hadware reset till next week. I have tried the reset from the cli along with re-uploading the FW to the AP. if that still does not work what would be another step?

Elec

Photo of Darrel Rhodes

Darrel Rhodes, Employee

  • 100 Posts
  • 50 Reply Likes
Hi Elec,

What was the command you used in the AP CLI? Was it 'set-factory'?

This should work the same (for the most part) as a hardware reset.

Thanks,
Darrel.
Photo of Elec Travis

Elec Travis

  • 5 Posts
  • 0 Reply Likes
Hello Darrel,

I used the cli set factory is there any difference between the "-" and no "-" ?
Photo of Anusha Vemula

Anusha Vemula, Employee

  • 78 Posts
  • 41 Reply Likes
'set factory' is the correct CLI command. 'set-factory' is invalid.

- Anusha
Photo of Darrel Rhodes

Darrel Rhodes, Employee

  • 100 Posts
  • 50 Reply Likes
Hi Elec, apologies for the hyphon confusion.  Only the correct command would be accepted by the AP.  Differen platforms and firmware revisions can have slightly different commands. Thanks to Anusha for the correction.
Darrel.
Photo of Anusha Vemula

Anusha Vemula, Employee

  • 79 Posts
  • 41 Reply Likes
Hi Elec,

You can try upgrading an AP to the ZD firmware and check if that helps.

AP firmware can be downloaded from the ZD using below procedure. However, please make sure that ftp is enabled on the ZD.

To enable FTP :

ruckus>en
ruckus#config
ruckus(config)#ftp-anon

URL :

ftp://<ZD IP address>

- Anusha
Photo of Elec Travis

Elec Travis

  • 5 Posts
  • 0 Reply Likes
Thanks for the reply Anusha. The ap does get the FW for the ZD installed on it I can even see that the ap thinks its associated to the ZD. It just wont finish getting the config pushed to it. This is happening on 10 aps. Could there be something corrupted on the ZD and can that be fixed without have to reset the ZD.
Photo of Anusha Vemula

Anusha Vemula, Employee

  • 79 Posts
  • 41 Reply Likes
Hi Elec,

In this case, I would suggest you to open a ticket with Ruckus TAC support to check the logs and assist you further.

- Anusha
(Edited)