Enabling multicast for a Sonos environment

  • 1
  • Question
  • Updated 3 days ago
  • Answered
  • (Edited)
I am having trouble with a ZoneFlex R510 in standalone mode, and integrating Sonos. In a nutshell, I can't get the Sonos hardware to join the 2.4Ghz network. Here is a relevant discussion on the Sonos forums. I spent hours troubleshooting this last weekend. When I put my old WAP in place everything worked fine. Re-introduce the Ruckus equipment and it falls apart again. It sounds like I need to try enabling multicast traffic?

https://en.community.sonos.com/troubleshooting-228999/surround-setup-error-6804042

Is this an option in the Web GUI or a CLI only thing? I started looking into this last night and did not find any clear steps. The AP is running v200.6.10.1.308 software.
Photo of Eric Bullock

Eric Bullock

  • 9 Posts
  • 0 Reply Likes

Posted 3 months ago

  • 1
Photo of Eric Bullock

Eric Bullock

  • 9 Posts
  • 0 Reply Likes
Nobody, eh? So I need to call support?
Photo of Joseph

Joseph

  • 22 Posts
  • 2 Reply Likes
Photo of Joseph

Joseph

  • 22 Posts
  • 2 Reply Likes
https://forums.ruckuswireless.com/ruckuswireless/topics/sonos-play-5

Last post will fix your issue providing you have no other networking issues
(Edited)
Photo of Eric Bullock

Eric Bullock

  • 9 Posts
  • 0 Reply Likes
Thanks for the post. The syntax of those commands is different for Unleashed? They did not work for me when I was connected to the AP via SSH.

Here is the translation. Or at least the commands that executed successfully for ME.

The first command was supposed to be this:

rkscli: set qos directed multicast disabled

Should be:

ruckus(config-wlan)# no qos directed-multicast

The second command was supposed to be this:

rkscli: set qos eth0 igmp disable

Should be:

ruckus(config-wlan)# no qos igmp-snooping

The third command I could not figure out.

rkscli: set qos eth0 classification disable

I tried digging into the system configuration and entering this command, which is the ONLY QoS setting I could find in the Unleashed CLI:

ruckus(config-sys)# no qos
Changes are saved!
System QoS function has been disabled

However, after entering this series of commands I am still not able to join my Sonos hardware to my Ruckus WiFi network. The error presented by the Sonos controller is to make sure the 2.4 Ghz WLAN is 802.11b/g compatible.

:/




(Edited)
Photo of Dan Richer

Dan Richer

  • 1 Post
  • 0 Reply Likes
for this command - rkscli: set qos eth0 classification disable 
try running
no qos classification 
Photo of Joseph

Joseph

  • 22 Posts
  • 2 Reply Likes

You didn’t say it was unleashed. That is a controller so you won’t have those commands. What version unleashed? Also change the unleashed to a regular stand alone AP software and run those commands and it should work. Sonos doesn’t like enterprise networks that is why your other AP works. Hence the very reason you don't' use consumer products in business WLANs You can still get this to work. I will setup my unleashed and see what I can do. Stand by....  Also you may have to reset your wifi on the Sonos itself. I honesty think these things are garbage but I listen to them too LOL  :)
(Edited)
Photo of Eric Bullock

Eric Bullock

  • 9 Posts
  • 0 Reply Likes
I am currently running 200.6.10.1.308 of Unleashed. Seems silly to have to "downgrade" it to standalone mode. Is there no equivalent command or setting in Unleashed? I'd really like to figure this out, just in case I ever run into this situation again at a client site. I'm happy to switch to the ZoneFlex standalone mode for home, but in the enterprise that may not be an option.

;)

For the cost the Sonos stuff sounds OK, and the UI is pretty damn good. I like the PlayBar a lot.

My other AP is also an Enterprise-oriented solution. But I hear what you're saying. This system just seems especially persnickety.
Photo of Joseph

Joseph

  • 22 Posts
  • 2 Reply Likes
HI Eric

You may not be able to use this in a business I haven't looked lately at the unleashed however you can try this

if it is available

Radio Resource Management:Enable 802.11k Neighbor-list Report  (enable this)

and set this to this 

Directed MC/BC Threshold:  set this to 0

(0-128)Defines the client count at which an AP will stop converting group addressed data traffic to unicast  


do not allow background scanning and set the 2.4 to channel one only do not use the other 2.4 channels.

I use a ZD1200 and this gives me the availability to set those commands so in a business you may need to go this route

Photo of Eric Bullock

Eric Bullock

  • 9 Posts
  • 0 Reply Likes
I just re-flashed the AP so its a ZoneFlex AP. First command was not accepted:

rkscli: set qos directed multicast disabled
usage: set qos...
    set qos heuristics {voice|video} classify <octet count>
         -- Sets octet count for Heuristic-based classification
    set qos heuristics {voice|video} noclassify <octet count>
         -- Sets octet count for Heuristic-based no-classification window
    set qos heuristics {voice|video} {ipg|pktlen} <minimum> <maximum>
         -- Sets parameters for Heuristic-based classification
    set qos tos classify {voice|video} {<comma separated TOS value(s)>|none}
         -- Sets values for TOS-based classification
    set qos tos mark {voice|video} <TOS value>
         -- Sets TOS values for each type of traffic
    set qos dot1p classify {voice|video} {<comma separated Dot1p value(s)>|none}
         -- Sets values for DOT1P-based classification
    set qos dot1p mark {voice|video} <Dot1p value>
         -- Sets Dot1p values for each type of traffic
    -------------------------------------------------------------

The other two commands were accepted. And...it seems like Sonos is able to connect to the WLAN. I may try reverting back to Unleashed and seeing if the settings you outlined above are available.

Thanks for all the help. I appreciate it!


Photo of Joseph

Joseph

  • 22 Posts
  • 2 Reply Likes
Your welcome. I spent 4 days on this until I figured it out.
Photo of Joseph

Joseph

  • 22 Posts
  • 2 Reply Likes
Yep it works that way and on a zd. But it won’t work from the zd GUI controller. You still have to go to the AP and use the commands.
Photo of Eric Bullock

Eric Bullock

  • 9 Posts
  • 0 Reply Likes
Yep. These were issued while SSH'd into the AP.
Photo of Joseph

Joseph

  • 22 Posts
  • 2 Reply Likes
Yep that’s why it works. How did it go on flashing back to unleashed?
Photo of Joseph

Joseph

  • 22 Posts
  • 2 Reply Likes
Hi Eric
Just propped up a t300  Firmware: 200.6.10.1.312
It worked for me with these settings

Turn off all scanning and load balancing (make your AP as dumb as Sonos)

Set neighbor list report on the radio control setting in the WLAN Radio Resource Management: Enable 802.11k Neighbor-list Report

Make sure that there is only channel 1 available to Sonos

and lastly 802.11d:Support for 802.11d (only applies to radios configured to operate in 2.4 GHz band)

I am listening now..... Lol

Joseph

Photo of Eric Bullock

Eric Bullock

  • 9 Posts
  • 0 Reply Likes
There does not appear to be a way to both disable background scanning AND enabble 802.11k Neighbor-list Report. At least when I un-checked BackGround Scanning the option to check Radio Resource Mgt. was disabled (in WLAN > Advanced Options).

Where is the option to set the directed multicast threshold?
Photo of Eric Bullock

Eric Bullock

  • 9 Posts
  • 0 Reply Likes
Re) 802.11d support. Are you saying to disable it?
Photo of Joseph

Joseph

  • 22 Posts
  • 2 Reply Likes
Enable d
Enable k

Background scanning is in services section
Photo of Joseph

Joseph

  • 22 Posts
  • 2 Reply Likes
There isn’t a option for multicast threshold that is why unleashed is not a good fit for sonos
Photo of Eric Bullock

Eric Bullock

  • 9 Posts
  • 0 Reply Likes
Joseph - I want to say a HUGE THANK YOU for sharing all of this information. I appreciate it very much! The Universe owes you a solid.

:)

Just knowing Unleashed isn't a good fit for Sonos (or vice versa) is huge. In those situations its probably best to just let the Sonos gear set up its own 2.4Ghz mesh network (SonosNet) and let it be.
Photo of Joseph

Joseph

  • 22 Posts
  • 2 Reply Likes
Thank you and you are very welcome. I wouldn’t use a Ruckus AP with Sonos if you are selling this. Your plan is the best. Another option is to use a ZD and dedicate one AP to Sonos and then SSH into that AP and run the commands. From the controller you can put it in its own AP group SONOS 2.4 and then turn off everything but channel 1 It won’t affect the rest of your deployment for non Sonos clients.
Photo of Jeronimo

Jeronimo

  • 244 Posts
  • 26 Reply Likes
You can type the command using "ap-mode" on ssh into Unleashed.

ruckus# ap-mode
You have all rights in this mode.
ruckus(ap-mode)# set qos

If you don't find "ap-mode", it's old versions for UAP.

If so, you can type the command using remote-ap-cli -a 'ap mac' "set qos ~~~" on debug mode into ssh of UAP.