Does band steering work for open wlans?

  • 1
  • Question
  • Updated 3 years ago
We have sites with 70% apple devices but see very little on the 5GHz radios. Does band steering work for open wlans?
Photo of Salvatore Buscemi

Salvatore Buscemi

  • 24 Posts
  • 3 Reply Likes

Posted 4 years ago

  • 1
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
It shouldn't make any difference in relation to the encryption setting. What might be making a difference is

a) Older Apple devices that don't support 5Ghz
b) 2.4Ghz has better signal propagation. If you are not deployed for "saturation" in the 5Ghz range, devices might see 2.4 more often (including outdoors, etc where you might not intend/expect coverage..)
c) You have mesh enabled (this might be the culprit...)

-K
Photo of Salvatore Buscemi

Salvatore Buscemi

  • 24 Posts
  • 3 Reply Likes
I'm sure there are some older apple devices, but these sites are 70% apple, and we only see maybe 25% connected to 5GHz. APs are quite dense, and avg. signal according to the zonedirector is >60%
Looking at one AP, I'll see 10 client devices, 9 of them are ipads and iphones, and maybe on will be connected at 5GHz. All are reporting good signal strength.

I know I asked about mesh in another thread, but these two are unrelated. We do have many sites with similar ruckus deployments. Oddly enough, I saw no increase in the percentage of clients on 5GHz at the site where I removed the mesh settings.

I just dont see any evidence that band steering is working at all. How can we adjust the rssi thresholds to make it more aggressive?
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
Try this from the ZD CLI:

remote_ap_cli -A get band-steering

If you disabled mesh by factory reset, then it should be enabled. If you disabled mesh via any other method, it's still "on" and band-steering on the APs will be disabled.
Photo of Salvatore Buscemi

Salvatore Buscemi

  • 24 Posts
  • 3 Reply Likes
Mesh was disabled by a factory reset. Do the outputs below mean band steering is off?
ruckus# show mesh info
Mesh Settings:
Mesh Status= Disabled
---- Command 'rkscli -c "get band-steering "' executed at 54:3d:37:14:5a:a0
Band Steering:
Under Mesh AP : Off
OK
---- Command 'rkscli -c "get band-steering "' executed at 8c:0c:90:17:da:d0
Band Steering:
Under Mesh AP : Off
OK
---- Command 'rkscli -c "get band-steering "' executed at 8c:0c:90:14:e1:20
Band Steering:
Under Mesh AP : Off
Photo of Michael Brado

Michael Brado, Official Rep

  • 1810 Posts
  • 263 Reply Likes
Yes,the APs are reporting that band-steering is currently OFF. They had
to be configured this way. Notice that a 7025 with only one radio,
reports “command is not recognized”.

- Michael

ruckus(debug)# remote_ap_cli -A "get band-steering"
---- Command 'rkscli -c "get band-steering "' executed at c4:10:8a:10:e2:60
Command is not recognized: get band-steering
---- Command 'rkscli -c "get band-steering "' executed at 50:a7:33:11:40:70
Band Steering:
Under Mesh AP : On
OK
---- Command 'rkscli -c "get band-steering "' executed at 58:93:96:0d:b9:d0
Band Steering:
Under Mesh AP : On
OK
---- Command 'rkscli -c "get band-steering "' executed at c4:10:8a:1f:d4:a0
Band Steering:
Under Mesh AP : On
OK
---- Command Execution Summary:
success: 4
failure: 0
total: 4
ruckus(debug)#

ruckus(debug)#
ruckus(debug)# remote_ap_cli -A "get version"
---- Command 'rkscli -c "get version "' executed at c4:10:8a:10:e2:60
Ruckus 7025 Multimedia Wall Pluggable Wireless AP
Version: 9.6.1.0.15
OK
---- Command 'rkscli -c "get version "' executed at 50:a7:33:11:40:70
Ruckus 7962 Multimedia Hotzone Wireless AP
Version: 9.6.1.0.13790099
OK
---- Command 'rkscli -c "get version "' executed at 58:93:96:0d:b9:d0
Ruckus 7363 Multimedia Hotzone Wireless AP
Version: 9.6.1.0.15
OK
---- Command 'rkscli -c "get version "' executed at c4:10:8a:1f:d4:a0
Ruckus 7982 Multimedia Hotzone Wireless AP
Version: 9.6.1.0.15
OK
---- Command Execution Summary:
success: 4
failure: 0
total: 4
ruckus(debug)#
Photo of Salvatore Buscemi

Salvatore Buscemi

  • 24 Posts
  • 3 Reply Likes
Hmm. I've checked a few other sites where mesh has never been enabled, and they all show the same thing. The only site I've found that has band steering enabled is the site where we have 7055s

How would I turn it on. And how would it have been turned off in the first place.
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
Yes, interesting questions. Let's start with what version of ZoneFlex are you running now, and if you did an upgrade recently, what was the prior version?

As to turning it on, why don't we try doing it on a single AP via the CLI first. Here's the syntax:

get band-steering <wlan name> -- Get band steering RSSI threshold
set band-steering <wlan name> mesh-ap {enable|disable} rssi --
Enable band steering, modify RSSI threshold
Example rkscli: get band-steering
Band Steering:
Under Mesh AP : Off
OK
rkscli: set band-steering mesh-ap enable 20
OK
rkscli: get band-steering wlan0
Band Steering:
Under Mesh AP : On
RSSI Threshold: 20
OK
Photo of Salvatore Buscemi

Salvatore Buscemi

  • 24 Posts
  • 3 Reply Likes
Firmware version 9.6.1.0 build 15
recently upgraded from 9.5 something, but I've checked sites with 9.4, 9.5 9.6 and they're all the same.
Previously
rkscli: get band-steering wlan0
Band Steering:
Under Mesh AP : Off
RSSI Threshold: 20
OK
rkscli: get band-steering wlan1
Band Steering:
Under Mesh AP : Off
RSSI Threshold: 20
OK
rkscli: get band-steering wlan32
Band Steering:
Under Mesh AP : Off
RSSI Threshold: 20
OK
rkscli: get band-steering wlan33
Band Steering:
Under Mesh AP : Off
RSSI Threshold: 20
OK

I set one ap "set band-steering mesh-ap enable 20"
and get
rkscli: set band-steering mesh-ap enable 20
OK
rkscli: get band-steering
Band Steering:
Under Mesh AP : On
OK
rkscli: get band-steering wlan0
Band Steering:
Under Mesh AP : On
RSSI Threshold: 20
OK
rkscli: get band-steering wlan1
Band Steering:
Under Mesh AP : On
RSSI Threshold: 20
OK
rkscli: get band-steering wlan32
Band Steering:
Under Mesh AP : On
RSSI Threshold: 20
OK
rkscli: get band-steering wlan33
Band Steering:
Under Mesh AP : On
RSSI Threshold: 20
OK
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
So...I think the test would be for devices on that AP, turn their wlan off/on (or re-boot) and see if the band-steering ratio looks better. Meanwhile I will go chase engineering to see what's going on...

Oh...and just to cover all bases...you have the same SSID configured on both radios, right?
Photo of Salvatore Buscemi

Salvatore Buscemi

  • 24 Posts
  • 3 Reply Likes
Yes, same SSIDs on both radios
Photo of Salvatore Buscemi

Salvatore Buscemi

  • 24 Posts
  • 3 Reply Likes
Are we sure we're all reading that output correctly? From a site with mesh enabled:

ruckus# show mesh info
Mesh Settings:
Mesh Status= Enabled
Mesh Name(ESSID)= Mesh-361208000373
Mesh Passphrase= LYbntyRkYRNumH0D0MhXqhNN6HpYcvYLK8df5Z6C52 cvQ1o0ielnAGywHOJKOC
Mesh Hop Detection:
Status= Disabled
Mesh Downlinks Detection:
Status= Disabled
Tx. Rate of Management Frame= 2Mbps
Beacon Interval= 200ms
ruckus# debug
ruckus(debug)# remote_ap_cli -A get band-steering
---- Command 'rkscli -c "get band-steering "' executed at 8c:0c:90:17:70:00
Band Steering:
Under Mesh AP : On
OK
---- Command 'rkscli -c "get band-steering "' executed at 8c:0c:90:3c:6f:00
Band Steering:
Under Mesh AP : On
OK
---- Command 'rkscli -c "get band-steering "' executed at 8c:0c:90:3b:b2:00
Band Steering:
Under Mesh AP : On

ruckus(debug)# remote_ap_cli -A get band-steering wlan0
---- Command 'rkscli -c "get band-steering wlan0 "' executed at 8c:0c:90:17:70:00
Band Steering:
Under Mesh AP : On
RSSI Threshold: 20
OK
---- Command 'rkscli -c "get band-steering wlan0 "' executed at 8c:0c:90:3c:6f:00
Band Steering:
Under Mesh AP : On
RSSI Threshold: 20
OK
---- Command 'rkscli -c "get band-steering wlan0 "' executed at 8c:0c:90:3b:b2:00
Band Steering:
Under Mesh AP : On
RSSI Threshold: 20
OK
---- Command 'rkscli -c "get band-steering wlan0 "' executed at 8c:0c:90:16:1e:00
Band Steering:
Under Mesh AP : On
RSSI Threshold: 20
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
OK, a couple of corrections - first you can use band-steering AND have mesh as of 9.3.

Second - proper syntax for the relevant AP CLI commands:


rkscli: set band-steering mesh-ap enable
OK
rkscli: get band-steering
Band Steering:
Under Mesh AP : On
OK
rkscli: get band-steering wlan0
Band Steering:
Under Mesh AP : On
RSSI Threshold: 20
OK
rkscli: set band-steering wlan0 1
OK
rkscli: get band-steering wlan0
Band Steering:
Under Mesh AP : On
RSSI Threshold: 1



Note that you basically run the command twice with different arguments - first to enable and second to set the RSSI threshold.
Photo of Salvatore Buscemi

Salvatore Buscemi

  • 24 Posts
  • 3 Reply Likes
I don't want to beat a dead horse, but according to the 9.3 release notes, that's not correct.

Ruckus Wireless ZoneFlex 9.3
(FlexMaster, ZoneDirector and ZoneFlex Access Points)
Release Notes

Band Steering
5.2.59 Band steering is disabled on mesh-enabled APs

I haven't found in subsequent releases where that's been corrected.
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
If you actually turn mesh on you see a different (and redundant) message - see below. It's then active. The writer of the release notes was confused for the same reason I was - the CLI output is horribly confusing. Scheduled to be corrected in 9.8
Photo of Salvatore Buscemi

Salvatore Buscemi

  • 24 Posts
  • 3 Reply Likes
Any clues as to why or how it was turned off?

Also, when you change something via the remote ap cli, does it auto save?
will later AP installations need to have that same command run? I'm lost as to why we need to turn on an "on by default" feature.
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
I just did a simple test with a Samsung S4 client and a 7055 (9.6.1) with an open SSID of "Band-steering" on wlan0 and wlan8.

First I set wlan0(2.4G) to an RSSI of 1 and left wlan8(5G) at 20. I could not connect to the 5Ghz.

Then I set wlan8 to 1 and wlan0 to default of 20. I could not connect to the 2.4.

So..yes it works. I think the only remaining question is why it seems to be defaulting to "off".

I ran another simple test - I factory defaulted the same unit - band-steering was "off" - so I think we (accidentally?) changed the default somewhere in recent code.
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
Mystery solved - it's not "off" - only if the RSSI value is 0 is it off. (all agree the CLI needs improvement..coming in 9.8). The [Under Mesh AP] status changes to "On under mesh AP" if mesh is actually configured.

@Salvatore - we're back to other explanations for why you're not seeing it be more aggressive. Have you had a chance to play with different RSSI values?
Photo of Salvatore Buscemi

Salvatore Buscemi

  • 24 Posts
  • 3 Reply Likes
so what is happening with the "set band-steering mesh-ap enable" command.

rkscli: get band-steering
Band Steering:
Under Mesh AP : On
OK
rkscli: get mesh
Mesh is not enabled
OK

To answer your question, no I haven't adjusted the thresholds.

would leaving the default 20 on 2.4, but lowering 5GHz to say 17 cause more band steering?
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
If you set it to 1 all 5Ghz capable clients will go to the 5Ghz radio - maybe try that value first, and then if it causes any issues with areas of lower RSSI, raise it up perhaps 5 at a time.
Photo of Jason Vore

Jason Vore

  • 5 Posts
  • 0 Reply Likes
I know that I'm a couple months late getting in on this discussion, but I have the same question as Salvatore.

Should we leave the 2.4 WLANs at the default of 20 and only lower the 5 GHz WLANs to 1? Or should we lower the RSSI for all WLANs to 1?

Thanks!
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
Ideally, just leave things at the defaults unless you are seeing the problem that Salvatore saw.

If you do change the RSSI threshold - set them on both radios.

https://support.ruckuswireless.com/an... talks about this and some other options.

Our own testing shows IOS devices are extremely aggressive about connecting to 2.4 for reasons only Apple can explain.
Photo of Jason Vore

Jason Vore

  • 5 Posts
  • 0 Reply Likes
I'm seeing similar problems with Android tablets on our network. They are being very aggressive with connecting to 2.4 GHz as well.

One more question. If I wanted to increase the withholding-limit, would I also do that identically on both radios? Or, would I only increase the withholding-limit on the 2.4 radios?

Thanks!
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
I think technically you could just do it on the 2.4 (the 2.4 radio is actually doing all the deciding - whether to send de-auths, withold probes, etc), but we're recommending setting both radios identically.

Toggling airplane mode might help the clients that tend to stick to 2.4, and also have them forget the 2.4 wlans (if you have any with distinct SSID)
Photo of Bill Burns

Bill Burns, AlphaDog

  • 203 Posts
  • 38 Reply Likes
Sal:
Are your issues resolved?

"band-steering" can cause clients to roam to other 2.4Ghz radios instead of the local 5Ghz radio.

If you've got a high density of APs, this may account for the majority of clients being on 2.4Ghz instead of 5Ghz.

If that's what's going on, making changes like ofdm-only and bss-minrate may help.
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
Resurrecting an old thread. We found that a default setting in the AP's may not be optimal for some clients - so if you are seeing poor band-balancing results try (on the AP)

set rpmkey wifi0/wlan-withholding-limit 7

This ups the number of probe/auths to 7

Preliminary testing shows this improves the band-balancing behavior for some stubbornly 2.4ghz clients without adversely affecting others. But you should test on your own client sets and be prepared to set it back to default (1) if you see adverse effects.
Photo of Jason Vore

Jason Vore

  • 5 Posts
  • 0 Reply Likes
Keith,

Just wanting to clarify one thing. I'm assuming you the have wifi1/wlan-withholding-limit set to 1?
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
I believe that's correct but have not yet had a chance to verify.