different VLAN per SSID, zd1200 10.1.1 fw

  • 1
  • Question
  • Updated 2 months ago
I am having difficulties creating a different VLAN per SSID. I don't know if I missed something. below is my setup;

Zd1200 fw 10.1.1

Cisco layer 3

vlan 1 - 192.168.11.1

vlan10 - 192.168.10.1

------------------

ip subnet-zero

ip routing

ip dhcp excluded-address 192.168.10.0 192.168.10.10

!

ip dhcp pool ruckus

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

dns-server 8.8.8.8

!

ip dhcp pool vlan1

   network 192.168.11.0 255.255.255.0

   default-router 192.168.11.1

   dns-server 8.8.8.8

!

 

!

spanning-tree mode pvst

spanning-tree etherchannel guard misconfig

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

!

interface FastEthernet1/0/1

no switchport

ip address dhcp

!

interface FastEthernet1/0/11 -ZD CONTROLLER

switchport mode access


interface FastEthernet1/0/35 -AP

switchport trunk encapsulation dot1q

switchport trunk native vlan 80

switchport trunk allowed vlan 1,10,80

switchport mode trunk


interface Vlan1

ip address 192.168.11.1 255.255.255.0

!

interface Vlan10

ip address 192.168.10.1 255.255.255.0

!

ip default-gateway 192.168.1.1

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.1


FOR ZD

-What I just did is I entered the VLAN in SSID config.

- I entered native VLAN 80 under SYSTEM SETTING >management interface


thanks,

JR

Photo of *BATMAN*

*BATMAN*

  • 9 Posts
  • 2 Reply Likes

Posted 2 months ago

  • 1
Photo of abi

abi

  • 30 Posts
  • 8 Reply Likes
Hi Batman,


AP/ZD Vlan 80

Let's say SSID 1 is vlan 1 and SSID 10 is vlan 10.


Configuration needed on ZD.


Configure>>WLAN>>SSID 1>> ACCESS VLAN 1

Configure>>WLAN>>SSID 10>> ACCESS VLAN 10


Configuration needed on switch.


Port where ZD is connected Access vlan 80.

Port where all APs are connected.

Native vlan 80

Tag all other vlans


The above configuration should work.


All APs and ZD would get it address from vlan 80, clients connecting to SSIDs/WLAN would get IP from respective vlans.


If possible please change vlan 1 to any other if possible.


Regards,

Abilash PR.
(Edited)
Photo of Joseph

Joseph

  • 22 Posts
  • 2 Reply Likes
Can you please  try to change your controller port to mirror your AP port

Your ZD needs a trunk port


interface FastEthernet1/0/35 -AP   <<<<<<<PUT ZD on a port like this one that you configured

switchport trunk encapsulation dot1q

switchport trunk native vlan 80

switchport trunk allowed vlan 1,10,80

switchport mode trunk