Different VLAN for different SSID

  • 1
  • Question
  • Updated 4 months ago
  • Answered
Hello,

I have a SmartZone - Essential 3.6.1.0.227 with 4 AP R500.
Our configuration now is:

2 SSID with default VLAN, client take IP address from Windows DHCP Server, 10.80.1.0/24

I would like to keep this configuration for 1 SSID (network laptop) and for the second SSID I would like to create other VLAN that can provide this subnet 10.80.2.0/24.
Could I use the built-in DHCP in SmartZone instead of the windows one for the second VLAN ?

Thanks in advance
Regards,
Leandro
Photo of Roberto Baccara

Roberto Baccara

  • 18 Posts
  • 4 Reply Likes

Posted 4 months ago

  • 1
Photo of U. Richards

U. Richards

  • 9 Posts
  • 3 Reply Likes
Hi Leandro,

Great question! 

A possible, but more complex way to do it:
There are a number of ways you may go about accomplishing this, but if you were to use a second SSID, you can specify a specific VLAN under Menu -> Wireless LANs -> then select the Zone in your domain, the domain being System by default.  Under the Zone, you will select your SSID 2, that you want to use the subnet 10.80.2.0/24 on, and once the SSID has been selected, you will click Configure, scroll all the way down to the bottom and then click to expand Advanced Options, and on the 7th field down, you will see Access VLAN: VAN ID, where you can enter the desired VLAN number into the box, click OK to save, and then it will use the network assigned to that VLAN for DHCP on that second SSID.

Additionally, you may want to go under Menu -> Services & Profiles -> DHCP & NAT, and select the desired Zone that your AP that is broadcasting SSID 2 in. From there, you can have the option to enable the DHCP service locally, which will be handled globally for that Zone by Ruckus, however, you may need to create a second Zone and place the AP into that Zone that will be serving SSID 2 on the 10.80.2.0/24 network so that it doesn't interfere with the other APs and SSIDs in that Zone.  You may also adjust, and setup the DHCP Pools setting as well for the desired Zone, once DHCP is enabled for that Zone.

However please keep in mind that that this will delegate DHCP control to the Ruckus Controller instead globally for that Zone. 
Given the information you provided, to accomplish what you'd like, I would not go this route.

Best Solution:
Instead, I would log into your Window DHCP server, and setup a new network for 10.80.2.0/24, and place that new network exclusively on it's own VLAN.  From there, I would go to the Wireless LANs Menu, select SSID 2, and Hit Configure, then scroll down to Advanced Options, and specify the newly created VLAN you made on your Windows DHCP server, and then assign/input that VLAN number into the VLAN ID box for that specific SSID 2 on the Ruckus Controller.  This will enable you to maintain both APs in the same zone, while allowing you to customize the IP address that is assigned based on the SSID the client is connecting to, and route those DHCP requests from the client, to the appropriate VLAN that had been assigned in the Advanced Settings of the specific SSID.

Also be sure the port connecting your AP R500 to the network is in Trunk Mode, so it is able to see all available VLANS.  If this isn't configured, you may run into some trouble.

If you require further clarification or guidance, please don't hesitate to reach out!  
I'll be happy to answer any questions you may have!

TL;DR There are many ways to do this, but would recommend configuring the DHCP settings on the DHCP server, and assigning the network settings to a specific VLAN, and having the SSID 2 operate on that new VLAN. 
(Edited)
Photo of Roberto Baccara

Roberto Baccara

  • 18 Posts
  • 4 Reply Likes
Hello,

I agree to set with the second option you said.
I set the port in trunk mode where the AP is connected but I can't ping anymore the AP, is there any configuration that I have to modify on AP setting ?

Regards,
Leandro
Photo of Roberto Baccara

Roberto Baccara

  • 18 Posts
  • 4 Reply Likes
Hello,

I've revert the switch port setting as my default, in this way my AP is ONLINE on vSZ.
Change the VLAN on AP setting and then change switch port setting, it works like a charm!
Thanks for the support.

Regards,
Leandro
Photo of U. Richards

U. Richards

  • 9 Posts
  • 3 Reply Likes
I am happy to hear you were able to get it up and running Leandro!

If you found my advice to be helpful in your endeavor, please feel free to hit the "Like" button.

Kind regards,
U.
Photo of Michael Brado

Michael Brado, Official Rep

  • 2534 Posts
  • 348 Reply Likes
You get a thumbs up from me!  (haha, Archer gif in your sig)
Photo of Roberto Baccara

Roberto Baccara

  • 18 Posts
  • 4 Reply Likes
Hello,

now, as I write, it works fine.
Except one thing regarding one SSID and DHCP.
I create another SSID (with WPA2) with "User Traffic" rules. The same rule that I use for a SSID for a guest access Free_WiFi that works fine.
With the new SSID, my mobile phone can't take IP address, if I allow all on the "User Traffic" my mobile phone take IP address correctly.

What I can verify ?

Regards,
Leandro