DHCP Superscope ZD Discovery problem

  • 1
  • Question
  • Updated 3 years ago
We have a DHCP Superscope setup with 2 different IP address ranges. I have a problem where if the APs get an address from the same range the ZD is on that they work but if they get an address from the other range then they do not see the ZD.

If I set the IP address manually on an AP then it sees the ZD and becomes managed but if I then turn it back to DHCP if fails to see the ZD again. I thought it would learn the ZD IP and continue to work?

All required Ruckus ports are open on the router than enables the ranges to work together and we have no problem with general clients access these ports or services.

There is mention about adding DHCP Option 43 for ZD discovery. Is this needed in this environment? There is also mention about using a DNS entry of zonedirector.domin to provide the ZD IP address - again would this help?

TIA
Photo of Andrew Manning

Andrew Manning

  • 7 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Sid Sok

Sid Sok, Official Rep

  • 102 Posts
  • 48 Reply Likes
Andrew,

I assume that when you statically set the IP manually and it sees the ZD, you mean that you set it so the "other" range. This as you say indicate that all the required port are open.

When the AP get it's IP from the other range it needs to be told what the ZD's IP is so it would know to talk to the GW or not. As you already found in this configuration you need to do one of two things:

1) DHCP option 43 so, just like when it's statically configured it will know the IP of the ZD and know that it's out side the APs subnet so need to communicate to the ZD via the GW.

2) Without DHCP option 43, the AP will by default look for "zonedirector" or "zonedirector.domain" and if an AP looks for the ZD and DNS returns an IP of the ZD, the AP will again know if the ZD is in it's subnet or not and if not will need to communicate with it via the GW.