dhcp server failing to lease. am I missing something? fastiiron gs 648 runnung layer 3

  • 1
  • Question
  • Updated 1 month ago
  • Answered
i'm trying to set up a dhcp server on my gs648p running layer 3. nothing gets a lease from it.

this is my log

0d00h07m38s:A:DHCPS: Exhausts all allocation methods, no address pool found from received port 1
0d00h07m29s:A:DHCPS: unable to find an address pool for rx port 1, dropping DHCPOFFER message
0d00h07m29s:A:DHCPS: Exhausts all allocation methods, no address pool found from received port 1
0d00h07m21s:A:DHCPS: unable to find an address pool for rx port 1, dropping DHCPOFFER message
0d00h07m21s:A:DHCPS: Exhausts all allocation methods, no address pool found from received port 1
0d00h07m13s:A:DHCPS: unable to find an address pool for rx port 1, dropping DHCPOFFER message
0d00h07m13s:A:DHCPS: Exhausts all allocation methods, no address pool found from received port 1
0d00h07m04s:A:DHCPS: unable to find an address pool for rx port 1, dropping DHCPOFFER message
0d00h07m04s:A:DHCPS: Exhausts all allocation methods, no address pool found from received port 1
0d00h07m00s:A:DHCPS: unable to find an address pool for rx port 1, dropping DHCPOFFER message
0d00h07m00s:A:DHCPS: Exhausts all allocation methods, no address pool found from received port 1
BR-r2>

here's my config
ver 07.2.02aT7e1
!
module 1 fgs-48-port-management-module
!
!
!
!
vlan 1 name DEFAULT-VLAN by port
 router-interface ve 1
!
vlan 10 by port
 untagged ethe 0/1/1 to 0/1/2 ethe 0/1/13 to 0/1/14
 router-interface ve 10
!
!
!
!
!
!
!
!
aaa authentication web-server default local
aaa authentication enable default local
boot sys fl sec
hostname r2
ip dhcp snooping vlan 10
ip dhcp-server enable
ip dhcp-server server-identifier 192.168.1.4
!
ip dhcp-server pool studios
 dhcp-default-router 192.168.1.4
 dns-server 192.168.1.4
 domain-name lincolncityradio.com
 excluded-address 192.168.11.150
 excluded-address 192.168.11.1 192.168.11.20
 excluded-address 192.168.11.101 192.168.11.120
 excluded-address 192.168.11.201 192.168.11.210
 excluded-address 192.168.11.240 192.168.11.254
 lease 0 2 0
 network 192.168.11.0 255.255.255.0
 deploy
!
ip dns domain-name lincolncityradio.com
username tech password .....
web-management enable vlan 1
no port bootp
interface ethernet 0/1/1
 dhcp snooping trust
!
interface ethernet 0/1/2
 dhcp snooping trust
!
interface ethernet 0/1/13
 dhcp snooping trust
!
interface ethernet 0/1/14
 dhcp snooping trust
!
interface ve 1
 ip address 10.10.1.4 255.255.255.0
 ip address 192.168.1.4 255.255.255.0
!
interface ve 10
 ip address 10.10.10.252 255.255.255.0
 ip address 192.168.11.4 255.255.255.0
!
!
!
!
!
!
ip ssh  source-interface ve 1
!
!
end

as you can see i have bound the dhcp to the ports on vlan 10 bu it fails to lease. am i missing something?

thank you.


Photo of frank b

frank b

  • 11 Posts
  • 1 Reply Like

Posted 1 month ago

  • 1
Photo of Mohand Sellal

Mohand Sellal, Employee

  • 4 Posts
  • 0 Reply Likes

Hello Frank,

Please remove the “no port bootp” from the config and check it again.

Regards,







Photo of frank b

frank b

  • 11 Posts
  • 1 Reply Like
Thanks. I just tried that. it made no difference. 

Photo of Michael Brado

Michael Brado, Official Rep

  • 2507 Posts
  • 344 Reply Likes
Can you have DNS-Server and DHCP-Default-Router 192.168.1.4, on the 192.168.11.0/24 subnet?
Photo of frank b

frank b

  • 11 Posts
  • 1 Reply Like
thanks but my new config doesn't have  the no bootp option. also i changed the pool 10 192.168.10 rather than 11 which now matches ve10 ip. still not working though. 
Photo of Mohand Sellal

Mohand Sellal, Employee

  • 4 Posts
  • 0 Reply Likes
Please update your code to 07202r.

From above config we see no port bootp just above the eth 0/1/25,

no port bootp
interface ethernet 0/1/25
dual-mode

Do you have the DHCP client directly connected to the switch? have you ran a pcap to see if the DHCP Discover into the switch?

Thanks,
Photo of frank b

frank b

  • 11 Posts
  • 1 Reply Like
that's odd. i did not port that in. How do i turn that off?  and how do i update my code to 07202r. ?
Photo of Mohand Sellal

Mohand Sellal, Employee

  • 4 Posts
  • 0 Reply Likes

To remove the no port bootp from the config you need to enter “port bootp”

 

Here is the link to download the code the https://support.ruckuswireless.com/software?filter=125#firmwares

 

Ruckus FastIron code 07.2.02r applies to your GS648P


 






Photo of frank b

frank b

  • 11 Posts
  • 1 Reply Like
thank you. i need premium membership to update the firmware. i don't have that.
Photo of Michael Brado

Michael Brado, Official Rep

  • 2507 Posts
  • 344 Reply Likes
I don't know what a GS-648P switch is, but Brocade "gave" Ruckus the old Foundry lines of FastIron CX, SX, WS, EdgeX, and TurboIron but not any "GS" line.

The lowest version of FastIron firmware we provide is 7.3 so no 7.2.x is available from Ruckus.  We don't officially support your product it seems, so all hope
must come from previous Brocade way back folks, if any are here, thanks.
Photo of frank b

frank b

  • 11 Posts
  • 1 Reply Like
it was them that sent me here
Photo of Jon Maiman

Jon Maiman, Employee

  • 8 Posts
  • 4 Reply Likes
The FGS is an older Foundry switch model that is EOL.   The 7.2.x code train is the latest version that can run on it.  Mohand who has already responded on this thread is one of our TAC engineers.   I recommend that you continue to work with him and follow his guidance.
Photo of Michael Brado

Michael Brado, Official Rep

  • 2507 Posts
  • 344 Reply Likes
Agree, thanks Jon.  
(Edited)
Photo of frank b

frank b

  • 11 Posts
  • 1 Reply Like
funny. i remove the no port bootp from the config. save it and when i restart it's back again. wierd. On the plus side recabling fixed the dhcp problem. i wouldn't mind the 7.2 formware but you can only get that with a premium account. I don't know how much that is and as i'm en employee for the company that owns this box. i would have to put it past them.