DHCP server created on switch can't bind IP address

  • 1
  • Question
  • Updated 11 months ago
  • Answered
Hi,

I have an ICX6610 that I wanted to test some subnets on an SRX 240 firewall. On my SRX I have an interface that's configured as a DHCP client. If I connect a cord between that port and another switch that has DHCP from an SSG firewall, I get an IP bound.

But if I connect it to a port on the 6610 I get the offer but there is no binding on the SRX. The 6610 though sees it as bound. After around a minute or so the SRX port returns to INIT state.

How can I investigate DHCP issues on the 6610?

Here's my config:
vlan 20 by port
untagged ethe 1/1/2
router-interface ve 20
!

ip dhcp-server enable
!
ip dhcp-server pool dhcp20
dhcp-default-router 192.168.20.254
excluded-address 192.168.20.100 192.168.20.254
lease 1 0 0
network 192.168.20.0 255.255.255.0
deploy
!

interface ve 20
ip address 192.168.20.254 255.255.255.0
!
[email protected] Router#show ip dhcp-server binding
Bindings from all pools:
IP Address Client-ID/ Lease expiration Type
Hardware address

192.168.20.1 288a.1c40.e8cd 000d:23h:59m:37s Automatic
I have no VLANs configured on the SSG/SRX port. I thought I could define a VLAN and untag the port on the ICX and it should work. The port works with a notebook running Windows. Is there anything more I must add to the configuration?


Thanks!

Photo of klui

klui

  • 5 Posts
  • 0 Reply Likes

Posted 11 months ago

  • 1
Photo of Hashim Bharoocha

Hashim Bharoocha, Employee

  • 65 Posts
  • 39 Reply Likes
Hey K Lui,
It seems to be working as you already served an IP Address.

Your config is good, your Pool is for vlan 20 ONLY,  but it ONLY has one port, all devices connecting to VLAN 20 will get DHCP served.
Please add more ports to VLAN 20.

Hope this helps.

Thanks
Hashim