DHCP option 43 on Fortigate

  • 1
  • Question
  • Updated 2 months ago
I currently have a Fortigate 61E in a lab that use remotely to plug Ruckus APs in to a local switch to provision to a vSZ I have running in a datacenter. I'd like to provision them automatically with option 43 but everything I've tried on my Fortigate has been unsuccessful. It won't pass the code to the AP. Has anyone else got this working? the IP address is public since it's in my datacenter. If I manually add the IP address to the AP via web interface or CLI, it works fine. However, with option 43, the AP does not populate the SCG IP. 

Any pointers would be appreciated.
Photo of Joshua Lee

Joshua Lee

  • 18 Posts
  • 4 Reply Likes

Posted 2 months ago

  • 1
Photo of Tamer Morcos

Tamer Morcos

  • 11 Posts
  • 1 Reply Like
at DHCP server setting you need to setup additional dhcp server option
create new one with option code 43 type is string then add hexadecimal for your server IP
you can use this website to convert your server ip to hexadecimal code

https://shimi.net/services/opt43/index.php

use ruckus scg option

let me know your feedback


Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 276 Posts
  • 103 Reply Likes
Hi Joshua,

We have a public KBA for this.

https://support.ruckuswireless.com/articles/000004754

Regards,
Syamantak Omer