Decreased battery life on company WiFi

  • 2
  • Question
  • Updated 8 months ago
  • (Edited)
our mobile phones have a decreased battery life, when they are in the company wifi. if they are off the company wifi or in a wifi in the employees homes, battery life is normal.

we are using vSZ with R700/R710 APs. 

are there any settings we could try?
Photo of Bernd Zierhofer

Bernd Zierhofer

  • 5 Posts
  • 2 Reply Likes

Posted 2 years ago

  • 2
Photo of John D

John D, AlphaDog

  • 513 Posts
  • 144 Reply Likes
Wild guesses: Do you have any sort of "disconnect idle users after ____" setting?

Have you tried sniffing the network and seeing if there's a lot of broadcast/multicast traffic that devices have to respond to, like Bonjour?
Photo of Michael Brado

Michael Brado, Official Rep

  • 2870 Posts
  • 399 Reply Likes
Ruckus defaults to a DTIM of 2, which should help save battery life over "constantly aware mode" DTIM=1.

You can increase DTIM on a per-WLAN basis, but it needs to match what the phones are using.

These are AP CLI commands.


- First find the WLAN number in your system:

get wlanlist

rkscli: get wlanlist

name status type wlanID radioID bssid

-----------------------------------------------------------

wlan0 up AP wlan0 0 00:1d:2e:02:79:09

wlan1 up AP wlan1 0 00:1d:2e:42:79:09

Then apply the setting to all voice WLANs.

set dtim-period wlan0 2


set dtim-period wlan1 2




The dtim-period setting can be done either by SSH to each access point or via the Controller to all

access points with the command below.

debug#remote_ap_cli -A set dtim-period wlan0 2


debug#remote_ap_cli -A set dtim-period wlan1 2
Photo of Bernd Zierhofer

Bernd Zierhofer

  • 5 Posts
  • 2 Reply Likes
Hi Michael,

i have tried the DTIM 2 setting, but it does not help. Also Broadcast/Mutlicast is not an issue here, i have tested with a seperate network, only 4 clients in it.



the device was sitting on the desk, with no interaction. see the drop in the screenshot.
Photo of Michael Brado

Michael Brado, Official Rep

  • 2870 Posts
  • 399 Reply Likes
Bernd,

   Can you open a ticket with Tech Support, and help us take a wireless capture
in order to determine what is really happening?  Thanks!
Photo of Bernd Zierhofer

Bernd Zierhofer

  • 5 Posts
  • 2 Reply Likes
so, i have opened a ticket and we have found a solution. 

setting the dtim-period to 5 and the directed-thr to 0. attached the ap-cli script:

#define AP FW version (must match the AP version in the zone)
fw_version=3.4.1.0.819
#define Model class (only option available is 'all')
model=all
# Command (these are examples, any AP CLI command will be accepted; One command per line)
# first SSID on 2,4 and 5GHZ set dtim-period wlan1 5
set dtim-period wlan33 5
set directed-thr wlan1 0
set directed-thr wlan33 0
# second SSID on 2,4 and 5GHZ
set dtim-period wlan3 5
set dtim-period wlan35 5
set directed-thr wlan3 0
set directed-thr wlan35 0
Photo of David Weinberg

David Weinberg

  • 3 Posts
  • 0 Reply Likes
Hello - I am having the exact same issue as the above. Luckily I found this forum, and this thread. The AP unit is a Ruckus R310. 

Did the solution above work? I would love to try this in my situation but do not know how to go about making those updates. Can this be done on the Ruckus side? Or does my building WiFi provider need to do it? 
(Edited)