Decreased battery life on company WiFi

  • 2
  • Question
  • Updated 6 months ago
  • (Edited)
our mobile phones have a decreased battery life, when they are in the company wifi. if they are off the company wifi or in a wifi in the employees homes, battery life is normal.

we are using vSZ with R700/R710 APs. 

are there any settings we could try?
Photo of Bernd Zierhofer

Bernd Zierhofer

  • 3 Posts
  • 1 Reply Like

Posted 7 months ago

  • 2
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 136 Reply Likes
Wild guesses: Do you have any sort of "disconnect idle users after ____" setting?

Have you tried sniffing the network and seeing if there's a lot of broadcast/multicast traffic that devices have to respond to, like Bonjour?
Photo of Michael Brado

Michael Brado, Official Rep

  • 1982 Posts
  • 276 Reply Likes
Ruckus defaults to a DTIM of 2, which should help save battery life over "constantly aware mode" DTIM=1.

You can increase DTIM on a per-WLAN basis, but it needs to match what the phones are using.

These are AP CLI commands.


- First find the WLAN number in your system:

get wlanlist

rkscli: get wlanlist

name status type wlanID radioID bssid

-----------------------------------------------------------

wlan0 up AP wlan0 0 00:1d:2e:02:79:09

wlan1 up AP wlan1 0 00:1d:2e:42:79:09

Then apply the setting to all voice WLANs.

set dtim-period wlan0 2


set dtim-period wlan1 2




The dtim-period setting can be done either by SSH to each access point or via the Controller to all

access points with the command below.

debug#remote_ap_cli -A set dtim-period wlan0 2


debug#remote_ap_cli -A set dtim-period wlan1 2
Photo of Bernd Zierhofer

Bernd Zierhofer

  • 3 Posts
  • 1 Reply Like
Hi Michael,

i have tried the DTIM 2 setting, but it does not help. Also Broadcast/Mutlicast is not an issue here, i have tested with a seperate network, only 4 clients in it.



the device was sitting on the desk, with no interaction. see the drop in the screenshot.
Photo of Michael Brado

Michael Brado, Official Rep

  • 1982 Posts
  • 276 Reply Likes
Bernd,

   Can you open a ticket with Tech Support, and help us take a wireless capture
in order to determine what is really happening?  Thanks!
Photo of Bernd Zierhofer

Bernd Zierhofer

  • 3 Posts
  • 1 Reply Like
so, i have opened a ticket and we have found a solution. 

setting the dtim-period to 5 and the directed-thr to 0. attached the ap-cli script:

#define AP FW version (must match the AP version in the zone)
fw_version=3.4.1.0.819
#define Model class (only option available is 'all')
model=all
# Command (these are examples, any AP CLI command will be accepted; One command per line)
# first SSID on 2,4 and 5GHZ set dtim-period wlan1 5
set dtim-period wlan33 5
set directed-thr wlan1 0
set directed-thr wlan33 0
# second SSID on 2,4 and 5GHZ
set dtim-period wlan3 5
set dtim-period wlan35 5
set directed-thr wlan3 0
set directed-thr wlan35 0