clients not connecting to nearest AP

  • 3
  • Question
  • Updated 3 years ago


I have clients that connect two to three AP's away for some reason when they have an AP in their room and one in the next room. Even when there are not more then ten people on that AP it does it making their signal strength like 50 percent. Am i doing something wrong or?
Photo of Marty

Marty

  • 8 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 3
Photo of Bob Williamson

Bob Williamson

  • 21 Posts
  • 2 Reply Likes
I have seen this as well. I believe there will be a way to tweak this in the next revision (called smart-roam).

I have found that a client be too close to an AP (7363). Not sure why, but being at about 5-8 feet can have a real negative influence.

Hope that helps,
Bob
Photo of Primož Marinšek

Primož Marinšek, AlphaDog

  • 413 Posts
  • 48 Reply Likes
Marty, how far are the other APs?
What model? 7055?

Ruckus has "Band Steering" and it looks like some clients can be persuaded to connect to a different AP. Maybe the one that has fewer clients attached to it.

Maybe the airspace is too saturated with all the APs.
Photo of Max O'Driscoll

Max O'Driscoll, AlphaDog

  • 301 Posts
  • 70 Reply Likes
I see this here in school as well.

Typical scenario 8 classrooms (4 up 4 down) with 2 APs and I'll see 40 laptops in those rooms connect to 1 AP and only a few (5 perhaps) connect to the other AP. Would have expected a little more balancing between the two.

The 7363s seem to handle the numbers fine so it's more a curiosity than problem. I've learnt to ignore it and just be pleased it all works well!

To be clear the laptops are not missing the two nearest APs and picking up a remote one, just a big imbalance in which AP serves majority of clients. So not quite the same as Marty...should have read more closely.

Will post a similar screenie if I get chance early next week.
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
This is a great conversation that's separate from the main topic, so I created a new topic to continue the discussion. Please reference the new topic here: AP load balancing question
Photo of Primož Marinšek

Primož Marinšek, AlphaDog

  • 413 Posts
  • 48 Reply Likes
Here's my theory Marty

I see that you have APs configures on very different channels. There are 2 on UNII1 (36,44) and one in UNII3 on 161. Higher channels usually have higher power limits, so it would make sense to me that clients would choose the AP using the higher channels.

What if you set both APs in the same UNII band?
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
That seems like a pretty smart answer even if it proves false!
Photo of Bill Burns

Bill Burns, AlphaDog

  • 203 Posts
  • 38 Reply Likes
Marty:
Have you gotten a resolution to your issue?

I have seen something similar where a client will connect to a distant AP w/ a much weaker signal and have connectivity problems as a result.

This is especially an issue for dual-band clients that are set to prefer the 2.4Ghz band. (or possibly if there is interference in the 5Ghz band)

When Ruckus load balancing features are turned on, running inSSIDer on a dual-band client will show the 2.4Ghz signal alternating between very stong and non-existant.
This is a result of Ruckus load balancing causing the AP to provide very delayed responses to the client in hopes of steering the client to the 5Ghz band.

Unfortunately, the client may instead associate to a distant 2.4Ghz radio.
(have you gotten tired of hearing that it's the *client* that's responsible for roaming decisions?)

Solutions:
Turn-off a 2.4Ghz band preference on the wifi client (if it has that option) or set it to prefer 5Ghz.
Provide specific SSIDs for only 2.4Ghz and only 5Ghz operation. (which will supress band steering when a client associates w/ one of those specific SSIDs)
More extreme: Provide per-radio SSIDs. (I.E. an extra 2 SSIDs per AP throughout the organization) That way a user can manually choose which AP to associate with.

A (band-aid?) solution that does not involve adding SSIDs might be to turn off load-balancing on the one AP that the client has trouble connecting to.
(That option *might* be available w/ the very latest firmware. Otherwise, it will require a call to tech-support, and that config may not persist through an AP reboot)
This may also have the negative result of causing clients that should have associated with distant APs to associate with the local non-loadbalancing AP.

Let me know if any of that helps.
Photo of Nick

Nick

  • 1 Post
  • 0 Reply Likes
I've had this problem quite often although I'm not using load-balancing but just band-steering.

I'm not sure what type of clients you have, but we use mostly Lenovo T400, T410, T420,and T430's with different Intel adapters and removing the full Intel Wifi Software Suite and replacing with the latest driver-only package + changing the adapter settings for Roaming Aggressiveness from "Medium" to "Medium-High" fixed 95% of those issues. Before we would have notebooks that refused to roam when going to conference rooms, etc.

I know this probably isn't the answer you want to hear (far easier to control it on the AP side) but it was the fix for our environment.
Photo of Bill Burns

Bill Burns, AlphaDog

  • 203 Posts
  • 38 Reply Likes
I was able to replicate the problem on a Lenovo x220. (near one particular AP)
"Intel" driver 14.2.0.10
Roaming aggressiveness is "medium" (the default)

Yup. This issue is related to band-steering.

Glad to hear you found your fix.
It's an academic environment here.
There's no way I can update drivers or settings for all clients.
Photo of Odilo Junior

Odilo Junior

  • 15 Posts
  • 2 Reply Likes
He have issues like that here at the university too, and also got the "it's the *client* that's responsible for roaming decisions".

For instance, I was doing a test at the Library on a private room and my laptop (MB pro) connected to an AP that was behind of another building something like:

My Laptop Library 2nd floor -> 20meters (distance between the buildings) -> another building (2 floors, have others APs) -> 10 meters -> 4th floor AP that my laptop connected. And I was like 5 meters from one of the library's AP. Checked the library AP currently connected users at the time and it had around 40 clients. The AP i was connected had around 20 clients.

It caused some low connections when I was accessing the internet.

We have around 200 zf7962 & zf7363 and now with 9.7 fw version.

We also set, a while ago, with help of Ruckus to avoid clients to connect with 802.11b a.k.a really old wireless cards, we decided to "expand" our area with non wifi signal to guarantee a good quality signal to most of our clients 802.11g/n. But I don't know if this feature stills apply after a lot of FW upgrades. I remember that helps a little with client roaming.
Photo of Primož Marinšek

Primož Marinšek, AlphaDog

  • 413 Posts
  • 48 Reply Likes
You can check if OFDM only is enabled and what the BSS min rate is if you log into ZDs SSH and running the following

# enable
# show wlan all

You will get a list of all your WLANs. Then look for "OFDM-Only State = Enabled" and "BSS Minrate = X Mbps"

Do you have client load balancing enabled?

IT would be nice to see how much your APs "hear" each other. There is a way of seeing this by going to the Monitor :: APs and clicking on an APs MAC address which takes you to the APs details page. There you will find "Neighbor APs" table which lists all the other APs this particular AP can "hear". There you will also see the "Signal" indicator.

Now this isn't by any means the best way of getting proper data to solve your issue, but if you see many audible APs with power greater than 15% you are probably having issues due to too much overlap.

I suspect your APs are really close to each other so raising BSS min rate would probably help a bit. You can try raising it to 24Mbps but probably not more, since you can create other problems that way.
Photo of Marty

Marty

  • 8 Posts
  • 0 Reply Likes
I just turned off client load balancing to see if that would effect it any differently. I have all the latest AP's(7982's) We are a 1:1 school so each student has thier own laptop, around 460ish plus another 100 faculty/admin devices. The student laptops are all single band cards, some of the faculty i put some intel dual band cards but not many.
So if roaming is client based, should i have client roaming up to its highest or lowest?