Clients still getting kicked from AP.

  • 1
  • Question
  • Updated 2 years ago
I think the various questions i am asking are getting lost in other threads so....

Could someone tell me why i'm seeing this...?

"wmi_peer_sta_kickout_event_handler:838 Kicking off STA *************** AID 1"

I am also seeing the above, but with AID 2 at the end.

Thanks.
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes

Posted 2 years ago

  • 1
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
Anyone?
Photo of Sean

Sean

  • 341 Posts
  • 86 Reply Likes
wmi_peer_sta_kickout_event_handler:838 Kicking off STA *************** AID 1:

this could either be inactivity timeout or tx failure in high noise environment

(confirmed by Ruckus support)

As i see it it is normal behaviour and the AP is reacting to something.
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
Do clients ping an AP to keep them connected so that this doesnt happen?.

My environment is reasonably 'noise' free, especially during the night when most of these issue seem to be occurring. 
Photo of Michael Brado

Michael Brado, Official Rep

  • 1979 Posts
  • 275 Reply Likes
I'd open a ticket with tech support and provide your ZD debug/AP support info
and describe your environment and if you're having a problem with one or more
clients, all the same device type or various, and what you're seeing from that
client side.

Single line above is not enough to determine if it's a client roam/leave, or a feature
like band balancing/band steering or SmartRoam, etc.
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
Hi Michael,

I have opened a support ticket for someone to have a look through, even if it is to confirm everything looks correct..

Thanks
Photo of Sean

Sean

  • 342 Posts
  • 87 Reply Likes
What AP are you seeing this behaviour on?

Have you seen it on more than one AP?

What firmware are you running and have you tried other firmware?

Have you done a promiscuous sniff to see whats happening airside?

How is the network confured?

Whats the max-aid value on your radios set too? :
get max-aid wlan0
get max-aid wlan32
(Edited)
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
Thanks Michael, and may well do.

Hi Sean....

It is happening on the R600.

Latest standalone firmware (...432) and yes but still the same.

Rogue AP's are listed but have very weak signals.

Network is 2.4ghz for most clients, and i have 5ghz for my MBP and iPhone6s.

Ill check out the Max Aid values when i get home.



Also, my iphone was the only client connected last night (5Ghz) and it was kicked off (Reason 0) at around 04.11 just after this in the log, which i havent noticed before...

"ieee80211_find_best_vht_channel:2753 ***** pick 20MHz channel 140 flags 0x2201100"
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
not as far as im aware as the above was logged at approx 4am today

This is what i get from the commands you gave above...

 get max-aid wlan0

Max Assoc ID is  512

OK

rkscli: get max-aid wlan32

rkscli: get max-aid wlan8 

Max Assoc ID is  180



wlan0 is what the 2.4 clients & network is operating on and wlan8 is for 5Ghz.

(Edited)
Photo of Sean

Sean

  • 341 Posts
  • 86 Reply Likes
OK so your max-aid value is not impacting clients being kicked or stopping them from connecting.

I would say that unless you are seeing any issues with clients not being able to connect or are being kicked during connection i.e. watching You Tube and then your suddenly offline (other entertainment  websites are available), that there is no reason to be concerned with outputs from the log of the AP.

What I would say is that if you have session idle timeout configured on the AP/ZD then this value should be set to be the same as your DHCP lease value as I have seen this to cause issues in the past

Note: In my home network I have the session idle timeout value within my WLAN on my ZD set to 600 minutes.
(Edited)
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
Thanks Sean,

My DHCP leases on my router are set to the default which is 1500minutes so i guess that rules that out, but then, should my AP match the router or is there no way of altering the AP as im on stand alone firmware?

My iPhone also doesn't seem to always connect straight away when i have been out of the building and return, and sometimes its a fair few minutes before it does connect.

My only reason of concern with the logs is that again i got up this morning to find my phone had dropped back to 4G, and when i checked the log again when i got up, it showed a channel fly, just before the kickoff (AID 1) which now appears the reason that my phone was disconnected, but then reconnected when i unlocked it. (the last actual wifi use was around 11pm as i check emails before i go to bed).

What i don't understand is why it gets kicked (Aid 1, and then also Reason 0) but then doesn't reconnect? There is plenty of signal there.

The frustrating things is, is that this doesn't happen every night, and when it does, the log seems to show a different reason each time, although not always.

If need be, i will open a support ticket, however, i'm not overly convinced there is a solution.
(Edited)
Photo of Sean

Sean

  • 341 Posts
  • 86 Reply Likes
I would monitor the reason Codes and see what your getting.

Reason Code 0 is a funny one as it's reserved:

https://support.ruckuswireless.com/answers/000002430

Usually you see Reason Code 4 or 8 - none of which are anything to worry about.

If you are just having issues with reconnecting on an irregular basis, have you tried other devices and are you seeing the same behaviour, or is it specifically tied to the iPhone?
(Edited)
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
Hi Sean, 

Yes i get the occasional reason 0, and i did find that it was a reserved code, although im sure i saw somewhere that it is also listed as "normal operation" or words to that effect.

Must admit, i certainly havent seen a Reason 4 (inactivity?) code yet.
(Edited)
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
Anyway, apologies for all the questions.

i appreciate that these products are primarily for enterprise use, however, i would like to understand how they work as much as possible so that i can learn what to look out for when ther are problems such as this.

:)
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 136 Reply Likes
Do you still have ChannelFly or SmartRoam enabled? I've definitely noticed that my iPhone, if kicked off a network via SmartRoam, will not bother using the wifi network again for several minutes unless I manually reconnect it.

If you are having random client disconnect problems, I would highly recommend going to a static channel assignment and disabling smart_roam if you had turned it on as a part of your roaming optimization attempts.

I've got a household of 15-20 Apple devices and have not seen any connectivity / disconnection problems with them.
Photo of Bill Burns

Bill Burns, AlphaDog

  • 203 Posts
  • 38 Reply Likes
Thanks for confirming that this (smartroam problem) is "normal".

In my case it seems like the iPhone gets smartroamed back and forth between APs several times, and then gives up on WiFi "permanently". (or until the device gets locked/unlocked, etc.)

There are courtyard areas between buildings where this often happens.

 I've had this user complaint many times, and mentioned it to tech support many times without hearing any explanation/confirmation.

smartroam solves serious roaming problems for me, but if I use it, I shouldn't expect my iPhone devices to work...
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 136 Reply Likes
Yeah, I don't know what's "normal", but it definitely feels like the iOS devices take SmartRoam disassociations to mean "please don't connect to me for a while"... I've found bss-minrate is a more effective mechanism to reduce coverage radius for iOS devices.

I've also found that even for WPA2-PSK networks, enabling 802.11r/k (such as in a controller environment or possibly in Unleashed) causes iOS devices to roam more frequently. Ever since I turned that on, I haven't had a need to further change roaming related settings.
Photo of Sean

Sean

  • 341 Posts
  • 86 Reply Likes
@ Bill

If you have smart roam enable and there is a lot of shifting going on, then I would recommend that you need to adjust your smart roam value
(Edited)
Photo of Bill Burns

Bill Burns, AlphaDog

  • 203 Posts
  • 38 Reply Likes
There has been much tweaking of smartroam values.
At a certain point (with over 100 APs) it becomes overwhelming.
Plus, settings that work fine indoors may not work well for iPhone users that are standing just outside or between buildings. (like when they step outside for a smoke break)
Photo of Dave Watkins

Dave Watkins

  • 61 Posts
  • 12 Reply Likes
Mobile devices always disconnect when not in use to save power, at least every iPhone I've ever had and many Android devices I've seen do. I would consider that completely normal. In the case of my iPhone when I wake it up and unlock it it reconnects and away I go.
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
Hi Dave/all,

I have now disabled SmartSelect and last night after looking through the logs i had no issues with my phone disconnecting.

However, its early days yet as this does happen randomly.

As for roaming, it seems to work ok for 80% of the time, but there are occasions were it takes a minute or two to realise there is a better signal much closer.

It appears to roam better from an R600 to an R500, but sometimes struggles to go roam back from the 500 to the 600. (both running latest stand alone FW).

:) (Edited)
(Edited)
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 136 Reply Likes
Dude, a minute or two is not a long time. A client, when scanning for additional APs, has to spend time not being able to transmit/receive to your AP in order to do a scan. It will only do so periodically, unless its connection to the current AP is so bad that it's worth a fraction of a second of 100% packet loss to search for a better one. 

If you want roaming in more realtime, you'll need 802.11k/v/r support from a controller (or perhaps future Ruckus Unleashed implementations). That allows the controller to inform the client about nearby AP's.
Photo of Sean

Sean

  • 342 Posts
  • 87 Reply Likes
If you have a stand alone AP network look in to using smart roam:

https://support.ruckuswireless.com/answers/000002277

Dont set it too high though and perhaps even doing some cell overlap test to determine your actual coverage to make sure you get the value right

You could use Heat Mapper from Ekahau - windows only:

http://www.ekahau.com/wifidesign/ekahau-heatmapper

Or if you are a mac user I only know off NetSpot:

https://itunes.apple.com/gb/app/netspot-wifi-survey-wireless/id514951692?mt=12

Good luck
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 136 Reply Likes
Yeah, as the SmartRoam article says, I wouldn't set it above 2 or 3. I have mine set at 2, because empirically, 2 is the value where connectivity is so poor I'd rather have the client off wifi than on wifi.
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
I have tried adjusting the settings on the smart roam feature with the AP in the garage as this is the phone my phone likes to hang on to, and i'm now at setting 4 and its doesn't appear to make any difference at all as my phone still likes to hang in there even though the indoor AP is right above it.

Do i need to enable the Smart Road feature in the CLI first, even though i've checked what its set at and adjusted the values?

Thanks!
(Edited)
Photo of Bill Burns

Bill Burns, AlphaDog

  • 203 Posts
  • 38 Reply Likes
Jason:

When it comes to selecting a smartroam value, the smartroam to "RSSI" table that you can find here:
https://support.ruckuswireless.com/answers/000002277
may help.

You should be able to view the "RSSI" values that your Ruckus sees for your client by looking at the GUI.
You may want to select a smartroam value based on what the "RSSI" value is at the point you'd like a roaming event to occur.

note: What Ruckus calls RSSI is really SNR.

note: (AFAIK) Smartroam will only "kick" a client when it transitions from an "RSSI" that's higher than your smartroam value to an "RSSI" that's lower than your smartroam value.
This is to "encourage" the client to associate w/ another AP. If it re-associates w/ the original AP and the RSSI stays lower than the smartroam value, your client won't get another "kick".

note: reported "RSSI" values naturally fluctuate, even when a client remains stationary.
If your client happens to be in a location where its "RSSI" is near the smartroam threshold, it's likely to get "kicked" repeatedly. (if it doesn't roam to another AP)
If your client is near the smartroam threshold of the 2 nearest Ruckus APs, your client is likely to get kicked back-and-forth between APs.
This is bad for connectivity and may cause the client to give up on the idea of using WiFi.

note: At least w/ zondedirectors, the smartroam value is configurable on a per-WLAN basis.
It may be possible to configure a pair of WLANS, each w/ different smartroam values so that your client devices can manually choose the SSID that give them the best roaming behavior.

Or.. You can use the Ruckus "When all else fails" technique of assigning a unique SSID to each AP, so that you can manually select the SSID of the nearest AP.

In some cases, manually selecting AP-unique SSIDs may give you a more reliable experience.
This is essentially giving up on automatic roaming behavior but sometimes it's necessary.

At least, this will be the case until Ruckus comes up w/ the idea of having their APs communicate w/ each other to determine when to "kick" a client, instead of depending on a fixed smartroam threshold.
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
Thanks Bill,

Ive just tried and roamed to the garage and back again.

My phone is still connected to the garage and, if i understand you correctly, the rssi (shown as estimated SNR if i click on the client in the web ui) is right down to 7db with a 55% packet error rate and it is still refusing to let go!!

And i have the Smart roam value set to 4 which should have kicked it off by now

Like you say, it might be better to assign a different SSID for now and see how that works.
(Edited)
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
Both AP's are set to for 2.4 & 5, however, my phone is only paired only to the 5G network


I have Netspot on my Macbook, so ill give that a go for the signal strength.

:)
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
Ok my 5G network on these uploads are the only two ac "modes" that are listed..

This is at the place were the phone is directly underneath the indoor AP...



And this is just were i come into the house from the garage, which is back around the corner...



Just to add, the phone is an iPhone 6s, and the MBP is a Jan 15 vintage.
(Edited)
Photo of Sean

Sean

  • 341 Posts
  • 86 Reply Likes
try the following:
set ofdm-only wlan0 enable
set roam_factor wlan0 4
set bss-minrate wlan0 36000
set roam_factor wlan32 4
set bss-minrate wlan32 36000
reboot now
quit
Note: bss-minrate only affects the 802.11ag standards at the moment (I have ticket open to include MCS), but your client might be falling back and holding on to these rates - you can adjust the bss-minrate to 54000 if required
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
Thanks Sean,

I'll give that a try later.
Photo of JasonS

JasonS

  • 89 Posts
  • 8 Reply Likes
Sean,

A massive thanks for your suggestion as this has worked perfectly!

I adjust the BSS for my 5G network to 54000 in the garage (the R500) and it works first time every time.

Its strange that its only this AP/client that has the problem, but hey, it all works and thats all that matters.

Back on topic, i have had the channels static for a few days and this has also solved the random disconnections i was having with my iphone.

Thanks again to everyone that has helped!

Jason.