Clients disconnection issue

  • 1
  • Question
  • Updated 8 months ago
Hi,

We have some issues about clients randomly disconnected from our Wifi.
It happens frequently without clear reason.
When they are disconnected, the can disconnect and reconnect to the network and it's working fine again.
Our Wlan is configured with WPA2/AES security.
No isolation, no captive portal.
We set the inactivity disconnection to 500minutes.
It's configured to provide a VLAN (33)

Our controller is a ZD1200
Firmware : 9.13.2.0 build 33
Our access points are R500

Do not hesitate if you need some more information.

Thank you for your help !

Matthieu
Photo of Bastien Lefebvre

Bastien Lefebvre

  • 3 Posts
  • 0 Reply Likes

Posted 9 months ago

  • 1
Photo of RS

RS

  • 7 Posts
  • 0 Reply Likes
had seen this issue with ZD3000 and stil having similar issue in Smartzone 100. Sent out multiple OTA captures . Issue still unresolved. All we see on the logs is "reason code 4" - client inactivity timeout and this is happening in IOS devices. Is yours issue the same? @Matthieu
Photo of Bastien Lefebvre

Bastien Lefebvre

  • 3 Posts
  • 0 Reply Likes
We have this issue especially on windows 7 computers.

For mac addresses that are disconnected, we can see this kind of logs :

STA-DISASSOC-REASON [ieee80211_input(),2097,received IEEE80211_FC0_SUBTYPE_DISASSOC] 10:08:b1:a0:9c:a1 rx_rssi=54,ack_rssi=0,reason=8,freq=2452,chan=9,rx pkt,byte;tx pkt,byte=(4712,1061152,75127,11654925).


I can't see some "reason code 4" - client inactivity timeout" in our logs.
Photo of RS

RS

  • 7 Posts
  • 0 Reply Likes
same problem here. Did multiple captures and sent support logs. All we get is reason code 4 as well. It really hard to replicate & customers complain different times of the day in diff location. Not possible to do the entire OTA capture with them.However managed to do OTA but still all Ruckus is saying is reason code 4 . Whats next? BTW this problem started in ZD3000 and still is present in our SZ100 with the latest code.
(Edited)
Photo of Milan Kothari

Milan Kothari

  • 3 Posts
  • 0 Reply Likes
Try setting qos directed threshhold to 70 and check  form controller. 
Photo of Michael Brado

Michael Brado, Official Rep

  • 2518 Posts
  • 345 Reply Likes
QOS directed threshold value does not go to 70!
Photo of Michael Brado

Michael Brado, Official Rep

  • 2518 Posts
  • 345 Reply Likes
...don't go over 5.
Photo of Milan Kothari

Milan Kothari

  • 3 Posts
  • 0 Reply Likes
ruckus>en
2)ruckus#config
3)ruckus(config)#wlan 'your wlan id'
The WLAN service 'your wlan id' has been loaded. To save the WLAN service, type 'end' or 'exit'.
4)ruckus(config-wlan)#

5)ruckus# qos directed-threshold 70

6)ruckus# exit ( type this to save the configuration)
Photo of Bastien Lefebvre

Bastien Lefebvre

  • 3 Posts
  • 0 Reply Likes
Hi, where we find this setting please ?
Photo of Michael Brado

Michael Brado, Official Rep

  • 2518 Posts
  • 345 Reply Likes
From KBA-2849:

Ruckus APs by default convert incoming broadcast and multicast traffic to unicast. This feature has the following benefits:
1. By default both broadcast and multicast traffic go out at a lower data rate over wireless. Converting them to unicast enables the AP to send the data at higher rates. This behavior conserves airtime.
2. It also enables 802.11 acknowledgements. Acknowledgement from a receiver ensures reliable data transfer.

This features is turned on each SSID until the client count reaches 5. This feature gets disabled automatically once a 6th client joins the SSID.

If you have incompatibility issues with any application due to unicast transmission, there are certain commands you can run to disable this behavior even before the client count crosses 5.

These commands need to be run from "wlan" context in ZD CLI.

1. ruckus(config-wlan)# no qos directed-multicast
Above command will disable directed multicast which means a multicast traffic will go out as multicast traffic.
This command has no impact on the directed broadcast behavior which remains enabled.

2. ruckus(config-wlan)# qos directed-threshold 0
This command disables BOTH directed broadcast and directed multicast on the SSID. If there is only a single client, it will receive broadcast traffic as broadcast and multicast traffic as multicast.

Please note that you can specify any number at the end of above line based on your need. For example, it can be 1, 2, 5, or 10,etc. But be careful with any number above 5 since it will have performance impact on the AP.




Photo of Milan Kothari

Milan Kothari

  • 3 Posts
  • 0 Reply Likes
Can you please let  me know what kind of performance issue will be there if i exceed above 5 or 10  or set it to 70?