Cisco AP not getting enough power off a 6430-48P

  • 1
  • Question
  • Updated 4 months ago
  • Acknowledged
I am trying to get my Cisco 3602I with AC Module to work with 30W. I have configured it on the switch saying CDP enable and max power available on the port set to 30000. 


BROCADE:




CISCO:  
Photo of Matthew C

Matthew C

  • 7 Posts
  • 0 Reply Likes
  • pondering

Posted 5 months ago

  • 1
Photo of Jijo Panangat

Jijo Panangat, Employee

  • 37 Posts
  • 13 Reply Likes
Hello Mathew,

It seems like you dont have enough power budget to turn on all PDs. By default with internal power supply 6430-48P can power 24 PoE and 12 PoE+ (802.3at)

With internal and external power supplies, Max is 48 for PoE and 24 PoE+ ports.

Hope that helps.


Thanks
Jijo
Photo of Matthew C

Matthew C

  • 7 Posts
  • 0 Reply Likes
Hello. I have extra PoE power I am just confused why it's not using all the power I allocated...

Power Supply total capacity is 370000 of which 314200 is currently available. Power has been successfully allocated 48 times.

(Edited)
Photo of Jijo Panangat

Jijo Panangat, Employee

  • 37 Posts
  • 13 Reply Likes
Hello Matthew, The cause of failure is not clear, please try upgrading to latest 8030x firmware or open a Tac case for further debugging.

Photo of NETWizz

NETWizz

  • 182 Posts
  • 57 Reply Likes
Good Afternoon:


Below is how I would troubleshoot this if this were assigned to me...



I am personally avoiding 08080t because it has a bug showing the proper boot time/uptime, but regardless 08080sa is working great with everything I have thrown out at.  Most folks won't notice any issue with 08030t.

What is your POE Firmware you are running, too?  The latest is 02.1.0 Build 004

Looking at one of my older installs with an ICX 6430-48P:


[email protected]#show inline power detail


Power Supply Data On stack 1:
++++++++++++++++++



Power Supply Data:
++++++++++++++++++

Power Supply #1:
        Max Curr:       6.8 Amps
        Voltage:        54.0 Volts
        Capacity:       370 Watts
power supply 2 is not present


POE Details Info. On Stack 1 :


General PoE Data:
+++++++++++++++++

Firmware
Version
----------------
02.1.0 Build 004



Cumulative Port State Data:
+++++++++++++++++++++++++++

#Ports    #Ports     #Ports   #Ports    #Ports       #Ports     #Ports
Admin-On  Admin-Off  Oper-On  Oper-Off  Off-Denied   Off-No-PD  Off-Fault
-------------------------------------------------------------------------
48        0          15       33        0            33         5



Cumulative Port Power Data:
+++++++++++++++++++++++++++

#Ports  #Ports  #Ports        Power       Power
Pri: 1  Pri: 2  Pri: 3  Consumption  Allocation
-----------------------------------------------
0       0       48         41.800 W    58.222 W


What build are you running for the POE Firmware too?

[email protected]#sh inline pow


Power Capacity:         Total is 370000 mWatts. Current Free is 311778 mWatts.


Power Allocations:      Requests Honored 71 times




 Port   Admin   Oper    ---Power(mWatts)---  PD Type  PD Class  Pri  Fault/
        State   State   Consumed  Allocated                          Error
--------------------------------------------------------------------------
  1/1/1 On      Off            0          0  n/a      n/a         3  n/a
  1/1/2 On      Off            0          0  n/a      n/a         3  n/a
  1/1/3 On      On          2400       3903  802.3af  Class 1     3  n/a
  1/1/4 On      Off            0          0  n/a      n/a         3  n/a
  1/1/5 On      Off            0          0  n/a      n/a         3  n/a
  1/1/6 On      Off            0          0  n/a      n/a         3  n/a
  1/1/7 On      Off            0          0  n/a      n/a         3  n/a
  1/1/8 On      Off            0          0  n/a      n/a         3  n/a
  1/1/9 On      Off            0          0  n/a      n/a         3  n/a
 1/1/10 On      On          3000       3587  802.3af  Class 1     3  n/a
 1/1/11 On      Off            0          0  n/a      n/a         3  n/a
<brevity>
--------------------------------------------------------------------------
 Total                     41200      58222


Photo of NETWizz

NETWizz

  • 182 Posts
  • 57 Reply Likes



I realize this switch doesn't have any 30W devices, but I see those run all the time without issues on various ICX switches, and I am not going out of my way to set the ports to any strange settings!

If you are not running the latest, please upgrade the device!

Here is an example interface:

interface ethernet 1/1/10
 dual-mode  144
 inline power
 trust dscp
!

These are enabled, too:
cdp run
lldp run
fdp run

------------
If you want to upgrade:
------------



First verify what you are booting to (primary or secondary... Default = Primary or if Primary fails then boot Secondary).  If it is default, leave it alone:

[email protected]#sh boot
Boot system preference(Configured):
        Use Default

Boot system preference(Default):
        Boot system flash primary
        Boot system flash secondary
[email protected]#



[email protected]#sh fl
Stack unit 1:
  Compressed Pri Code size = 8559140, Version:08.0.30sT311 (ICX64S08030sa.bin)
  Compressed Sec Code size = 8533104, Version:08.0.30mT311 (ICX64S08030mb.bin)
  Compressed Boot-Monitor Image size = 786944, Version:10.1.05T310
  Code Flash Free Space = 5677056



Photo of Matthew C

Matthew C

  • 7 Posts
  • 0 Reply Likes
Hello, 

Here is the inline power detail. I have enabled LLDP, CDP and FDP enabled on 1/1/4. 

Power Supply Data On stack 1:
++++++++++++++++++



Power Supply Data:
++++++++++++++++++

Power Supply #1:
        Max Curr:       6.8 Amps
        Voltage:        54.0 Volts
        Capacity:       370 Watts
power supply 2 is not present


POE Details Info. On Stack 1 :


General PoE Data:
+++++++++++++++++

Firmware
Version
--------
02.1.0



Cumulative Port State Data:
+++++++++++++++++++++++++++

#Ports    #Ports     #Ports   #Ports    #Ports       #Ports     #Ports
Admin-On  Admin-Off  Oper-On  Oper-Off  Off-Denied   Off-No-PD  Off-Fault
-------------------------------------------------------------------------
10        38         3        45        0            7          5



Cumulative Port Power Data:
+++++++++++++++++++++++++++

#Ports  #Ports  #Ports        Power       Power
Pri: 1  Pri: 2  Pri: 3  Consumption  Allocation
-----------------------------------------------
1       0       9          25.822 W    60.800 W





Flash firmware is here. 

  Compressed Pri Code size = 10371776, Version:07.4.00bT311 (ICX64S08030t.bin)
  Compressed Sec Code size = 10371776, Version:07.4.00bT311 (ICX64S08030t.bin)
  Compressed Boot-Monitor Image size = 786944, Version:10.1.05T310
  Code Flash Free Space = 5894144

The boot information is set to boot primary then secondary. 

Let me know if you need to look at anything else.




Photo of NETWizz

NETWizz

  • 182 Posts
  • 57 Reply Likes
Good Morning:

I would upgrade the POE firmware next.  Using the same TFTP server you used to send 08030t navigate to the folder with the firmware file and send it like this substituting your computer's IP for 10.1.2.3:

Command:

inline power install-firmware stack-unit 1 tftp 10.1.2.3 icx64xx_poeplus_02.1.0.b004.fw


This will take all POE offline for about 12 minutes, so I would NOT do it in the middle of the work day if you have a bunch of users on VoIP phones!  This cannot be automatically scheduled on the switch itself though you could probably have some management software send the command at a time of your choosing.

Make certain the power is stable etc.; since, any loss of power will likely brick the POE controller necessitating a TAC case and most likely an RMA (if they still do that for the 64xx units).  I have only had one out of maybe 300 of these fail after this upgrade, but it was already flaky with a bad power supply.  You can check that with "show chassis"


If you are doing this over SSH, you will want to enable "term mon" or "terminal monitor" to watch the syslog messages scroll by the screen, so you know when it is done.

Otherwise you will be typing "show logging" to check the syslog for status.

If your unit is stacked, you need to do this for each unit... otherwise the one and only unit is #1 and the command above will simply work.  If in doubt, you can use "show stack."  Though I doubt this is the use case given your outputs list only one unit.

Afterwords, running the "show inline power detail" command should return:

Firmware
Version
----------------
02.1.0 Build 004

(Edited)
Photo of Matthew C

Matthew C

  • 7 Posts
  • 0 Reply Likes
Hello. I have updated my firmware and still have the issue. I have posted my PoE detail below. 

Power Supply Data On stack 1:
++++++++++++++++++



Power Supply Data:
++++++++++++++++++

Power Supply #1:
        Max Curr:       6.8 Amps
        Voltage:        54.0 Volts
        Capacity:       370 Watts
power supply 2 is not present


POE Details Info. On Stack 1 :


General PoE Data:
+++++++++++++++++

Firmware
Version
--------
02.1.0



Cumulative Port State Data:
+++++++++++++++++++++++++++

#Ports    #Ports     #Ports   #Ports    #Ports       #Ports     #Ports
Admin-On  Admin-Off  Oper-On  Oper-Off  Off-Denied   Off-No-PD  Off-Fault
-------------------------------------------------------------------------
10        38         3        45        0            7          5



Cumulative Port Power Data:
+++++++++++++++++++++++++++

#Ports  #Ports  #Ports        Power       Power
Pri: 1  Pri: 2  Pri: 3  Consumption  Allocation
-----------------------------------------------
1       0       9          22.629 W    40.500 W

Photo of NETWizz

NETWizz

  • 182 Posts
  • 57 Reply Likes
Your output doesn't seem to indicate the POE update successfully installed.

If it were successful, it would display this:

Firmware
Version
----------------
02.1.0 Build 004


NOT


Firmware
Version
--------
02.1.0

Photo of Matthew C

Matthew C

  • 7 Posts
  • 0 Reply Likes
Ok. I thought I had the updated firmware. I apologize that I didn't double check. 
Photo of Matthew C

Matthew C

  • 7 Posts
  • 0 Reply Likes
Hello, I have updated the firmware to icx64xx_poeplus_02.1.0.b004.fw but it wont update properly. It says the firmware has been updated successfully. Does the switch require a reboot? 
Photo of NETWizz

NETWizz

  • 182 Posts
  • 57 Reply Likes
Usually, the switch doesn't require a reload after the POE firmware is upgraded.  Not sure what went wrong.

Did it transfer the firmware file?
Photo of NETWizz

NETWizz

  • 182 Posts
  • 57 Reply Likes
Last one I did was from 02.1.0 build 002 to 02.1.0 build 004 on March 14, 2019 according to my logs:


ICX6430-24P Switch#sh inline pow det
Power Supply Data On stack 1:
++++++++++++++++++
Power Supply Data:
++++++++++++++++++

Power Supply #1:
Max Curr:  6.8 Amps
Voltage:    54.0 Volts
Capacity:  370 Watts
power supply 2 is not present 

POE Details Info. On Stack 1 : 

General PoE Data:
+++++++++++++++++

Firmware
Version
----------------
02.1.0 Build 002

<brevity>

ICX6430-24P Switch#inline power install-firmware stack-unit 1 tftp 10.1.2.3 icx64xx_poeplus_02.1.0.b004.fw

ICX6430-24P Switch#Flash Memory Write (8192 bytes per dot) ..........
 tftp download successful file name = poe-fw
Sending PoE Firmware to Unit 1.
Firmware version from File: 2.1.1
PoE Warning: Upgrading firmware in slot 1....DO NOT HOTSWAP OR POWER DOWN THE MODULE.

SYSLOG: <12>Dec 31 19:01:11 System: PoE Warning: Upgrading firmware in slot 1....DO NOT HOTSWAP OR POWER DOWN THE MODULE. 
PoE Info: FW Download on slot 1...sending download command...
PoE Info: FW Download on slot 1...TPE response received.
PoE Info: FW Download on slot 1...sending erase command...
PoE Info: FW Download on slot 1...erase command...accepted.
PoE Info: FW Download on slot 1...erasing firmware memory...
PoE Info: FW Download on slot 1...erasing firmware memory...completed
PoE Info: FW Download on slot 1...sending program command...
PoE Info: FW Download on slot 1...sending program command...accepted.
PoE Info: FW Download on slot 1...programming firmware...takes around 12 minutes....

SYSLOG: <14>Dec 31 19:01:20 System: Interface ethernet 1/1/24, state down 
U1-MSG: PoE Info: Firmware Download on slot 1.....10 percent completed.

SYSLOG: <14>Dec 31 19:02:26 System: U1-MSG: PoE Info: Firmware Download on slot 1.....10 percent completed. 
U1-MSG: PoE Info: Firmware Download on slot 1.....20 percent completed.

SYSLOG: <14>Dec 31 19:03:35 System: U1-MSG: PoE Info: Firmware Download on slot 1.....20 percent completed. 
U1-MSG: PoE Info: Firmware Download on slot 1.....30 percent completed.

SYSLOG: <14>Dec 31 19:04:44 System: U1-MSG: PoE Info: Firmware Download on slot 1.....30 percent completed. 
U1-MSG: PoE Info: Firmware Download on slot 1.....40 percent completed.

SYSLOG: <14>Dec 31 19:05:53 System: U1-MSG: PoE Info: Firmware Download on slot 1.....40 percent completed. 
U1-MSG: PoE Info: Firmware Download on slot 1.....50 percent completed.

SYSLOG: <14>Dec 31 19:07:03 System: U1-MSG: PoE Info: Firmware Download on slot 1.....50 percent completed. 
U1-MSG: PoE Info: Firmware Download on slot 1.....60 percent completed.

SYSLOG: <14>Dec 31 19:08:12 System: U1-MSG: PoE Info: Firmware Download on slot 1.....60 percent completed. 
U1-MSG: PoE Info: Firmware Download on slot 1.....70 percent completed.

SYSLOG: <14>Dec 31 19:09:21 System: U1-MSG: PoE Info: Firmware Download on slot 1.....70 percent completed. 
U1-MSG: PoE Info: Firmware Download on slot 1.....80 percent completed.

SYSLOG: <14>Dec 31 19:10:30 System: U1-MSG: PoE Info: Firmware Download on slot 1.....80 percent completed. 
U1-MSG: PoE Info: Firmware Download on slot 1.....90 percent completed.

SYSLOG: <14>Dec 31 19:11:40 System: U1-MSG: PoE Info: Firmware Download on slot 1.....90 percent completed. 
U1-MSG: PoE Info: Firmware Download on slot 1.....100 percent completed.

SYSLOG: <14>Dec 31 19:12:49 System: U1-MSG: PoE Info: Firmware Download on slot 1.....100 percent completed. 
PoE Info: FW Download on slot 1...programming firmware...completed.
PoE Info: FW Download on slot 1...upgrading firmware...completed. Module will be reset.
PoE Info: Resetting in slot 1....
PoE Info: Resetting module in slot 1....completed.
PoE Error: Device 0 failed to start on PoE module.
PoE Error: Device 1 failed to start on PoE module.
Resetting module in slot 1 again to recover from dev fault
PoE Info: Hard Resetting in slot 1....
PoE Info: Resetting module in slot 1....completed.
PoE Info: Programming Ruckus defaults. Step 1: Writing port defaults on module in slot 1....
PoE Info: Programming Ruckus Defaults: Step 2: Writing PM defaults on module in slot 1.
PoE Info: Programming Ruckus defaults. Step 3: Writing user byte 0xf3 on module in slot 1.
PoE Info: Programming Ruckus defaults. Step 4: Saving settings on module in slot 1.
PoE Info: Programming Ruckus defaults....completed.
PoE Info: PoE module 1 of Unit 1 initialization is done. 


ICX6430-24P Switch#sh inline pow det

Power Supply Data On stack 1:
++++++++++++++++++

Power Supply Data:
++++++++++++++++++

Power Supply #1:
Max Curr:  6.8 Amps
Voltage:    54.0 Volts
Capacity:  370 Watts
power supply 2 is not present 


POE Details Info. On Stack 1 : 


General PoE Data:
+++++++++++++++++

Firmware
Version
----------------
02.1.0 Build 004



Photo of Matthew C

Matthew C

  • 7 Posts
  • 0 Reply Likes
It did transfer via TFTP. I will try again today and post the install log.