Response [500] Causes - SmartZone API

  • 1
  • Question
  • Updated 4 months ago
  • Answered
  • (Edited)
Been playing with the API and currently struggling to create a new WLAN. 

I am following http://docs.ruckuswireless.com/smartzone/3.6.2/sz100-public-api-reference-guide-3-6-2.html this documentation. 

Can generate invalid, 404 and 500 responses but never 201. 

Got everything structured correctly to generate as per the documentation but getting Response 500. Which is "The request is valid, but the controller is unable to process the request."

Is there a list of possible causes for <Response [500]>?

Could it be that we currently have a node out of service on the cluster?
Photo of Gareth Hay

Gareth Hay

  • 8 Posts
  • 2 Reply Likes

Posted 4 months ago

  • 1
Photo of Martin

Martin, Official Rep

  • 309 Posts
  • 79 Reply Likes
Hi Gareth,

So first are you using the correct user to access the API? use the admin user to make sure you have the correct rights.

Then what port are you using 7443 or 8443 as they have different URL's

500 is usually not authorised.

regards
martin
 
Photo of Gareth Hay

Gareth Hay

  • 8 Posts
  • 2 Reply Likes
Hi Martin,

If it was the port none of my requests would work but using 8443 as it is the recommended.

Tested with both an account with full rights and the inbuilt admin account. 

Also there are 2 codes for that:

401UnauthorizedAuthentication failed or you do not have the permission to perform the requested operation.

403ForbiddenAccess denied.

So why would it be returning 500?
(Edited)
Photo of Gareth Hay

Gareth Hay

  • 8 Posts
  • 2 Reply Likes
Solved, the posted data was malformed so should have been getting a 400 error code.