Captive portal problems

  • 1
  • Question
  • Updated 1 year ago
  • Acknowledged
  • (Edited)
The captive portal does not appear automatically when the user opens the browser, most devices show an SSL warning, ok i don't have a problem with SSL warning but on some devices when the user tries to skip it or click "I Accept the risk" the page reloads the warning instead of opening up the Captive Portal, it should be noted that this problem occurs regardless of browser.

The following browsers were tested:
  1. Firefox
  2. Chrome
  3. Opera
  4. Edge
The tests were run on 8 "windows 10" and "Linux Ubuntu" devices, the problem only occurred on windows devices.

Keywords: Ruckus ZoneDirector 1200, Captive Portal, Issue.

Photo of anas baayou

anas baayou

  • 6 Posts
  • 0 Reply Likes
  • confused

Posted 1 year ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 3288 Posts
  • 520 Reply Likes
The URL of the browser homepage must be reachable.  If you have no Internet access for example, www.yahoo.com will not get the return TCP SYN-ACK for us to "hijack" and open a Guest page.
Photo of anas baayou

anas baayou

  • 6 Posts
  • 0 Reply Likes

Thanks for your concern dear,


actually, the captive portal is using for authentication to access the internet without login user cannot reach any website


Photo of anas baayou

anas baayou

  • 6 Posts
  • 0 Reply Likes
Hint: there is no problem with the guest portal,
the problem just with a captive portal where I am using a local database for authentication.
Photo of anas baayou

anas baayou

  • 6 Posts
  • 0 Reply Likes

screenshot for different browsers,
Hint: same browsers sometimes work well in different laptops.




(Edited)