Can't connect to one of my WiFi network (R710)

  • 1
  • Question
  • Updated 2 months ago
  • Answered
Hello!

As the address saying: i can not connect to one of my WLAN.

My network is:

Router: pfSense on miniPC
Switch: unifi 24 ports PoE switch
Access Point: R710 unleashed

I have 4 networks (all networks assigned to IGB1 on pfSense):
- LAN: 192.168.1.0/24
- VLAN10 (management - MGMT - VLAN): 192.168.10.0/24
- VLAN20 (for VPN): 192.168.20.0/24
- VLAN30 (for IOT devices): 192.168.30.0/24
- VLAN40 (for ClearNET): 192.168.40.0/24

unifi setup:
- LAN as corporate network (shouldn't do anything, because i had no USG on my network)
- VLANs as VLAN only network
- Trunk to WiFI switch port profile: VLAN10 as native network, the other VLANs as tagged network (LAN is excluded, it just needed till adopted the switch)
- switch's management VLAN is set to VLAN10, and it has an IP address: 192.168.10.2

Ruckus WiFi network:
- MGMT 5GHz wifi network
- VPN 5GHz wifi network
- IOT 2,4GHz wifi network
- ClearNET 5GHz wifi network
All network is signed with the correct VLAN ID under WiFi Networks --> Edit/Create WLAN --> Advanced Options --> WLAN Priority --> Access VLAN number

I can connect all of my WiFi networks, except my MGMT 5GHz wifi network. The AP is on the right MGMT network with IP address: 192.168.10.3. I just can't figure it out why i can't connect to my MGMT WLAN. I know i shouldn't make my management network visible as a WLAN, but it is just too comfortable for me right now.

Do you have maybe any idea what should i do, or where should i start to investigate the problem?

Thanks any help you can provide!



Photo of Gabor

Gabor

  • 9 Posts
  • 2 Reply Likes

Posted 2 months ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 3288 Posts
  • 521 Reply Likes
I have a feeling VLAN 10 needs to be tagged throughout the network...?
Photo of Gabor

Gabor

  • 9 Posts
  • 2 Reply Likes
Thanks for your reply!

So you say that my "Trunk to WiFi" switch port profile should be modified as tagged VLANs only (i can't set the port to "All" switch port profile, because there are other networks i don't want to trunk to the R710)? If that's the case: how will the R710 know that it should get an IP from the VLAN10 network (should i setup a static IP from the VLAN10 network in the settings)? Forgive my ignorance, but the VLAN's world is new to me, especially on the unifi controller. I've read an article about how to setup a unifi AP, there the management network's VLAN ID was not specified. Maybe i should do the same?

Photo of Michael Brado

Michael Brado, Official Rep

  • 3288 Posts
  • 521 Reply Likes
I'm not sure I follow the Cisco guide, but either untag VLAN 10 (your Mgt VLAN) throughout, or set it to be tagged throughout, ought to pass DHCP/DNS/Routing.
Photo of Gabor

Gabor

  • 9 Posts
  • 2 Reply Likes
Sorry for the late reply, there was too late to reply here in central europe.

Syamantak Omer's answer was i looked for.
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 282 Posts
  • 104 Reply Likes
Hi Gabor,

Go to MGMT WLAN advanced options and make sure VLAN is set to 1 (In Ruckus APs/WLAN settings, as long as VLAN 1 is configured, it is a untagged VLAN and if you change it from 1 to any other VLAN, it becomes tagged VLAN).

1- Keep VLAN 10 (MGMT) Untagged on all the trunk ports connecting SW with APs or any other network distribution device.
2- Tag rest VLANs on all the Trunk ports connected to APs.
3- On Unleashed, configure WLANs with below VLAN settings ("Advanced options" under WLAN settings)
  • MGMT 5GHz wifi network (VLAN 1)
  • VPN 5GHz wifi network (VLAN 20)
  • IOT 2,4GHz wifi network (VLAN 30)
  • ClearNET 5GHz wifi network (VLAN 40)
This will fix your problem.

Regards,
Syamantak Omer


Photo of Gabor

Gabor

  • 9 Posts
  • 2 Reply Likes
Thanks for the reply! I wasn't  aware of this, and it did fix my problem.

Unfortunately i don't see any possible way indicated in the address, that the problem is solved...
(Edited)
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 282 Posts
  • 104 Reply Likes
Happy to hear that it fixed the issue!

Regards,
Syamantak Omer