Band steering settings lost after AP reboot

  • 1
  • Question
  • Updated 4 years ago
Is there a way to save band-steering settings on AP so they are persistent after reboot?
Photo of William Fowler

William Fowler

  • 18 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Primož Marinšek

Primož Marinšek, AlphaDog

  • 413 Posts
  • 48 Reply Likes
That one is hard to answer.

What makes you think they aren't?
Photo of William Fowler

William Fowler

  • 18 Posts
  • 0 Reply Likes
for example before AP reboot:

---- Command 'rkscli -c "get band-steering "' executed at 2c:e6:cc:2a:96:f0
Band Steering:
Under Mesh AP : On

reboot:
---- Command 'rkscli -c "reboot "' executed at 2c:e6:cc:2a:96:f0

after reboot:
---- Command 'rkscli -c "get band-steering "' executed at 2c:e6:cc:2a:96:f0
Band Steering:
Under Mesh AP : Off
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 51 Reply Likes
If this is on a standalone AP, upgrade - we had some bugs around that in earlier code. 9.6.2 should fix it.

However, you may just be experiencing some UI confusion. If the RSSI is set to what you want - it's on. (the "under Mesh AP" stuff doesn't mean what you think it means..) We're going to change that in future releases to be more clear.
Photo of William Fowler

William Fowler

  • 18 Posts
  • 0 Reply Likes
OK, Thanks
Photo of Bill Burns

Bill Burns, AlphaDog

  • 203 Posts
  • 38 Reply Likes
Did you configure this setting from the contoller?
It is possibe to configure a controlled AP directly from the AP's commandline but AFAIK: no setting changes made in this way will survive a reboot.

One way to doublecheck this band-steering behavior:
Use inSSIDer (on a computer w/ a dual-band WiFi card) to look at signal-strength levels.
If band-steering is on, when you're close to the AP, you may (should?) see a very strong signal reported on the 2.4Ghz side but with "gaps"/delays in the signal-strength report.

(In the graph, this would look like a "Broken line" or a line that's not drawn in as quickly as the 5Ghz signal strength report)
Photo of William Fowler

William Fowler

  • 18 Posts
  • 0 Reply Likes
I tried both ZD remote_ap_cli and AP directly with same result. Is there another method?

I will try your method with inSSIDer to check band steering.

Thanks for the info.
Photo of Bill Burns

Bill Burns, AlphaDog

  • 203 Posts
  • 38 Reply Likes
Hmm.. Let's see...

If you're using a ZoneDirector, Band Steering is on by default.
..unless the AP is making use of the mesh feature.

To turn on band steering for a *meshed* AP, use the command:
set band-steering mesh-ap enable
as-per: https://forums.ruckuswireless.com/ruc...
(which changes that misleading "on/off" entry you were looking at)

note: You probably don't want to do that (mesh-ap enable) because your mesh connection will be on the 5Ghz radio and you don't want that band congested w/ client traffic.
You might want to take all SSIDs off of the 5Ghz radio on a meshed AP.

Culling + combining information from a few threads here:
https://forums.ruckuswireless.com/ruc...
https://forums.ruckuswireless.com/ruc...
https://support.ruckuswireless.com/an...

Gives us the following info:

To get/set band steering:
remote_api_cli -A "get band-steering "
remote_api_cli -A "set band-steering [ mesh-ap {enable|disable} ] "
(sorry if that "set" command is too long to display on a single line)

To turn band-steering off, use an "rssi_threshold" of "0".

By the way, I'm not able to find this command on my system:
set withholding-limit "
But it's supposed to have an effect on band-steering too.
Photo of William Fowler

William Fowler

  • 18 Posts
  • 0 Reply Likes
OK, Thanks for the info!