Apple devices do not remember wifi password

  • 1
  • Question
  • Updated 3 years ago
Hello!
In my company we have a Ruckus ZoneFlex 7372, dual-band 802.11n AP2x2:2 stream Beamflex, PD-MRC, dual ports, PoE. We have configured two wifi accesses: one for domain users and one for guests (only in this case a password is required to access the network).
We have a problem when we use the guest wifi connection with Apple devices: the wifi password cannot be memorized. In fact after few minutes of browser inactivity (or after unlocking of display), the password to connect to the wifi is required again (and this happens continuously).
Fyi, I have already tried to put manually wifi settings into more than one Apple devices but the problem remains.
Other devices (i.e. Samsung) can keep the password without any problem.
Could you help me? thanks in advance
Regards
Silvia
Photo of Silvia

Silvia

  • 3 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of MLG

MLG

  • 73 Posts
  • 23 Reply Likes
Are they APs using different SSID's?
Photo of Munish Dhiman

Munish Dhiman, Employee

  • 100 Posts
  • 14 Reply Likes
Hi Silvia,

Is it happening on all apple devices , iPhone,pad ,MAC etc? Software version of the OS?

Thanks,
Munish
Photo of Silvia

Silvia

  • 3 Posts
  • 0 Reply Likes
@MLG
First of all let me tell you that I'm not an IT expert. So I apologize if my wording is not so clear and appropriate.
The answer to your questio is yes.
when I access the network using the wifi for domain users, it is not required to key a password ( the authentication is done by a certificate installed in the laptop). so the connection is automatically done.

When I connect to the wifi for guest, a password is required. Please refer to the attached image for Wifi properties
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 136 Reply Likes
Ah, this is a guest network. Under Advanced Options in the menu you're in, can you double-check the settings for "Grace Period"? When that timeout expires, a re-connecting user will be forced to authenticate again.

In addition, double check the "Inactivity Timeout". I believe the default settings here are 480 minutes and 30 minutes respectively, which should be more than enough. If these are your settings, then disregard this -- it's probably not your problem.
Photo of Silvia

Silvia

  • 3 Posts
  • 0 Reply Likes
@ Munish Dhiman

it is happening on all Apple devices (and not on Android devices).
we face the problem with iPhone5 and 6, with iPad and Mac. IOS version: 7 and 8