AP 7372 WILL NOT JOIN ZD FIRMWARE UPGRADE LOOP

  • 2
  • Question
  • Updated 3 months ago
  • Answered
When joining two my 7372 (currently at  9.7.1.0.17) AP to the ZoneDirector (10.1.0.0.1515)  I get the following:
( MAC ADDRESS INTENTIONALLY DELETED )

2018/06/20  12:12:55 Medium AP[38:ff:xx:xx:xx:xx] joins with different firmware/custom file version and is being upgraded.
2018/06/20  12:10:28 Medium AP[38:ff:xx:xx:xx:xx] joins with different firmware/custom file version and is being upgraded.
2018/06/20  12:07:46 Medium AP[38:ff:xx:xx:xx:xx] joins with different firmware/custom file version and is being upgraded.
2018/06/20  12:05:14 Medium AP[38:ff:xx:xx:xx:xx] joins with different firmware/custom file version and is being upgraded.
2018/06/20  12:02:44 Medium AP[38:ff:xx:xx:xx:xx] joins with different firmware/custom file version and is being upgraded.
2018/06/20  12:00:12 Medium AP[38:ff:xx:xx:xx:xx] joins with different firmware/custom file version and is being upgraded.
2018/06/20  11:57:40 Medium AP[38:ff:xx:xx:xx:xx] joins with different firmware/custom file version and is being upgraded.
2018/06/20  11:54:53 Medium AP[38:ff:xx:xx:xx:xx] joins with different firmware/custom file version and is being upgraded.
2018/06/20  11:52:26 Medium AP[38:ff:xx:xx:xx:xx] joins with different firmware/custom file version and is being upgraded.
2018/06/20  11:49:55 Medium AP[38:ff:xx:xx:xx:xx] joins with different firmware/custom file version and is being upgraded.

ACTIONS TAKEN

1. Tried several Firmware Versions of the AP (100.x.x.x down to 9.5 ) and the result is the same as above:
* currently AP is at 9.7.1.0.17

2. Entered the CLI and tried to force update the AP with the following:
rkscli: fw force-update xxx.xx.xx.xx
fw: Updating rcks_wlan.main ...
**fw(7723) 172.16.17.18: CTL Get Error
OK

3. Enabled FTP on the Zonedirector to look for AP Specific Files:




Index of /zf7372/10.1.0.0.1515/
[parent directory]

rcks_fw.bl7 0 B 
rcks_fw.bl7.bkup 0 B
rcks_fw.bl7.bkup.version 14 B
rcks_fw.bl7.main 0 B
rcks_fw.bl7.option 28 B
zf7372_1010_cntrl.rcks 140 B

FILE SIZES SEEM TO BE TOO SMALL ( same sizes appear in all model-specific directories) ?

What is the next step now ?

Thank you.

N.B. I have two (2) other 7372s that have upgraded without a problem.

Photo of Kurt Cedric Salvador

Kurt Cedric Salvador

  • 5 Posts
  • 2 Reply Likes
  • worried

Posted 3 months ago

  • 2
Photo of Kurt Cedric Salvador

Kurt Cedric Salvador

  • 5 Posts
  • 2 Reply Likes
As an update and after talking to Ruckus Support, the solution is to install firmware version 104.0.0.0.1347 on the APs before letting them join the Zone Director.

Thanks to Nayab Khan for the timely assist!
Photo of Jonathan Daigle

Jonathan Daigle

  • 1 Post
  • 0 Reply Likes
Are there instructions on how to manually upgrade the firmware?
Photo of JArdel Almeida

JArdel Almeida

  • 5 Posts
  • 0 Reply Likes
Friend,
I suggest that you do the manual upgrade by following these steps:
1 - Upgrade to version100.1.x.194
2 - After the configuration, point the ap to the controller with the set director IP x.x.x.x
3 - Get the get version (see if the update worked)
3.1 - Get the get director (to see if the LWAPP connection between Ap x wlc is established
3.2 - Do the show fw all (to see if the two images have been updated) - If not, I suggest a new update - or a new note for wlc;
4 - If ap does not provision, repeat these steps with firmware 104.0.1397.

Please post the result here.

NOTE: You must enter the ruckus site, and verify that this version of the 10.1.15 x controller supports this AP model.
Photo of Kurt Cedric Salvador

Kurt Cedric Salvador

  • 5 Posts
  • 1 Reply Like
Thank you for the reply.
As of this time, the APs have already been recognized by the ZD and have been updated as well.
1. I took route of a direct firmware upgrade to 104.0.0.0.1347 ;
2. Configured the static addresses the APs ( yes, I used static addressing for the APS and the ZD), and then after a reboot, the ZD recognized them and provisioned them with 10.1.0.0.1515

Don't want to tinker with it for now :-)
(Edited)