Anyone using Cacti?

  • 4
  • Question
  • Updated 2 years ago
  • Answered
I am running Cacti for monitoring our network, and would like to monitor the Zone Director as well. What I'm running into is that there are no Cacti templates out there and I'm not comfortable building my own. Has anybody built a Cacti template that monitors the ZD or APs?
Photo of John Case

John Case

  • 10 Posts
  • 2 Reply Likes

Posted 6 years ago

  • 4
Photo of John Case

John Case

  • 10 Posts
  • 2 Reply Likes
Sorry Travis. I edited my comment after posting it. I restarted Cacti, and my graphs started working again. All that I'm collecting from the APs is uptime.
Photo of Joel Baltazor

Joel Baltazor

  • 6 Posts
  • 1 Reply Like
A short while back I put together some templates. They can be found in the cacti forums here:
http://forums.cacti.net/viewtopic.php...

-Joel
Photo of John Case

John Case

  • 10 Posts
  • 2 Reply Likes
Joel,
The templates you put together are awesome. I award you all of my Internet points for the day!
Photo of Odilo Junior

Odilo Junior

  • 15 Posts
  • 2 Reply Likes
I just upgraded to 9.8.1 and its working great here.

We still have Cacti but we are moving to Zabbix as it has some more interesting features that we want for monitor not just our WiFi but also our servers and other network devices.
Photo of Nanda Soe

Nanda Soe

  • 2 Posts
  • 0 Reply Likes
do you have zabbix template ?
Photo of Nanda Soe

Nanda Soe

  • 2 Posts
  • 0 Reply Likes
hi Odilo,

do you have Zabbix Ruckus Zone Director template ?
Photo of StarLog

StarLog

  • 14 Posts
  • 0 Reply Likes
I keep getting snmp error when I build out the AP.
Photo of Rodrigo Soares

Rodrigo Soares

  • 6 Posts
  • 1 Reply Like
I am also behind a template for zabbix .
I need to access the ZD1100 how many simultaneous connections via SNMP have in each AP .
This is a very difficult task , because I could not have any reference material that can help me with my problem .
Photo of Julius Kisielius

Julius Kisielius

  • 30 Posts
  • 1 Reply Like
Hi Rodrigo,

I had a similar requirement, I don't use zabbix though, I use PRTG but the process was the same. You cannot query the director for the number of clients that are connected to each AP, you need to query each AP individually. I had created a custom OID sensor with the following value on each AP:

1.3.6.1.4.1.25053.1.1.6.1.1.1.4.1.3.21

This gave me the number of clients connected to that AP.
Photo of Rodrigo Soares

Rodrigo Soares

  • 6 Posts
  • 1 Reply Like
Hi Julius ,
Thank you very much for your help, so to know that the settings should be performed in AP already gave me a better direction.
I'll probably have to do a trigger or something in zabbix to collect this information . In Zabbix is a little tricky to make custom components .
I'll keep trying.
Photo of Odilo Junior

Odilo Junior

  • 15 Posts
  • 2 Reply Likes
Just a reminder.. you gotta use SNMPv2 for query on APs (we are still not able to work with v3) and you will find the number of active clients for each Radio.. you just need to sum them..

I wasn't the one responsible to move from Cacti to Zabbix, now I just monitor the graphs :)
But as far as I know Zabbix it's a little bit more complicated. I don't know if I could simply export a template as we did on Cacti but I'll check with our Zabbix master here.. he told me it take a time to implement all the auto-discovery features, templates, applications, triggers a lot of stuff that I don't have a clue.. but now if we connect a new AP it will automatically find it and graph it and even if we deploy a new SSID it will do the same. Pretty awesome :)
Photo of Rodrigo Soares

Rodrigo Soares

  • 6 Posts
  • 1 Reply Like
Good afternoon people.
At one time concludes my goal to manage to collect the users connected to each AP at Ruckus .
After trying both decided to follow a tip in a post on another tópicp from right here .

Ran a GET SNMP directly on the controller with the following OIDS ,

get the description of each AP - .1.3.6.1.4.1.25053.1.2.2.1.1.2.1.1.16
and also
Users get connected - .1.3.6.1.4.1.25053.1.2.2.1.1.2.1.1.15

As I passed the values ​​for a notebook was only associate the AP name in the same sequence of each connected User query.

Thus I managed to make several graphics and widened my monitoring with Zabbix .

Actually my template was very good and I can now view in real time all my wirelles environment.

Thanks for personal assistance without you guys would not be possible to my success in this project
Photo of AlvinP

AlvinP

  • 16 Posts
  • 0 Reply Likes
Hi, 

I've found a Ruckus template for Cacti from this website http://forums.cacti.net/viewtopic.php?f=12&t=53270 , but when I added a new Host on cacti using those template. I got the following snmp error.



Anyone could help me how to fix this?
Thanks

ps:
ZD1000 ver 9.3
ZF7343 ver 9.3
cacti  ver 0.8.8c
Photo of Joel Baltazor

Joel Baltazor

  • 6 Posts
  • 1 Reply Like
Hello,
On your zonedirector:  Configure -> System.  Scroll to the bottom and expand "Network Management".  Make sure the SNMPv2 Agent is enabled and the SNMP community (specifically RO) match the ones you are using in the Cacti host device you are trying to add.

In Cacti "SNMP Error" can mean a lot of different things, but is basically is a connection failure.  It means either the target host is not online, is not running SNMP, or the settings are mis-matched.  If there is a firewall between your ZD and Cacti this could be the problem also.

-Joel
Photo of AlvinP

AlvinP

  • 16 Posts
  • 0 Reply Likes
Thanks joel for your response. And the problem already fix, i've forgotten to open the ACL control access. 

But anyway, after i put the ZD host template. Then I chose several graphs which I want to be shown in my cacti, but It is not showing all graphs which i chose.
The shown graphs only 'APs' and 'Authed Clients', and the rest is not shown.

Have any suggestion why that could be happen? 




Thank you,
Photo of Joel Baltazor

Joel Baltazor

  • 6 Posts
  • 1 Reply Like
Hello,
Some other users have posted strange issues similar to this in the thread on the cacti forum:  http://forums.cacti.net/viewtopic.php?f=12&t=53270  (I'm not able to reproduce this issue on my own Cacti and thus have not changed the templates)
Their solution is to edit the graph templates to change the CF Type of the AREA/LINE objects from "LAST" to "AVERAGE".

Here's an example of how to do that:
In Cacti, go to "Console" -> Graph Templates (under the Templates heading) -> Click on one of the templates that is broken on your system (like "Ruckus ZD 3000 - CPU") -> Click on the "Area" item #1. Change CF Type from "LAST" to "AVERAGE" and click save.

If this fixes your graph(s) then it is the same problem.  If not, you may need to run the graph(s) in debug mode to see if there are other errors.
Or you may need to look at the "data templates" that are associated with each graph, then find the OID and do a snmpwalk against it to verify that it is still a valid OID for your Zone Director (for example, the OID for CPU is defined as ".1.3.6.1.4.1.25053.1.1.11.1.1.1.1.0" in the "Ruckus AP - CPU" data template).

-Joel
Photo of AlvinP

AlvinP

  • 16 Posts
  • 0 Reply Likes
Hi Joel, 

Thank you about your suggestion. The problem has been fix since I change the CF Type from "LAST" to "AVERAGE". 

But I have found some unactive OID, I did snmpwalk but the result was not OK. So, it make the graphs didn't display properly. 



The OID is:
APs Total - result: NOK        1.3.6.1.4.1.25053.1.2.1.1.1.15.15.0
All Clients - result: NOK        1.3.6.1.4.1.25053.1.2.1.1.1.15.30.0


Do you know how to fix it? I tried looking the SNMP OID from ruckus SNMP reference guide, but I have not found yet which OID should be used.

Thanks,
Photo of Joel Baltazor

Joel Baltazor

  • 6 Posts
  • 1 Reply Like
I don't have much of an idea of what is wrong with the graphs you show as mine do not have this problem. I'm not an SNMP/Cacti expert and also do not know what "NOK" means as a result.

Sorry I can't be more help.
-Joel
Photo of AlvinP

AlvinP

  • 16 Posts
  • 0 Reply Likes
Yes, the graph is showing normal in my ZD ver 1100 but not in ZD1000. And I thought that is also working normal for ZD1100 above version, cmiiw

I didnt know why that could be happened, Then i did snmpwalk of these APs Total OID  1.3.6.1.4.1.25053.1.2.1.1.1.15.15.0 and  All Clients  OID 1.3.6.1.4.1.25053.1.2.1.1.1.15.30.0. And the result was Not OK, "NOK". 
Sorry for misunderstanding. 

So, now i am still looking for exact for those OID. 
Maybe someone here knows how to work with that issue?
(Edited)
Photo of Daniel Petrovic

Daniel Petrovic

  • 1 Post
  • 0 Reply Likes
Hi everyone,

we have been using Cacti for over a year now to monitor our ZD1200's. As we have recently started using the Smartzone 100 as well. I wanted to monitor it with Cacti.

I have successfully made a template for the SZ100 with FW 3.1 and later.

A link to the profile on our website:
www.padaco.nl/cacti_host_template_ruckus_sz100.xml

It can render data about the total registered APs and total concurrent stations/clients.
Sadly there is no SNMP data entry for the amount of connected APs or Root/Mesh APs, otherwise I could add those to give more differentiation.
(Edited)
Photo of Ferooz Ibadullaev

Ferooz Ibadullaev

  • 2 Posts
  • 0 Reply Likes
Hi all!
Does anybody can share the ruckus template for cacti?
In this topic I found 2 links, but none of them works.
First link: https://forums.cacti.net/viewtopic.php?f=12&t=53270
Second link: http://siaiota02.univali.br/odilo/cacti/cacti.zip