Anyone have trouble connecting their Sonos to their Ruckus R510 unleashed?

  • 1
  • Question
  • Updated 4 months ago
  • Answered
  • (Edited)
I have 4 APs at the office all R510s with R510_200.7.10.102.64   - for some reason my Sonos can't even find it.   I have 2.4GHz enabled.   I know with some APs I've worked with in the past I've had to enable multicast.  I couldn't find that in the GUI.   I found a very unclear thread that sounded like  you couldn't use unleashed or might need a zone director - I couldn't make heads or tails of what the environment that does or doesn't work with Sonos.    Can anyone answer for my specific environment?
Photo of Jim Millerick

Jim Millerick

  • 10 Posts
  • 0 Reply Likes

Posted 6 months ago

  • 1
Photo of Keven McCalister

Keven McCalister

  • 3 Posts
  • 0 Reply Likes
Yes! Apparently they don’t work well together. I have the Playbar, Sub, and two Ones and they wouldn’t work together for surround. I researched and probably looked at the same things you have and couldn’t figure it out. I ended up getting the Sonos Boost. I set that up and factory reset each device and it all works together now.
Photo of Jim Millerick

Jim Millerick

  • 10 Posts
  • 0 Reply Likes
Thanks for the reply.  Sorry if I'm not familiar with their products but isn't the sonos boost a wifi AP or router?   I'd hate to have to put in 4 of those competing for channels throughout my office.
(Edited)
Photo of John D

John D, AlphaDog

  • 579 Posts
  • 179 Reply Likes
The Boost is like a mesh base station but each Sonos speaker is capable of extending the Boost's network.

When you use Boost it will use a Sonos proprietary variant of wifi technology and you'll get better performance out of them.

Sonos actually uses a lot of the same wifi components as high end Enterprise APs -- for example, QCA chipsets, and even uses their Adaptive Noise Immunity feature just like Ruckus to combat interference.
Photo of Keven McCalister

Keven McCalister

  • 3 Posts
  • 0 Reply Likes
My application is residential with two APs. I have the Boost plugged into the Ruckus switch directly. The Boost creates a separate dedicated wi-fi just for Sonos. You can then dedicate a specific channel for your Sonos. From my understanding as long as the Boost can reach a speaker and then the speakers are close enough to each other the speakers essentially act as repeaters. The Boost itself doesn’t need to be in range of all the Sonos speakers. Maybe contact Sonos to discuss your specific application. I believe the Boost is a solution worth looking into.
Photo of ROY VALDEZ

ROY VALDEZ

  • 1 Post
  • 1 Reply Like
You actually don’t need the boost. I just hard wired one of my Play one speakers and it created the dedicated WiFi network. I talked with Sonos support when I had this problem a year ago and they told me to just hardwire my play one. I don’t remember if any speaker would work but I can confirm the play one works.
Photo of Keven McCalister

Keven McCalister

  • 3 Posts
  • 0 Reply Likes
Right, I couldn’t do that option myself as my APs are mounted on the ceiling and I could not connect via hard wire. I overlooked that tidbit for OP so hopefully that can be an option that works for him!
Photo of Jim Millerick

Jim Millerick

  • 10 Posts
  • 0 Reply Likes
Thanks - yes - when I hardwired them they worked however they need to be in places the ruckus is not.
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 283 Posts
  • 106 Reply Likes
Hi Jim,

Ruckus APs uses a feature called directed multicast which improves the performance when less clients are connected to AP.

Some devices which uses multicast do not like this feature and may cause issue for devices to find another device over the Ruckus WiFi network.

I will suggest you to try disabling directed multicast on WLAN and ether net ports of the APs and it should solve your problem.

Here is the article which explains about this feature and how to disable it.

https://support.ruckuswireless.com/articles/000006234 

Below artilce explains best practices configuring Sonos.

https://support.ruckuswireless.com/articles/000006140

Let me know if this solves your issue.

Regards,
Syamantak Omer
Photo of Jim Millerick

Jim Millerick

  • 10 Posts
  • 0 Reply Likes
Thanks - the first link for me got me -
We're sorry, but something went wrong.


The second link got me some info I'll try to find on the ruckus
-UPnP needs to be on  (couldn't find it in the unleashed interface - I do not have zone director)
-Multicast Packets need to be allowed
-BPDU packets need to be allowed
-STP (Spanning Tree Protocol) needs to be allowed
-Sonos units need to be on the same subnet as the controlling device(iPod, computer , etc)
-Wireless client isolation must be turned off if any wireless devices will be controlling Sonos
(Edited)
Photo of Jim Millerick

Jim Millerick

  • 10 Posts
  • 0 Reply Likes
Wired working fine - not an option - has to be wireless.
I couldn't find upnp, I couldn't find multicast and I couldn't find bpdu - didn't bother trying to find stp since I couldn't find the others.
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 280 Posts
  • 103 Reply Likes
My mistake, let me correct my comment.

On *wireless network side, all you need to do is to make sure directed multicast is disable on WLAN interface and eth interface and client isolation is turned off.

To disable directed multicast, I have already shared the 1st link in previous comment.

If still it is not working, I will suggest to open a case with support to troubleshoot further.
    (Edited)
    Photo of Jim Millerick

    Jim Millerick

    • 10 Posts
    • 0 Reply Likes
    Thanks - on the wireless side, I couldn't find directed multicast settings in ruckus.   Under edit wlan, advanced, other, there is directed MC/BC threshold - it is set to 1 by default - should I change that - if so to what value?
    (The link you shared isn't working)

    I think under advanced options - others, there is wireless isolation which is disabled by default - is that correct?
    (Edited)
    Photo of Syamantak Omer

    Syamantak Omer, Official Rep

    • 280 Posts
    • 103 Reply Likes
    Hi Jim,

    Yes, set that value to 0 (zero means disable).

    The link shared is a premium contents of if you don't have premium access, link may not work for you. I just tried and able to open both links.
    Photo of Jim Millerick

    Jim Millerick

    • 10 Posts
    • 0 Reply Likes
    Thanks!
    Photo of Michael Brado

    Michael Brado, Official Rep

    • 3289 Posts
    • 521 Reply Likes
    Both KBA links Syamantak provided should be visible on our Support portal.

    The first one is titled Sonos connection recommendations and guidelines:
    https://support.ruckuswireless.com/articles/000006140

    The second one has details on disabling directed Multicast on Unleashed:
    https://support.ruckuswireless.com/articles/000006234

    --
    If you who have newest, other Sonos equipment, find that any of these do not help, or that other commands were helpful, please let me/us know, and we'll update our articles, thanks!
    Photo of Jim Millerick

    Jim Millerick

    • 10 Posts
    • 0 Reply Likes
    Thanks - I tried both the boost and the  MC/BC  settting to zero.   I didn't have any luck with the boost but fortunately the  MC/BC solved the issue.   Thanks again!
    Photo of Eric Olson

    Eric Olson

    • 1 Post
    • 0 Reply Likes
    I called Ruckus Support about the settings configuration. The customer service person was very helpful in starting the ticket. An engineer called me right away, but I could not do anything this late at night. So he sent me an email with the program and commands that I'll be using to set everything up but he seemed to know that it was a multicast issue right away.
    Photo of Heiko

    Heiko

    • 2 Posts
    • 0 Reply Likes
    In unleashed:

    >AP>Edit AP Group> Radio (2.4G) and Radio (5G)>11n only Mode and 11n/ac/ax only Mode

    leave it on Auto.

    N-only and N/AC only does not work out for Sonos.