After an unsupported upgrade path from [9.7.1.0.32] to [9.9.1.0.32], I would like to downgrade to respect the official upgrade path.

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I accidentally upgraded my ZoneDirector 3000 from [9.7.1.0.32] to [9.9.1.0.32], which is not the correct upgrade path.
I would like to downgrade the firmware back to the [9.7.1.0.32] in order to respect the official upgrade path which is, in my case, [9.7.1.0.32] -> [9.7.2.0.9] -> [9.9.1.0.32].

The problem is, I don't know how to downgrade the firmware.

What I tried is to downgrade from the "Administer"->"Upgrade" menu to the [9.7.1.0.32] version.
The problem I get from this is "System is recovered from failure", and nothing happens.

I restarted the ZD3000 and tried to "downgrade" from [9.9.1.0.32] to [9.7.2.0.9].
This also gave me the error "System is recovered from failure".

Should I stay with the [9.9.1.0.32] version even though I didn't follow the official upgrade path or do you have a solution for my case?

Thank you very much for your responses, any help or attempt to help will be appretiated :-)
Photo of Emrah Engin

Emrah Engin

  • 3 Posts
  • 0 Reply Likes
  • dumb

Posted 2 years ago

  • 1
Photo of Sid Sok

Sid Sok, Official Rep

  • 102 Posts
  • 48 Reply Likes
Hi Emrah,

Is you system working as expected?  Generally speaking the upgrade path is so you retain the configuration and migration of features from previous version, but if you do not need or care about previous config then keep it on the 9.9.1 version, re-set to factory default and rebuild the config, but beyond that you should be fine to stay on 9.9.1.  

There is one exception though, if you have older APs that are not supported in the current version, like 7962 for example.  Then you will either have to replace the APs or downgrade to a support version of the controller code.

Sid
Photo of Emrah Engin

Emrah Engin

  • 3 Posts
  • 0 Reply Likes
Hello,

I'm very happy for your quick reply, I really love it !!!

My system is brand new which will manage 50x r500 APs.

I don't even know on which version the APs are. They're brand new and havn't even been taken out of the box but I know that they will be upgraded to my ZD version.

So if this doesn't cause any trouble for my lovely r500 APs, I'm happy to keep the [9.9.1.0.32] version.

Thank you very much for your help!!!
Photo of Sid Sok

Sid Sok, Official Rep

  • 102 Posts
  • 48 Reply Likes
If R500 is all you have, then you are good to go.  Keep it at 9.9.1.0.32.

Sid
Photo of Emrah Engin

Emrah Engin

  • 3 Posts
  • 0 Reply Likes
Great, than you again Sid :-)