Access within same vlan on ve by router image

  • 1
  • Question
  • Updated 3 months ago
  • (Edited)
I connected three 7450 switches with ROUTER image as below. Each switch has ve interface on same vlan as Management.
I can ping from SW1 to both SW2/SW3 and vice versa. But I cannot ping from SW2 to SW3 and vice versa.
How can I configure to communicate each other?
I can reach both switch from different subnet and both switch can go outside.


SW2 [e1/1/1] -- [e1/1/48]SW1[e1/1/47] -- [e1/1/1]SW3



SW1 config
---
vlan 100 name Management
tagg e 1/1/47 to 1/1/48
span 802
router-interface ve 100

int ve 100
ip add 10.100.0.1 255.255.255.0



SW2 config
---
vlan 100 name Management
tagg e 1/1/1
span 802
router-interface ve 100

ip route 0.0.0.0 0.0.0.0 10.100.0.1

int ve 100
ip add 10.100.0.2 255.255.255.0



SW3 config
---
vlan 100 name Management
tagg e 1/1/1
span 802
router-interface ve 100

ip route 0.0.0.0 0.0.0.0 10.100.0.1

int ve 100
ip add 10.100.0.3 255.255.255.0





Photo of saita

saita

  • 4 Posts
  • 2 Reply Likes

Posted 3 months ago

  • 1
Photo of Jijo Panangat

Jijo Panangat, Employee

  • 12 Posts
  • 3 Reply Likes
Hello!

Please add the below routes.

On Sw2 - ip route 10.100.0.3 255.255.255.0 10.100.0.1

On sw3 - ip route 10.100.0.2 255.255.255.0 10.100.0.1
Photo of saita

saita

  • 4 Posts
  • 2 Reply Likes
Hello, Jijo,

Thank you for your advice. Your command did not work but /32 worked well.

On Sw2 - ip route 10.100.0.3 255.255.255.255 10.100.0.1
On Sw3 - ip route 10.100.0.2 255.255.255.255 10.100.0.1


I have a lot of switches in this Management vlan. And also there is also a management PC in same vlan. I don't want to add static routes to all of them one by one.
I'm not sure why the switches do not learn mac address on the vlan that the switch has ve on, except SW1 which is acting as gateway.