Access Sonos from a different VLAN

  • 1
  • Question
  • Updated 4 months ago
  • Answered
Hi,
We currently have installed a Draytek Vigor 2952, 9x Ruckus ICX 7150 and a Ruckus ZD1200 with 9 Ruckus R510 access points.

The Sonos units are in VLAN9 with the Crestron touch panels and we're trying to get the Sonos units to play from VLAN5 which is the "Owner" VLAN. The VLANS are set up and working just fine, the only problem we have is with Sonos. Any ideas or pointers why can't we see the Sonos units from VLAN5 ?

Thank you,
Photo of Adrian

Adrian

  • 6 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of Diego Garcia del Rio

Diego Garcia del Rio

  • 89 Posts
  • 32 Reply Likes
Not sure for Sonos but you probably need to enable some form.of mdns proxy as otherwise the Sonos app will never find the Sonos devices. Also,.watch out that Sonos builds their own wifi mesh and run stp on all their interfaces so that might be interfering as well
Photo of Sander Groen

Sander Groen

  • 25 Posts
  • 0 Reply Likes
You would need to enable inter vlan routing in order to get this working I guess. Both type of devices are in different IP networks/broadcast domains. Sonos uses ssdp (part of UPnP) for discovery. There are projects to relay the multicast traffic from one VLAN to other VLANs.

https://github.com/alsmith/multicast-relay
Photo of Louis

Louis

  • 5 Posts
  • 2 Reply Likes
Sorry, but the Sonos system is not compatible with corporate networks that include vlans, firewalls, security policies,...

Photo of Logan Taylor

Logan Taylor

  • 13 Posts
  • 3 Reply Likes
This may help.

If the Sonos speakers are connecting wirelessly through a particulat WLAN (created on Unleashed Master), then you can run the commands as below from Master CLI:

 

ruckus> en

ruckus# config

You have all rights in this mode.

ruckus(config)# wlan "Test" [instead of "Test" use the correct WLAN name] The WLAN service 'Test' has been loaded. To save the WLAN service, type 'end' or 'exit'.

ruckus(config-wlan)# no qos directed-multicast The command was executed successfully. To save the changes, type 'end' or 'exit'.

ruckus(config-wlan)# qos directed-threshold 0 The command was executed successfully. To save the changes, type 'end' or 'exit'.

ruckus(config-wlan)# end

The WLAN service 'Test' has been updated and saved.

Your changes have been saved.

ruckus(config)# end

Your changes have been saved.

 

If the Sonos speakers are connected to eth ports of the APs then we can run the below commands too:

 

ruckus# debug

You have all rights in this mode.

ruckus(debug)# remote_ap_cli -A "set qos eth0 igmp disable" [instead of "eth0" use the particular eth interface to which Sonos is connected]

---- Command 'rkscli -c "set qos eth0 igmp disable "' executed at ec:58:ea:36:6f                                                                                                             :50

IGMP Snooping is Disabled on interface eth0 OK

---- Command 'rkscli -c "set qos eth0 igmp disable "' executed at f0:3e:90:10:62                                                                                                             :f0

IGMP Snooping is Disabled on interface eth0 OK

---- Command Execution Summary:

         success: 2

         failure: 0

           total: 2

remote_ap_cli "-A" ""set" "qos" "eth0" "igmp" "disable"" [instead of "eth0" use the particular eth interface to which Sonos is connected] ruckus(debug)# ruckus(debug)# ruckus(debug)# remote_ap_cli -A "set qos eth0 directed multicast disable"

---- Command 'rkscli -c "set qos eth0 directed multicast disable "' executed at                                                                                                              ec:58:ea:36:6f:50

Directed Multicast ingress packet processing is Disabled on interface eth0 OK

---- Command 'rkscli -c "set qos eth0 directed multicast disable "' executed at                                                                                                              f0:3e:90:10:62:f0

Directed Multicast ingress packet processing is Disabled on interface eth0 OK

---- Command Execution Summary:

         success: 2

         failure: 0

           total: 2

remote_ap_cli "-A" ""set" "qos" "eth0" "directed" "multicast" "disable""

 

I hope this helps.


Photo of Adrian

Adrian

  • 6 Posts
  • 0 Reply Likes
Thanks for your replies guys, really helpful. Although we decided to go on a different route I will definitely try your method Logan in the office or on the next job.
Logan just out of curiosity are you from Habitech ?
Thanks   
Photo of Logan Taylor

Logan Taylor

  • 13 Posts
  • 3 Reply Likes
I am indeed, Im going with Alpha touch as a guess :)
Just signed up to the forums recently for stuff i needed help with.
Photo of Adrian

Adrian

  • 6 Posts
  • 0 Reply Likes
I thought your name was familiar, I remembered it because you dialed in on my laptop a couple of days ago to help me with a problem on site. Thanks for that by the way !