access port - tagged or untagged?

  • 1
  • Question
  • Updated 2 weeks ago
  • Answered
I want to set one port on my switch to vlan 20.  In doing so I am hoping the port will acquire an ip address from my vlan 20 dhcp scope.  It works fine on a cisco switch port as an access port.

My understanding is I need to set the port to untagged on vlan 20 but I get an error that the port in a dual-mode port.  What do I need to do to make this port get only vlan 20?  thanks.
Photo of Dave W

Dave W

  • 15 Posts
  • 2 Reply Likes
  • frustrated

Posted 2 weeks ago

  • 1
Photo of Dacvar

Dacvar

  • 9 Posts
  • 1 Reply Like
Hi Dave.


This Is hapening because the Port Is already Tagged in a VLAN AND Is also in dual mode.


Go to the interface configuration and do no dual-mode.

After that you can go to the VLAN configuration and add the Port as untagged.


Regards
(Edited)
Photo of Dave W

Dave W

  • 15 Posts
  • 2 Reply Likes
I did already try that - but i got the following message:
"error - port ethe 3/1/1 are not member of default vlan"
Photo of Dave W

Dave W

  • 15 Posts
  • 2 Reply Likes
port settings are as follows:

interface ethernet 3/1/1
 inline power power-limit 15400

Photo of Dacvar

Dacvar

  • 9 Posts
  • 1 Reply Like
Hi Dave,


That means that the Port 3/1/1 Is Tagged in a VLAN. You cant untag a Port un More than one VLAN so first you need to remove the Port from the VLAN.


With a show VLAN, you can check which porta are assigned to which vlans, Tagged or untagged.


Go to that VLAN and do "no tag eth 3/1/1" after it is removed. You can add it as untagged un the required VLAN.
(Edited)
Photo of Dave W

Dave W

  • 15 Posts
  • 2 Reply Likes
I got it to work with your help of course!  I did a sho vlan brief e 3/1/1 and it showed that it was still in the voice vlan 200.  Once I removed it from 200 and remove the dual-mode, I was able to "untagged" the port in vlan 20.  Thanks for your help.
Photo of Dacvar

Dacvar

  • 9 Posts
  • 1 Reply Like
I am glad I was able to help.

Pura Vida